mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
games/openspades: Added (Free multiplayer game).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
ca9b579315
commit
b3e29c4162
6 changed files with 178 additions and 0 deletions
7
games/openspades/README
Normal file
7
games/openspades/README
Normal file
|
@ -0,0 +1,7 @@
|
|||
OpenSpades is a clone of Voxlap Ace of Spades 0.75, which is a
|
||||
free multiplayer game created by Ben Aksoy.
|
||||
- ability to connect to vanilla/pyspades server
|
||||
- better performance on some modern computers/netbooks
|
||||
- sophisticated graphics
|
||||
- fully open source (GPLv3 compliant)
|
||||
- cross-platform
|
13
games/openspades/doinst.sh
Normal file
13
games/openspades/doinst.sh
Normal file
|
@ -0,0 +1,13 @@
|
|||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -x /usr/bin/update-mime-database ]; then
|
||||
/usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
|
||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
|
||||
fi
|
||||
fi
|
12
games/openspades/downloader.patch
Normal file
12
games/openspades/downloader.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- openspades-0.0.12/Resources/downloadpak.orig.sh 2015-03-18 04:27:00.876700540 +0200
|
||||
+++ openspades-0.0.12/Resources/downloadpak.sh 2015-03-18 04:27:37.619241195 +0200
|
||||
@@ -6,9 +6,4 @@
|
||||
PAK_NAME=$(basename "$PAK_URL")
|
||||
OUTPUT_DIR="DevPak"
|
||||
|
||||
-if [ -f "$PAK_NAME" ]; then
|
||||
- exit 0
|
||||
-fi
|
||||
-
|
||||
-wget "$PAK_URL" -O "$PAK_NAME"
|
||||
unzip -u -o "$PAK_NAME" -d "$OUTPUT_DIR"
|
115
games/openspades/openspades.SlackBuild
Normal file
115
games/openspades/openspades.SlackBuild
Normal file
|
@ -0,0 +1,115 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for openspades
|
||||
|
||||
# Copyright 2015 Dimitris Zlatanidis Orestiada, Greece
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=openspades
|
||||
VERSION=${VERSION:-0.0.12}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/v$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# copy develompent packs
|
||||
mkdir -p build/Resources
|
||||
cp $CWD/DevPaks27.zip build/Resources
|
||||
|
||||
# avoid download automatically development packs
|
||||
patch -p1 < $CWD/downloader.patch
|
||||
|
||||
# fix library path
|
||||
if [ "$ARCH" = "x86_64" ]; then
|
||||
sed -i "s/lib\/openspades/lib64\/openspades/" CMakeLists.txt
|
||||
fi
|
||||
|
||||
# fix doc and man path
|
||||
sed -i -e "s/share\/doc/doc/" -e "s/share\/man/man/" CMakeLists.txt
|
||||
|
||||
cd build
|
||||
cmake \
|
||||
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DOPENSPADES_RESDIR=/usr/share/openspades/Resources \
|
||||
-DOPENSPADES_INSTALL_RESOURCES=share/openspades/Resources \
|
||||
-DOPENSPADES_INSTALL_BINARY=bin \
|
||||
-DCMAKE_BUILD_TYPE=Release ..
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
cd ..
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
# remove unused
|
||||
rm -rf $PKG/usr/share/menu $PKG/usr/doc/openspades
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a AUTHORS ChangeLog README.md LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
12
games/openspades/openspades.info
Normal file
12
games/openspades/openspades.info
Normal file
|
@ -0,0 +1,12 @@
|
|||
PRGNAM="openspades"
|
||||
VERSION="0.0.12"
|
||||
HOMEPAGE="https://sites.google.com/a/yvt.jp/openspades/"
|
||||
DOWNLOAD="https://github.com/yvt/openspades/archive/v0.0.12.tar.gz \
|
||||
http://yvt.jp/files/programs/osppaks/DevPaks27.zip"
|
||||
MD5SUM="4f459b9e6c6243d2dd8983eb3752b4e4 \
|
||||
e193e1a1285268a54bd39216a3a6fcae"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="SDL2_image OpenAL"
|
||||
MAINTAINER="Dimitris Zlatanidis"
|
||||
EMAIL="d.zlatanidis@gmail.com"
|
19
games/openspades/slack-desc
Normal file
19
games/openspades/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description.
|
||||
# Line up the first '|' above the ':' following the base package name, and
|
||||
# the '|' on the right side marks the last column you can put a character in.
|
||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
openspades: openspades (Free multiplayer game)
|
||||
openspades:
|
||||
openspades: OpenSpades is a clone of Voxlap Ace of Spades 0.75, which is a free
|
||||
openspades: multiplayer game created by Ben Aksoy.
|
||||
openspades:
|
||||
openspades: Homepage: https://sites.google.com/a/yvt.jp/openspades
|
||||
openspades:
|
||||
openspades:
|
||||
openspades:
|
||||
openspades:
|
||||
openspades:
|
Loading…
Reference in a new issue