mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-20 19:41:34 +01:00
games/pushover: Build with lua51.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
9a13ba8cc4
commit
b3b7cd9459
3 changed files with 35 additions and 15 deletions
22
games/pushover/luajit.diff
Normal file
22
games/pushover/luajit.diff
Normal file
|
@ -0,0 +1,22 @@
|
|||
diff -Naur pushover-0.0.3/configure.ac pushover-0.0.3.patched/configure.ac
|
||||
--- pushover-0.0.3/configure.ac 2011-05-11 18:54:33.000000000 -0000
|
||||
+++ pushover-0.0.3.patched/configure.ac 2024-10-18 20:03:50.231244910 -0000
|
||||
@@ -35,8 +35,7 @@
|
||||
|
||||
# Checks for libraries.
|
||||
AC_MSG_CHECKING([for Lua package name])
|
||||
-PKG_CHECK_EXISTS([lua5.1], [LUA="lua5.1"],
|
||||
- [PKG_CHECK_EXISTS([lua-5.1], [LUA="lua-5.1"], [LUA="lua"])])
|
||||
+PKG_CHECK_EXISTS([luajit], [LUA="luajit"])
|
||||
AC_MSG_RESULT([$LUA])
|
||||
|
||||
PKG_CHECK_EXISTS([zlib], [ZLIB="zlib >= 1.2.3"],
|
||||
@@ -48,7 +47,7 @@
|
||||
PKG_CHECK_EXISTS([SDL_ttf], [SDL_TTF="SDL_ttf >= 2.0.0"],
|
||||
[AC_CHECK_LIB([SDL_ttf], [main], [], [AC_MSG_ERROR([Unable to find SDL_ttf.])])])
|
||||
|
||||
-PKG_CHECK_MODULES([DEPS], [$ZLIB libpng >= 1.2.40 sdl >= 1.2.0 $SDL_MIXER $SDL_TTF $LUA >= 5.1])
|
||||
+PKG_CHECK_MODULES([DEPS], [$ZLIB libpng >= 1.2.40 sdl >= 1.2.0 $SDL_MIXER $SDL_TTF $LUA >= 2.0])
|
||||
CPPFLAGS="$CPPFLAGS $DEPS_CFLAGS"
|
||||
LIBS="$LIBS $DEPS_LIBS"
|
||||
|
|
@ -22,11 +22,17 @@
|
|||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
# 20241018 bkw: Modified by SlackBuilds.org, BUILD=2:
|
||||
# - build with lua51.
|
||||
# - get INSTALL out of the doc dir.
|
||||
# - binary in /usr/games.
|
||||
# TODO: .desktop and icon.
|
||||
|
||||
cd $(dirname $0) ; CWD=$(pwd)
|
||||
|
||||
PRGNAM=pushover
|
||||
VERSION=${VERSION:-0.0.3}
|
||||
BUILD=${BUILD:-1}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
|
||||
|
@ -38,9 +44,6 @@ if [ -z "$ARCH" ]; then
|
|||
esac
|
||||
fi
|
||||
|
||||
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
||||
# the name of the created package would be, and then exit. This information
|
||||
# could be useful to other scripts.
|
||||
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
||||
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
|
||||
exit 0
|
||||
|
@ -74,11 +77,8 @@ rm -rf $PRGNAM-$VERSION
|
|||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
|
||||
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
|
@ -87,16 +87,14 @@ CXXFLAGS="$SLKCFLAGS" \
|
|||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||
--enable-shared \
|
||||
--bindir=/usr/games \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
make install-strip DESTDIR=$PKG
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a AUTHORS COPYING ChangeLog INSTALL NEWS README \
|
||||
cp -a AUTHORS COPYING ChangeLog NEWS README \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
|
|
|
@ -5,6 +5,6 @@ DOWNLOAD="http://attic-distfiles.pld-linux.org/distfiles/by-md5/8/3/831feec2d465
|
|||
MD5SUM="831feec2d46583db01647a73295d4108"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="lua"
|
||||
REQUIRES="lua51"
|
||||
MAINTAINER="MLanden"
|
||||
EMAIL="mlanden2009.home[AT]gmail.com"
|
||||
|
|
Loading…
Reference in a new issue