mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-20 19:41:34 +01:00
graphics/exact-image: Updated for version 0.8.2.
This commit is contained in:
parent
f2581bfdac
commit
b30abf75a5
6 changed files with 27 additions and 36 deletions
|
@ -1,9 +1,10 @@
|
|||
ExactImage is an image processing library which reimplements ImageMagick
|
||||
functions with a significant speed improvement. The library also provides
|
||||
several new algorithms: lossless JPEG transforms and creation of searchable
|
||||
PDFs from hOCR annotated HTML. There are bindings for PHP, Lua, Perl, and
|
||||
Python. See /usr/doc/exact-image-*/examples/ for information on using
|
||||
PDFs from hOCR annotated HTML created with an OCR program such as Tesseract or
|
||||
Cuneiform (available at Slackbuilds.org). There are bindings for PHP, Lua, Perl,
|
||||
and Python. See /usr/doc/exact-image-*/examples/ for information on using
|
||||
exactimage with Perl, Python, PHP and Lua.
|
||||
|
||||
This requires agg. lua and evas are optional dependencies, as is bardecode,
|
||||
but bardecode is not available from SlackBuilds.org.
|
||||
ExactImage requires agg. Lua and evas are optional dependencies available at
|
||||
Slackbuilds.org, while bardecode is optional but not available.
|
||||
|
|
|
@ -3,7 +3,7 @@
|
|||
# Written by Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
|
||||
|
||||
PRGNAM=exact-image
|
||||
VERSION=${VERSION:-0.8.1}
|
||||
VERSION=${VERSION:-0.8.2}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -52,9 +52,9 @@ find . \
|
|||
# Patch to fix libpng linkage
|
||||
patch -p1 --verbose < $CWD/png.cc-libpng14.diff
|
||||
|
||||
# Patch to fix python and perl paths
|
||||
# Patch to fix perl path
|
||||
eval $(perl -V:vendorlib)
|
||||
sed "s,@vendorlib@,$vendorlib,g" $CWD/fixup-python_and_perl_paths.diff | patch -p1
|
||||
sed "s,@vendorlib@,$vendorlib,g" $CWD/fixup-perl_paths.diff | patch -p1
|
||||
|
||||
./configure \
|
||||
--bindir=/usr/bin \
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="exact-image"
|
||||
VERSION="0.8.1"
|
||||
VERSION="0.8.2"
|
||||
HOMEPAGE="http://www.exactcode.de/site/open_source/exactimage/"
|
||||
DOWNLOAD="http://dl.exactcode.de/oss/exact-image/exact-image-0.8.1.tar.bz2"
|
||||
MD5SUM="f6c5a068a21a90c314ba557f0a601352"
|
||||
DOWNLOAD="http://dl.exactcode.de/oss/exact-image/exact-image-0.8.2.tar.bz2"
|
||||
MD5SUM="57df19be487307df1579b1f370c28e83"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Benjamin Trigona-Harany"
|
||||
EMAIL="bosth@alumni.sfu.ca"
|
||||
APPROVED="rworkman"
|
||||
APPROVED="Erik Hanson"
|
||||
|
|
12
graphics/exact-image/fixup-perl_paths.diff
Normal file
12
graphics/exact-image/fixup-perl_paths.diff
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -Nur exact-image-0.8.2.orig//api/perl/Makefile exact-image-0.8.2/api/perl/Makefile
|
||||
--- exact-image-0.8.2.orig//api/perl/Makefile 2008-12-09 03:42:19.000000000 -0600
|
||||
+++ exact-image-0.8.2/api/perl/Makefile 2010-06-23 08:57:13.015010261 -0500
|
||||
@@ -20,5 +20,6 @@
|
||||
all:: $($(X_MODULE)_BINARY)
|
||||
install:: $($(X_MODULE)_BINARY)
|
||||
$(Q)echo "INSTALL PERL module $^"
|
||||
- $(Q)mkdir -p $(DESTDIR)$(libdir)/perl5/site_perl/
|
||||
- $(Q)install $^ $(dir $^)/ExactImage.pm $(DESTDIR)$(libdir)/perl5/site_perl/
|
||||
+ eval `perl -V:vendorlib`
|
||||
+ $(Q)mkdir -p $(DESTDIR)@vendorlib@
|
||||
+ $(Q)install $^ $(dir $^)/ExactImage.pm $(DESTDIR)@vendorlib@
|
|
@ -1,22 +0,0 @@
|
|||
diff -Nur exact-image-0.8.1.orig//api/perl/Makefile exact-image-0.8.1/api/perl/Makefile
|
||||
--- exact-image-0.8.1.orig//api/perl/Makefile 2008-12-09 03:42:19.000000000 -0600
|
||||
+++ exact-image-0.8.1/api/perl/Makefile 2010-06-23 08:57:13.015010261 -0500
|
||||
@@ -20,5 +20,6 @@
|
||||
all:: $($(X_MODULE)_BINARY)
|
||||
install:: $($(X_MODULE)_BINARY)
|
||||
$(Q)echo "INSTALL PERL module $^"
|
||||
- $(Q)mkdir -p $(DESTDIR)$(libdir)/perl5/site_perl/
|
||||
- $(Q)install $^ $(dir $^)/ExactImage.pm $(DESTDIR)$(libdir)/perl5/site_perl/
|
||||
+ eval `perl -V:vendorlib`
|
||||
+ $(Q)mkdir -p $(DESTDIR)@vendorlib@
|
||||
+ $(Q)install $^ $(dir $^)/ExactImage.pm $(DESTDIR)@vendorlib@
|
||||
diff -Nur exact-image-0.8.1.orig//api/python/Makefile exact-image-0.8.1/api/python/Makefile
|
||||
--- exact-image-0.8.1.orig//api/python/Makefile 2010-04-05 10:28:40.000000000 -0500
|
||||
+++ exact-image-0.8.1/api/python/Makefile 2010-06-23 08:58:08.206169868 -0500
|
||||
@@ -20,5 +20,5 @@
|
||||
all:: $($(X_MODULE)_BINARY)
|
||||
install:: $($(X_MODULE)_BINARY)
|
||||
$(Q)echo "INSTALL PYTHON module $^"
|
||||
- $(Q)mkdir -p $(DESTDIR)$(libdir)/python2.5/site-packages/
|
||||
+ $(Q)mkdir -p $(DESTDIR)$(shell python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib()')
|
||||
$(Q)install $(dir $^)/ExactImage.py $^ $(DESTDIR)$(shell python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib()')/
|
|
@ -1,6 +1,6 @@
|
|||
diff -Naur exact-image-0.8.1-old/codecs/png.cc exact-image-0.8.1/codecs/png.cc
|
||||
--- exact-image-0.8.1-old/codecs/png.cc 2010-06-16 02:46:40.349543689 +0300
|
||||
+++ exact-image-0.8.1/codecs/png.cc 2010-06-16 02:57:50.156542917 +0300
|
||||
diff -Naur exact-image-0.8.2-old/codecs/png.cc exact-image-0.8.2/codecs/png.cc
|
||||
--- exact-image-0.8.2-old/codecs/png.cc 2010-06-16 02:46:40.349543689 +0300
|
||||
+++ exact-image-0.8.2/codecs/png.cc 2010-06-16 02:57:50.156542917 +0300
|
||||
@@ -71,7 +71,7 @@
|
||||
/* Allocate/initialize the memory for image information. REQUIRED. */
|
||||
info_ptr = png_create_info_struct(png_ptr);
|
||||
|
|
Loading…
Reference in a new issue