libraries/libsigrok: Added (logic analyzers access library).

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Andrzej Telszewski 2015-07-30 06:33:53 +07:00 committed by Willy Sudiarto Raharjo
parent c455e5f1c6
commit b2a1ad8a1a
5 changed files with 186 additions and 0 deletions

View file

@ -0,0 +1,20 @@
--- configure.ac 2014-05-06 23:01:43.000000000 +0200
+++ configure.ac.new 2015-07-24 17:08:46.795694956 +0200
@@ -317,7 +317,7 @@
# Serial port helper code is only compiled in if libserialport was found.
AM_CONDITIONAL(NEED_SERIAL, test "x$have_libserialport" != xno)
-PKG_CHECK_MODULES([librevisa], [librevisa >= 0.0.20130812],
+PKG_CHECK_MODULES([librevisa], [librevisa >= 0.0.20130412],
[have_librevisa="yes"; LIB_CFLAGS="$LIB_CFLAGS $librevisa_CFLAGS";
LIBS="$LIBS $librevisa_LIBS";
SR_PKGLIBS="$SR_PKGLIBS librevisa"],
@@ -599,7 +599,7 @@
echo
# Note: This only works for libs with pkg-config integration.
-for lib in "glib-2.0 >= 2.32.0" "libzip >= 0.10" "libserialport >= 0.1.0" "librevisa >= 0.0.20130812" "libusb-1.0 >= 1.0.16" "libftdi >= 0.16" "check >= 0.9.4"; do
+for lib in "glib-2.0 >= 2.32.0" "libzip >= 0.10" "libserialport >= 0.1.0" "librevisa >= 0.0.20130412" "libusb-1.0 >= 1.0.16" "libftdi >= 0.16" "check >= 0.9.4"; do
optional="OPTIONAL"
if test "x$lib" = "xglib-2.0 >= 2.32.0"; then optional="REQUIRED"; fi
if test "x$lib" = "xlibzip >= 0.10"; then optional="REQUIRED"; fi

View file

@ -0,0 +1,10 @@
libsigrok is a shared library written in C, which provides the basic
hardware access drivers for logic analyzers and other supported
devices, as well as input/output file format support.
NOTE:
Slackware's libusb is too old. Thus, to enable more hardware support,
build with LIBUSB=yes ./libsigrok.SlackBuild
Optional, but highly recommended dependencies are (available from SlackBuilds.org):
libftdi, librevisa and libserialport.

View file

@ -0,0 +1,125 @@
#!/bin/sh
# Slackware build script for libsigrok
# Copyright 2015 Andrzej Telszewski, Sabadell
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=libsigrok
VERSION=${VERSION:-0.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
LIBUSB_VERSION=${LIBUSB_VERSION:-1.0.19}
LIBUSB=${LIBUSB:-no}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Build libusb statically (based on qemu.SlackBuild).
if [ "$LIBUSB" = "yes" ]; then
tar xvf $CWD/libusb-$LIBUSB_VERSION.tar.bz2
cd libusb-$LIBUSB_VERSION
CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=$TMP/$PRGNAM-$VERSION/libusb-static \
--libdir=$TMP/$PRGNAM-$VERSION/libusb-static/lib \
--build=$ARCH-slackware-linux \
--disable-shared \
--enable-static
make
make install
cd ..
LIBUSB_PKG_CONFIG_PATH="$TMP/$PRGNAM-$VERSION/libusb-static/lib/pkgconfig:"
fi
# Check for librevisa >= 0.0.20130412 - the latest official release:
# http://comments.gmane.org/gmane.comp.debugging.sigrok.devel/1415
patch -p0 < $CWD/01-depend-on-librevisa-20130412.patch
aclocal
automake
autoconf
PKG_CONFIG_PATH="${LIBUSB_PKG_CONFIG_PATH}${PKG_CONFIG_PATH}" \
CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--build=$ARCH-slackware-linux \
--enable-shared \
--disable-static
make
make install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a contrib AUTHORS ChangeLog COPYING Doxyfile HACKING INSTALL NEWS README README.devices \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View file

@ -0,0 +1,12 @@
PRGNAM="libsigrok"
VERSION="0.3.0"
HOMEPAGE="http://sigrok.org/wiki/Libsigrok"
DOWNLOAD="http://sigrok.org/download/source/libsigrok/libsigrok-0.3.0.tar.gz \
http://downloads.sourceforge.net/libusb/libusb-1.0/libusb-1.0.19/libusb-1.0.19.tar.bz2"
MD5SUM="6bc9fa9da9b791b8da961003244adeec \
f9e2bb5879968467e5ca756cb4e1fa7e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="Andrzej Telszewski"
EMAIL="atelszewski@gmail.com"

View file

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description.
# Line up the first '|' above the ':' following the base package name, and
# the '|' on the right side marks the last column you can put a character in.
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
libsigrok: libsigrok (logic analyzers access library)
libsigrok:
libsigrok: libsigrok is a shared library written in C, which provides
libsigrok: the basic hardware access drivers for logic analyzers and other
libsigrok: supported devices, as well as input/output file format support.
libsigrok:
libsigrok:
libsigrok:
libsigrok:
libsigrok: Homepage: http://sigrok.org/wiki/Libsigrok
libsigrok: