mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
network/xombrero: Added (keyboard-centric web browser; formerly xxxterm)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
179e4ff91f
commit
b171e1b262
7 changed files with 201 additions and 0 deletions
29
network/xombrero/Makefile.patch
Normal file
29
network/xombrero/Makefile.patch
Normal file
|
@ -0,0 +1,29 @@
|
|||
--- Makefile 2012-11-28 11:23:15.000000000 -0700
|
||||
+++ Makefile.new 2013-02-08 10:21:31.839628119 -0700
|
||||
@@ -61,15 +61,21 @@
|
||||
install -m 755 -d $(DESTDIR)$(LIBDIR)
|
||||
install -m 755 -d $(DESTDIR)$(MANDIR)/man1
|
||||
install -m 755 -d $(DESTDIR)$(RESDIR)
|
||||
+ install -m 755 -d $(DESTDIR)$(PREFIX)/share/applications
|
||||
+ install -m 755 -d $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/16x16
|
||||
+ install -m 755 -d $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/32x32
|
||||
+ install -m 755 -d $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/48x48
|
||||
+ install -m 755 -d $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/64x64
|
||||
+ install -m 755 -d $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/128x128
|
||||
install -m 755 xombrero $(DESTDIR)$(BINDIR)
|
||||
install -m 644 ../xombrero.1 $(DESTDIR)$(MANDIR)/man1/xombrero.1
|
||||
install -m 644 ../xombrero.css $(DESTDIR)$(RESDIR)
|
||||
install -m 644 ../xombrero.desktop $(DESTDIR)$(PREFIX)/share/applications
|
||||
- install -m 644 ../xombreroicon16.png $(DESTDIR)$(RESDIR)
|
||||
- install -m 644 ../xombreroicon32.png $(DESTDIR)$(RESDIR)
|
||||
- install -m 644 ../xombreroicon48.png $(DESTDIR)$(RESDIR)
|
||||
- install -m 644 ../xombreroicon64.png $(DESTDIR)$(RESDIR)
|
||||
- install -m 644 ../xombreroicon128.png $(DESTDIR)$(RESDIR)
|
||||
+ install -m 644 ../xombreroicon16.png $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/16x16/xombrero.png
|
||||
+ install -m 644 ../xombreroicon32.png $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/32x32/xombrero.png
|
||||
+ install -m 644 ../xombreroicon48.png $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/48x48/xombrero.png
|
||||
+ install -m 644 ../xombreroicon64.png $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/64x64/xombrero.png
|
||||
+ install -m 644 ../xombreroicon128.png $(DESTDIR)$(PREFIX)/share/icons/hicolor/apps/128x128/xombrero.png
|
||||
install -m 644 ../tld-rules $(DESTDIR)$(RESDIR)
|
||||
install -m 644 ../style.css $(DESTDIR)$(RESDIR)
|
||||
install -m 644 ../hsts-preload $(DESTDIR)$(RESDIR)
|
9
network/xombrero/README
Normal file
9
network/xombrero/README
Normal file
|
@ -0,0 +1,9 @@
|
|||
xombrero (keyboard-centric web browser, formerly xxxterm)
|
||||
|
||||
xombrero is a minimalist web browser with sophisticated security
|
||||
features designed-in, rather than through an add-on after-the-fact.
|
||||
In particular, it provides both persistent and per-session controls
|
||||
for scripts and cookies.
|
||||
|
||||
In addition to providing a familiar mouse-based interface, it offers a
|
||||
set of vi-like keyboard commands for power-users.
|
9
network/xombrero/doinst.sh
Normal file
9
network/xombrero/doinst.sh
Normal file
|
@ -0,0 +1,9 @@
|
|||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
|
||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
|
||||
fi
|
||||
fi
|
19
network/xombrero/slack-desc
Normal file
19
network/xombrero/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description.
|
||||
# Line up the first '|' above the ':' following the base package name, and
|
||||
# the '|' on the right side marks the last column you can put a character in.
|
||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
xombrero: xombrero (keyboard-centric web browser, formerly xxxterm)
|
||||
xombrero:
|
||||
xombrero: xombrero is a minimalist web browser with sophisticated security
|
||||
xombrero: features designed-in, rather than through an add-on after-the-fact.
|
||||
xombrero: In particular, it provides both persistent and per-session controls
|
||||
xombrero: for scripts and cookies.
|
||||
xombrero:
|
||||
xombrero: In addition to providing a familiar mouse-based interface, it offers a
|
||||
xombrero: set of vi-like keyboard commands for power-users.
|
||||
xombrero:
|
||||
xombrero: Homepage: https://opensource.conformal.com/wiki/xombrero
|
113
network/xombrero/xombrero.SlackBuild
Normal file
113
network/xombrero/xombrero.SlackBuild
Normal file
|
@ -0,0 +1,113 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for xombrero
|
||||
|
||||
# Copyright 2013 Erik Falor, Utah, USA
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=xombrero
|
||||
VERSION=${VERSION:-1.4.0}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
# Automatically determine the architecture we're building on:
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
# Unless $ARCH is already set, use uname -m for all other archs:
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo} # For consistency's sake, use this
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp} # Drop the package in /tmp
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e # Exit on most errors
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tgz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# patch xombrero.h to not expect resources in /usr/local/share/xombrero
|
||||
# https://opensource.conformal.com/flyspray/index.php?do=details&task_id=372
|
||||
patch -i $CWD/xombrero.h.patch
|
||||
|
||||
# Hack Makefile so xombrero installs its icons and .desktop files in the right places
|
||||
# https://opensource.conformal.com/flyspray/index.php?do=details&task_id=410
|
||||
patch -d linux -i $CWD/Makefile.patch
|
||||
|
||||
# Compile the application and install it into the $PKG directory
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
PREFIX=/usr \
|
||||
MANDIR=/usr/man \
|
||||
DESTDIR="$PKG" \
|
||||
make -C linux install
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
|
||||
# Kill a spurrious directory
|
||||
rmdir $PKG/usr/lib
|
||||
|
||||
# Copy the .desktop file into usr/share/applications/,
|
||||
# massaging its icon property to match our desktop theme
|
||||
mkdir -p $PKG/usr/share/applications
|
||||
sed -i -e s/xombreroicon64.png/xombrero/ $PKG/usr/share/applications/xombrero.desktop
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
cat xombrero.conf > $PKG/usr/doc/$PRGNAM-$VERSION/xombrero.conf
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
11
network/xombrero/xombrero.h.patch
Normal file
11
network/xombrero/xombrero.h.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- xombrero.h 2012-11-28 11:23:15.000000000 -0700
|
||||
+++ xombrero.h.new 2013-02-08 12:49:32.000610834 -0700
|
||||
@@ -688,7 +688,7 @@
|
||||
#define XT_DS_ALLOW_INSECURE_CONTENT (TRUE)
|
||||
#define XT_DS_ALLOW_INSECURE_SCRIPTS (TRUE)
|
||||
#define XT_DS_WARN_CERT_CHANGES (0)
|
||||
-#define XT_DS_RESOURCE_DIR ("/usr/local/share/xombrero")
|
||||
+#define XT_DS_RESOURCE_DIR ("/usr/share/xombrero")
|
||||
#define XT_DS_DO_NOT_TRACK (0)
|
||||
#define XT_DS_PRELOAD_STRICT_TRANSPORT (1)
|
||||
#define XT_DS_GNUTLS_PRIORITY_STRING (NULL)
|
11
network/xombrero/xombrero.info
Normal file
11
network/xombrero/xombrero.info
Normal file
|
@ -0,0 +1,11 @@
|
|||
PRGNAM="xombrero"
|
||||
VERSION="1.4.0"
|
||||
HOMEPAGE="https://opensource.conformal.com/wiki/xombrero"
|
||||
DOWNLOAD="https://opensource.conformal.com/snapshots/xombrero/xombrero-1.4.0.tgz"
|
||||
MD5SUM="d5431623a7f5ac213adb1bcc0666f593"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="libbsd webkitgtk3"
|
||||
MAINTAINER="Erik Falor"
|
||||
EMAIL="ewfalor@gmail.com"
|
||||
|
Loading…
Reference in a new issue