libraries/opencv: Updated for version 3.4.3

Signed-off-by: Christoph Willing <chris.willing@linux.com>
This commit is contained in:
Christoph Willing 2018-08-31 09:14:39 +10:00
parent 9067f0a107
commit ad7bdcdbbe
4 changed files with 13 additions and 16 deletions

View file

@ -14,9 +14,8 @@ the feature set available in the resulting OpenCV package. The
additional optional packages will mostly be autodetected and used
at build time without any user intervention. Packages that are
processed in this way include (by SBo package name):
qt5 libdc1394 ffmpeg hdf5 VTK libwebp tesseract
glog apache-ant numpy python3 numpy3 OpenBLAS
openjdk8 (or openjdk or jdk)
qt5 libdc1394 ffmpeg hdf5 VTK libwebp tesseract glog
apache-ant numpy OpenBLAS openjdk8 (or openjdk or jdk)
In the unlikely situation that features from these packages are not
wanted despite already being installed on the host system,

View file

@ -26,8 +26,8 @@
PRGNAM=opencv
PRGNAM2=opencv_contrib
VERSION=${VERSION:-3.4.2}
BUILD=${BUILD:-2}
VERSION=${VERSION:-3.4.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PY2VERSION=${PY2VERSION:-2.7}

View file

@ -1,10 +1,10 @@
PRGNAM="opencv"
VERSION="3.4.2"
VERSION="3.4.3"
HOMEPAGE="https://opencv.org/"
DOWNLOAD="https://github.com/opencv/opencv/archive/3.4.2/opencv-3.4.2.tar.gz \
https://github.com/opencv/opencv_contrib/archive/3.4.2/opencv_contrib-3.4.2.tar.gz"
MD5SUM="8aba51c788cac3583bb39a0c24a5888f \
67b13857e0668b9e24be5ec6ae91ed48"
DOWNLOAD="https://github.com/opencv/opencv/archive/3.4.3/opencv-3.4.3.tar.gz \
https://github.com/opencv/opencv_contrib/archive/3.4.3/opencv_contrib-3.4.3.tar.gz"
MD5SUM="712896f5815938c014c199dde142d508 \
08340fb742d3c54184653091a1137927"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="numpy3"

View file

@ -1,5 +1,5 @@
--- CMakeLists.txt.orig 2018-07-04 21:05:47.000000000 +1000
+++ CMakeLists.txt 2018-07-12 21:54:32.406498966 +1000
--- CMakeLists.txt.orig 2018-08-28 22:58:21.000000000 +1000
+++ CMakeLists.txt 2018-08-31 07:58:34.745000000 +1000
@@ -374,7 +374,7 @@
if(ANDROID OR WIN32)
ocv_update(OPENCV_DOC_INSTALL_PATH doc)
@ -18,16 +18,14 @@
endif()
if(ANDROID)
@@ -445,18 +445,18 @@
ocv_update(OPENCV_CONFIG_INSTALL_PATH ".")
@@ -446,17 +446,17 @@
else()
include(GNUInstallDirs)
- ocv_update(OPENCV_LIB_INSTALL_PATH ${CMAKE_INSTALL_LIBDIR}${LIB_SUFFIX})
ocv_update(OPENCV_LIB_INSTALL_PATH ${CMAKE_INSTALL_LIBDIR}${LIB_SUFFIX})
- ocv_update(OPENCV_3P_LIB_INSTALL_PATH share/OpenCV/3rdparty/${OPENCV_LIB_INSTALL_PATH})
- ocv_update(OPENCV_SAMPLES_SRC_INSTALL_PATH share/OpenCV/samples)
- ocv_update(OPENCV_JAR_INSTALL_PATH share/OpenCV/java)
- ocv_update(OPENCV_OTHER_INSTALL_PATH share/OpenCV)
+ ocv_update(OPENCV_LIB_INSTALL_PATH ${CMAKE_INSTALL_LIBDIR})
+ ocv_update(OPENCV_3P_LIB_INSTALL_PATH share/opencv/3rdparty/${OPENCV_LIB_INSTALL_PATH})
+ ocv_update(OPENCV_SAMPLES_SRC_INSTALL_PATH share/opencv/samples)
+ ocv_update(OPENCV_JAR_INSTALL_PATH share/opencv/java)