mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-24 10:02:29 +01:00
network/gtorrentviewer: Make sure libm is linked
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
ac04695ab4
commit
ab44d415df
2 changed files with 16 additions and 1 deletions
|
@ -24,7 +24,7 @@
|
|||
|
||||
PRGNAM=gtorrentviewer
|
||||
VERSION=${VERSION:-0.2b}
|
||||
BUILD=${BUILD:-2}
|
||||
BUILD=${BUILD:-3}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -72,6 +72,9 @@ find . \
|
|||
# Fix building against newer cURL
|
||||
sed -i 's|#include <curl/types.h>||g' src/main.c
|
||||
|
||||
# Fix linking of libm
|
||||
patch -p1 < $CWD/patches/fix_linking_libm.diff
|
||||
|
||||
# The following 2 patches are from Fedora 13
|
||||
|
||||
# Let drag and drop work with URIs as well as files
|
||||
|
|
12
network/gtorrentviewer/patches/fix_linking_libm.diff
Normal file
12
network/gtorrentviewer/patches/fix_linking_libm.diff
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -Nur GTorrentViewer-0.2b.orig/src/Makefile.in GTorrentViewer-0.2b/src/Makefile.in
|
||||
--- GTorrentViewer-0.2b.orig/src/Makefile.in 2004-10-25 23:42:16.000000000 -0500
|
||||
+++ GTorrentViewer-0.2b/src/Makefile.in 2012-09-09 23:31:34.092115981 -0500
|
||||
@@ -115,7 +115,7 @@
|
||||
|
||||
CFLAGS = @CFLAGS@ @CURL_CFLAGS@ @GTK_CFLAGS@
|
||||
|
||||
-LDADD = @GTK_LIBS@ @CURL_LIBS@
|
||||
+LDADD = @GTK_LIBS@ @CURL_LIBS@ -lm
|
||||
|
||||
bin_PROGRAMS = gtorrentviewer
|
||||
|
Loading…
Reference in a new issue