academic/vcftools: Updated for version 0.1.12b.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Petar Petrov 2015-02-04 20:11:28 +07:00 committed by Willy Sudiarto Raharjo
parent 7b29b771ab
commit ab23379524
4 changed files with 15 additions and 32 deletions

View file

@ -1,19 +0,0 @@
Description: do not use MAKEFLAGS and not MANDIR
Author: Thorsten Alteholz <debian@alteholz.de>
Last-Update: 2014-04-03
Index: vcftools_0.1.12/Makefile
===================================================================
--- vcftools_0.1.12.orig/Makefile 2014-04-04 10:37:59.000000000 +0200
+++ vcftools_0.1.12/Makefile 2014-04-04 10:38:34.000000000 +0200
@@ -25,9 +25,8 @@
DIRS = cpp perl
install:
- @mkdir -p $(BINDIR); mkdir -p $(MODDIR); mkdir -p $(MANDIR); \
- cp ${PREFIX}/cpp/vcftools.1.gz $(MANDIR); \
- for dir in $(DIRS); do cd $$dir && $(MAKE) $(MAKEFLAGS) && cd ..; done
+ @mkdir -p $(BINDIR); mkdir -p $(MODDIR); \
+ for dir in $(DIRS); do cd $$dir && $(MAKE) && cd ..; done
clean:
@for dir in $(DIRS); do cd $$dir && $(MAKE) clean && cd ..; done

View file

@ -15,5 +15,5 @@ vcftools: VCF files: validating, merging, comparing and calculate some
vcftools: basic population genetic statistics.
vcftools:
vcftools: Home: http://vcftools.sourceforge.net/
vcftools: References: /usr/doc/vcftools-0.1.12a/References
vcftools: References: /usr/doc/vcftools-0.1.12b/References
vcftools:

View file

@ -2,7 +2,7 @@
# Slackware build script for vcftools
# Copyright 2013-2014 Petar Petrov, petar.petrov@student.oulu.fi
# Copyright 2013-2015 Petar Petrov, petar.petrov@student.oulu.fi
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=vcftools
VERSION=${VERSION:-0.1.12a}
VERSION=${VERSION:-0.1.12b}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -69,22 +69,21 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Thanks to Debian for the patches
patch -p1 -i $CWD/make.patch
# Thanks to Debian for the patch
patch -p1 -i $CWD/use-dpkg-buildflags.patch
# Set the proper, architecture-specific path
sed -i "s:/lib/perl5/site_perl:/lib${LIBDIRSUFFIX}/perl5:g" Makefile
# It seems that if you run just "make" as root, it will _install_ the
# executables and perl files before the package is even created...
CFLAGS="$SLKCFLAGS" \
CPPFLAGS="$SLKCFLAGS" \
PREFIX=$PKG/usr \
make install
# Copy man page
install -D -m644 cpp/vcftools.1.gz $PKG/usr/man/man1/vcftools.1.gz
# Remove this and copy the man page to its proper place
rm -rf $PKG/usr/bin/man1
mkdir -p $PKG//usr/man/man1
cp cpp/vcftools.1 $PKG/usr/man/man1
# Copy examples
mkdir -p $PKG/usr/share/$PRGNAM
@ -93,6 +92,9 @@ cp -a examples $PKG/usr/share/$PRGNAM
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README.txt perl/ChangeLog website/*.pdf $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

View file

@ -1,10 +1,10 @@
PRGNAM="vcftools"
VERSION="0.1.12a"
VERSION="0.1.12b"
HOMEPAGE="http://vcftools.sourceforge.net/"
DOWNLOAD="http://sourceforge.net/projects/vcftools/files/vcftools_0.1.12a.tar.gz"
MD5SUM="ca2ab768ed741623263dbe123cac428b"
DOWNLOAD="http://sourceforge.net/projects/vcftools/files/vcftools_0.1.12b.tar.gz"
MD5SUM="662758d1139c138cf5a0239ed99f12c2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
REQUIRES="tabix"
MAINTAINER="Petar Petrov"
EMAIL="petar.petrov@student.oulu.fi"