mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-24 10:02:29 +01:00
system/gnomint: Added (GUI for Certification Authorities).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
This commit is contained in:
parent
9ea447a1bb
commit
ab0b7a771e
8 changed files with 222 additions and 0 deletions
5
system/gnomint/README
Normal file
5
system/gnomint/README
Normal file
|
@ -0,0 +1,5 @@
|
|||
gnomint (certification authorities gui)
|
||||
|
||||
gnomint is a tool for an easy creation and management of Certification
|
||||
Authorities. It allows a fancy visualization of all the pieces that
|
||||
conform a CA: x509 certificates, CSRs, CRLs...
|
10
system/gnomint/doinst.sh
Normal file
10
system/gnomint/doinst.sh
Normal file
|
@ -0,0 +1,10 @@
|
|||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database &> /dev/null
|
||||
fi
|
||||
|
||||
if [ -x usr/bin/gconftool-2 ]; then
|
||||
( cd $PKG/etc/gconf/schemas
|
||||
GCONF_CONFIG_SOURCE="xml::etc/gconf/gconf.xml.defaults" \
|
||||
usr/bin/gconftool-2 --makefile-install-rule \
|
||||
etc/gconf/schemas/gnomint.schemas >/dev/null 2>&1 )
|
||||
fi
|
104
system/gnomint/gnomint.SlackBuild
Normal file
104
system/gnomint/gnomint.SlackBuild
Normal file
|
@ -0,0 +1,104 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for gnomint
|
||||
# Copyright Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy, 2012
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=gnomint
|
||||
VERSION=${VERSION:-1.2.1}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
DOCS="AUTHORS BUGS COPYING ChangeLog INSTALL MAINTAINERS NEWS README TODO"
|
||||
|
||||
set -e # Exit on most errors
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Apply two patches from Debian nd one from OpenSUSE (thanks a lot, fellas!)
|
||||
for i in $(ls $CWD/patches); do
|
||||
patch -p1 < $CWD/patches/$i
|
||||
done
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/man \
|
||||
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
10
system/gnomint/gnomint.info
Normal file
10
system/gnomint/gnomint.info
Normal file
|
@ -0,0 +1,10 @@
|
|||
PRGNAM="gnomint"
|
||||
VERSION="1.2.1"
|
||||
HOMEPAGE="http://sourceforge.net/projects/gnomint/"
|
||||
DOWNLOAD="http://downloads.sf.net/gnomint/gnomint-1.2.1.tar.gz"
|
||||
MD5SUM="f09f55abe094232fbea2a2d13ef600e6"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
MAINTAINER="Matteo Bernardini"
|
||||
EMAIL="ponce@slackbuilds.org"
|
14
system/gnomint/patches/01-ldd.patch
Normal file
14
system/gnomint/patches/01-ldd.patch
Normal file
|
@ -0,0 +1,14 @@
|
|||
Author: Daniel Baumann <daniel@debian.org>
|
||||
Description: Explicitly linking against libgcrypt.
|
||||
|
||||
diff -Naurp gnomint.orig/src/Makefile.in gnomint/src/Makefile.in
|
||||
--- gnomint.orig/src/Makefile.in 2011-05-17 19:57:50.013883380 +0200
|
||||
+++ gnomint/src/Makefile.in 2011-05-17 19:57:37.209981808 +0200
|
||||
@@ -347,6 +347,7 @@ gnomint_cli_SOURCES = \
|
||||
|
||||
gnomint_cli_LDADD = \
|
||||
$(GNOMINTCLI_LIBS) \
|
||||
+ $(LIBGCRYPT_LIBS) \
|
||||
$(LIBGNUTLS_LIBS) \
|
||||
$(SQLITE_LIBS) \
|
||||
$(READLINE_LIBS) \
|
28
system/gnomint/patches/02-cflags.patch
Normal file
28
system/gnomint/patches/02-cflags.patch
Normal file
|
@ -0,0 +1,28 @@
|
|||
Author: Daniel Baumann <daniel@debian.org>
|
||||
Description:
|
||||
Don't hardcode CFLAGS and respect the environemnt (Closes: #634395).
|
||||
|
||||
diff -Naurp gnomint.orig/configure gnomint/configure
|
||||
--- gnomint.orig/configure 2011-09-08 07:58:09.324752523 +0000
|
||||
+++ gnomint/configure 2011-09-08 07:59:20.113103539 +0000
|
||||
@@ -14338,7 +14338,7 @@ fi
|
||||
|
||||
|
||||
if test "x$GCC" = "xyes"; then
|
||||
- CFLAGS="-Wall -Werror"
|
||||
+ CFLAGS="${CFLAGS:--Wall -Werror}"
|
||||
if test "x$use_debug" = "xYes"; then
|
||||
CFLAGS="$CFLAGS -g -O0"
|
||||
fi
|
||||
diff -Naurp gnomint.orig/configure.in gnomint/configure.in
|
||||
--- gnomint.orig/configure.in 2011-09-08 07:58:09.328752536 +0000
|
||||
+++ gnomint/configure.in 2011-09-08 07:59:20.113103539 +0000
|
||||
@@ -181,7 +181,7 @@ dnl
|
||||
|
||||
dnl
|
||||
if test "x$GCC" = "xyes"; then
|
||||
- CFLAGS="-Wall -Werror"
|
||||
+ CFLAGS="${CFLAGS:--Wall -Werror}"
|
||||
if test "x$use_debug" = "xYes"; then
|
||||
CFLAGS="$CFLAGS -g -O0"
|
||||
fi
|
31
system/gnomint/patches/gnutls3.patch
Normal file
31
system/gnomint/patches/gnutls3.patch
Normal file
|
@ -0,0 +1,31 @@
|
|||
diff -aur a/src/import.c b/src/import.c
|
||||
--- a/src/import.c 2010-05-31 23:01:37.000000000 +0200
|
||||
+++ b/src/import.c 2012-06-27 17:50:06.993671796 +0200
|
||||
@@ -695,7 +695,7 @@
|
||||
|
||||
// After having all the parts unencrypted, we import all certificates first.
|
||||
for (i=0; i<n_bags; i++) {
|
||||
- gnutls_pkcs12_bag * pkcs12_bag = g_array_index (pkcs_bag_array, gnutls_pkcs12_bag_t *, i);
|
||||
+ gnutls_pkcs12_bag_t * pkcs12_bag = g_array_index (pkcs_bag_array, gnutls_pkcs12_bag_t *, i);
|
||||
guint num_elements_in_bag = gnutls_pkcs12_bag_get_count (*pkcs12_bag);
|
||||
|
||||
for (i=0; i < num_elements_in_bag; i++) {
|
||||
@@ -722,7 +722,7 @@
|
||||
|
||||
// Then, we import all PKCS8 private keys.
|
||||
for (i=0; i<n_bags; i++) {
|
||||
- gnutls_pkcs12_bag * pkcs12_bag = g_array_index (pkcs_bag_array, gnutls_pkcs12_bag_t *, i);
|
||||
+ gnutls_pkcs12_bag_t * pkcs12_bag = g_array_index (pkcs_bag_array, gnutls_pkcs12_bag_t *, i);
|
||||
guint num_elements_in_bag = gnutls_pkcs12_bag_get_count (*pkcs12_bag);
|
||||
|
||||
for (i=0; i < num_elements_in_bag; i++) {
|
||||
@@ -796,7 +796,7 @@
|
||||
// Then we import the CRLs
|
||||
|
||||
for (i=0; i<n_bags; i++) {
|
||||
- gnutls_pkcs12_bag * pkcs12_bag = g_array_index (pkcs_bag_array, gnutls_pkcs12_bag_t *, i);
|
||||
+ gnutls_pkcs12_bag_t * pkcs12_bag = g_array_index (pkcs_bag_array, gnutls_pkcs12_bag_t *, i);
|
||||
guint num_elements_in_bag = gnutls_pkcs12_bag_get_count (*pkcs12_bag);
|
||||
|
||||
for (i=0; i < num_elements_in_bag; i++) {
|
||||
Nur in b/src: import.c~.
|
20
system/gnomint/slack-desc
Normal file
20
system/gnomint/slack-desc
Normal file
|
@ -0,0 +1,20 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|'
|
||||
# on the right side marks the last column you can put a character in. You must
|
||||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
gnomint: gnomint (certification authorities gui)
|
||||
gnomint:
|
||||
gnomint: gnomint is a tool for an easy creation and management of Certification
|
||||
gnomint: Authorities. It allows a fancy visualization of all the pieces that
|
||||
gnomint: conform a CA: x509 certificates, CSRs, CRLs...
|
||||
gnomint:
|
||||
gnomint: homepage: http://sourceforge.net/projects/gnomint/
|
||||
gnomint:
|
||||
gnomint:
|
||||
gnomint:
|
||||
gnomint:
|
||||
|
Loading…
Reference in a new issue