mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
office/LibreOffice: Updated for version 7.4.2.3
Signed-off-by: Christoph Willing <chris.willing@linux.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
15348c732f
commit
aae988ef83
5 changed files with 6 additions and 107 deletions
|
@ -28,7 +28,7 @@ cd $(dirname $0) ; CWD=$(pwd)
|
|||
|
||||
PRGNAM=LibreOffice
|
||||
SRCNAM=libreoffice
|
||||
VERSION=${VERSION:-7.4.1.2}
|
||||
VERSION=${VERSION:-7.4.2.3}
|
||||
SHORT_VERSION=${VERSION%.*.*}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
@ -292,9 +292,6 @@ if [ "$HAVE_SRCS_TARBALL" = "0" ]; then
|
|||
fi
|
||||
|
||||
patch -p0 < $CWD/no-check-if-root.diff
|
||||
#patch -p0 < $CWD/skia-freetype-2.11.diff
|
||||
#patch -p0 < $CWD/bison_yyn-yyrule_rename.diff
|
||||
patch -p1 < $CWD/libreoffice-7.4.0.3-poppler_22_09_fixes-1.patch
|
||||
|
||||
# GCC10 requirements (Tx alienBOB)
|
||||
sed -i external/libebook/ExternalProject_libebook.mk \
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="LibreOffice"
|
||||
VERSION="7.4.1.2"
|
||||
VERSION="7.4.2.3"
|
||||
HOMEPAGE="https://www.libreoffice.org"
|
||||
DOWNLOAD="https://download.documentfoundation.org/libreoffice/src/7.4.1/libreoffice-7.4.1.2.tar.xz \
|
||||
https://sourceforge.net/projects/slackbuildsdirectlinks/files/LibreOffice/libreoffice-7.4.1.2-srcs.tar.xz"
|
||||
MD5SUM="2fb28cbd5a436e05fccf3b73ca77e6ed \
|
||||
bb2e0ad08305f80d4c8df4123ea07149"
|
||||
DOWNLOAD="https://download.documentfoundation.org/libreoffice/src/7.4.2/libreoffice-7.4.2.3.tar.xz \
|
||||
https://sourceforge.net/projects/slackbuildsdirectlinks/files/LibreOffice/libreoffice-7.4.2.3-srcs.tar.xz"
|
||||
MD5SUM="aeb1fba3a91cf2edd580f7acf3ac66c6 \
|
||||
4b020d96f8d28b0b16bf4ddcc853ae82"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="zulu-openjdk11 apache-ant perl-Archive-Zip"
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
--- connectivity/source/parse/sqlbison.y.orig 2021-09-18 13:35:17.897000000 +1000
|
||||
+++ connectivity/source/parse/sqlbison.y 2021-09-18 13:32:58.864000000 +1000
|
||||
@@ -74,9 +74,15 @@
|
||||
|
||||
// yyi is the internal number of the rule that is currently being reduced
|
||||
// This can be mapped to external rule number via the yyrmap.
|
||||
+#if defined YYBISON && YYBISON >= 30800
|
||||
+#define SQL_NEW_RULE newNode("", SQLNodeType::Rule, yyr1[yyrule])
|
||||
+#define SQL_NEW_LISTRULE newNode("", SQLNodeType::ListRule, yyr1[yyrule])
|
||||
+#define SQL_NEW_COMMALISTRULE newNode("", SQLNodeType::CommaListRule, yyr1[yyrule])
|
||||
+#else
|
||||
#define SQL_NEW_RULE newNode("", SQLNodeType::Rule, yyr1[yyn])
|
||||
#define SQL_NEW_LISTRULE newNode("", SQLNodeType::ListRule, yyr1[yyn])
|
||||
#define SQL_NEW_COMMALISTRULE newNode("", SQLNodeType::CommaListRule, yyr1[yyn])
|
||||
+#endif
|
||||
|
||||
|
||||
extern connectivity::OSQLParser* xxx_pGLOBAL_SQLPARSER;
|
|
@ -1,29 +0,0 @@
|
|||
Submitted By: Douglas R. Reno <renodr at linuxfromscratch dot org>
|
||||
Date: 2022-09-03
|
||||
Initial Package Version: 7.4.0.3
|
||||
Origin: Gentoo (commit 3fe3e0dc873e97eb1bb5ccb2846fffee35182caa in gentoo.git)
|
||||
Upstream Status: Submitted
|
||||
Description: Adapts libreoffice-7.4.0.3 to changes in Poppler's API,
|
||||
similar to Inkscape's poppler-22.09 patch.
|
||||
|
||||
diff -Naurp libreoffice-7.4.0.3.orig/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx libreoffice-7.4.0.3/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
|
||||
--- libreoffice-7.4.0.3.orig/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx 2022-08-10 09:14:32.000000000 -0500
|
||||
+++ libreoffice-7.4.0.3/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx 2022-09-03 10:39:04.244841138 -0500
|
||||
@@ -678,8 +678,16 @@ void PDFOutDev::updateLineDash(GfxState
|
||||
return;
|
||||
assert(state);
|
||||
|
||||
- double* dashArray; int arrayLen; double startOffset;
|
||||
+ int arrayLen; double startOffset;
|
||||
+#if POPPLER_CHECK_VERSION(22, 9, 0)
|
||||
+ const double* dashArray;
|
||||
+ const std::vector<double> &dash = state->getLineDash(&startOffset);
|
||||
+ dashArray = dash.data();
|
||||
+ arrayLen = dash.size();
|
||||
+#else
|
||||
+ double* dashArray;
|
||||
state->getLineDash(&dashArray, &arrayLen, &startOffset);
|
||||
+#endif
|
||||
|
||||
printf( "updateLineDash" );
|
||||
if( arrayLen && dashArray )
|
|
@ -1,51 +0,0 @@
|
|||
--- external/skia/UnpackedTarball_skia.mk.orig 2021-08-23 22:03:48.538000000 +1000
|
||||
+++ external/skia/UnpackedTarball_skia.mk 2021-08-23 22:04:58.137000000 +1000
|
||||
@@ -39,6 +39,7 @@
|
||||
fast-png-write.patch.1 \
|
||||
skia_sk_cpu_sse_level_0_by_default.patch.1 \
|
||||
fix-warnings.patch.1 \
|
||||
+ skia_freetype-2.11.patch.0 \
|
||||
|
||||
$(eval $(call gb_UnpackedTarball_set_patchlevel,skia,1))
|
||||
|
||||
--- /dev/null 2021-08-23 17:37:05.741000000 +1000
|
||||
+++ external/skia/skia_freetype-2.11.patch.0 2021-08-23 22:01:05.176000000 +1000
|
||||
@@ -0,0 +1,38 @@
|
||||
+--- src/ports/SkFontHost_FreeType_common.cpp.orig 2021-03-02 00:53:09.178606791 +1000
|
||||
++++ src/ports/SkFontHost_FreeType_common.cpp 2021-08-23 21:58:57.678000000 +1000
|
||||
+@@ -665,8 +665,13 @@
|
||||
+ canvas->drawPaint(paint);
|
||||
+ break;
|
||||
+ }
|
||||
++#ifdef FREETYPE_MAJOR == 2 && FREETYPE_MINOR >= 11
|
||||
++ case FT_COLR_PAINTFORMAT_TRANSFORM: {
|
||||
++ SkMatrix transform = ToSkMatrix(colrv1_paint.u.transform.affine);
|
||||
++#else
|
||||
+ case FT_COLR_PAINTFORMAT_TRANSFORMED: {
|
||||
+ SkMatrix transform = ToSkMatrix(colrv1_paint.u.transformed.affine);
|
||||
++#endif
|
||||
+
|
||||
+ canvas->concat(transform);
|
||||
+ break;
|
||||
+@@ -760,12 +765,21 @@
|
||||
+ traverse_result = colrv1_start_glyph(canvas, palette, face, paint.u.colr_glyph.glyphID,
|
||||
+ FT_COLOR_NO_ROOT_TRANSFORM);
|
||||
+ break;
|
||||
++#ifdef FREETYPE_MAJOR == 2 && FREETYPE_MINOR >= 11
|
||||
++ case FT_COLR_PAINTFORMAT_TRANSFORM:
|
||||
++ canvas->saveLayer(nullptr, nullptr);
|
||||
++ // Traverse / draw operation will apply transform.
|
||||
++ colrv1_draw_paint(canvas, palette, face, paint);
|
||||
++ traverse_result =
|
||||
++ colrv1_traverse_paint(canvas, palette, face, paint.u.transform.paint);
|
||||
++#else
|
||||
+ case FT_COLR_PAINTFORMAT_TRANSFORMED:
|
||||
+ canvas->saveLayer(nullptr, nullptr);
|
||||
+ // Traverse / draw operation will apply transform.
|
||||
+ colrv1_draw_paint(canvas, palette, face, paint);
|
||||
+ traverse_result =
|
||||
+ colrv1_traverse_paint(canvas, palette, face, paint.u.transformed.paint);
|
||||
++#endif
|
||||
+ canvas->restore();
|
||||
+ break;
|
||||
+ case FT_COLR_PAINTFORMAT_ROTATE:
|
Loading…
Reference in a new issue