mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-04 20:29:09 +01:00
system/ansible: Updated for version 1.7.2.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
360f749b9a
commit
aa4e553cdd
5 changed files with 22 additions and 94 deletions
|
@ -1,55 +0,0 @@
|
|||
--- a/Makefile 2013-07-05 14:59:24.000000000 +0200
|
||||
+++ b/Makefile 2013-07-05 15:01:21.000000000 +0200
|
||||
@@ -21,34 +21,13 @@
|
||||
# This doesn't evaluate until it's called. The -D argument is the
|
||||
# directory of the target file ($@), kinda like `dirname`.
|
||||
MANPAGES := docs/man/man1/ansible.1 docs/man/man1/ansible-playbook.1 docs/man/man1/ansible-pull.1 docs/man/man1/ansible-doc.1
|
||||
-ifneq ($(shell which a2x 2>/dev/null),)
|
||||
-ASCII2MAN = a2x -D $(dir $@) -d manpage -f manpage $<
|
||||
-ASCII2HTMLMAN = a2x -D docs/html/man/ -d manpage -f xhtml
|
||||
-else
|
||||
-ASCII2MAN = @echo "ERROR: AsciiDoc 'a2x' command is not installed but is required to build $(MANPAGES)" && exit 1
|
||||
-endif
|
||||
|
||||
-PYTHON=python
|
||||
+PYTHON=python2
|
||||
SITELIB = $(shell $(PYTHON) -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
|
||||
|
||||
# VERSION file provides one place to update the software version
|
||||
VERSION := $(shell cat VERSION)
|
||||
|
||||
-# Get the branch information from git
|
||||
-ifneq ($(shell which git),)
|
||||
-GIT_DATE := $(shell git log -n 1 --format="%ai")
|
||||
-endif
|
||||
-
|
||||
-ifeq ($(OS), FreeBSD)
|
||||
-DATE := $(shell date -j -f "%Y-%m-%d %H:%M:%s" "$(GIT_DATE)" +%Y%m%d%H%M)
|
||||
-else
|
||||
-ifeq ($(OS), Darwin)
|
||||
-DATE := $(shell date -j -f "%Y-%m-%d %H:%M:%S" "$(GIT_DATE)" +%Y%m%d%H%M)
|
||||
-else
|
||||
-DATE := $(shell date --utc --date="$(GIT_DATE)" +%Y%m%d%H%M)
|
||||
-endif
|
||||
-endif
|
||||
-
|
||||
# RPM build parameters
|
||||
RPMSPECDIR= packaging/rpm
|
||||
RPMSPEC = $(RPMSPECDIR)/ansible.spec
|
||||
@@ -74,16 +53,6 @@
|
||||
authors:
|
||||
sh hacking/authors.sh
|
||||
|
||||
-# Regenerate %.1.asciidoc if %.1.asciidoc.in has been modified more
|
||||
-# recently than %.1.asciidoc.
|
||||
-%.1.asciidoc: %.1.asciidoc.in
|
||||
- sed "s/%VERSION%/$(VERSION)/" $< > $@
|
||||
-
|
||||
-# Regenerate %.1 if %.1.asciidoc or VERSION has been modified more
|
||||
-# recently than %.1. (Implicitly runs the %.1.asciidoc recipe)
|
||||
-%.1: %.1.asciidoc VERSION
|
||||
- $(ASCII2MAN)
|
||||
-
|
||||
loc:
|
||||
sloccount lib library bin
|
||||
|
|
@ -4,10 +4,4 @@ A radically simple, model-driven orchestration solution that automates
|
|||
configuration, software deployment, and other IT needs.
|
||||
|
||||
It comes as an easy-to-use and powerful alternative to infrastructure
|
||||
management tools such as CFEngine, Chef, Puppet and SaltStack.
|
||||
|
||||
*NOTE* that as the source tarball is hosted by github (nodeload), its filename
|
||||
will vary depending on the download method. The filename may be "release1.2"
|
||||
when downloaded via wget/curl or it may be "ansible-ansible-v1.2-*.tar.gz"
|
||||
when downloaded via a browser. Any other form will not be accounted for, as
|
||||
the SlackBuild script is set to handle only those two filename patterns.
|
||||
management tools such as CFEngine, Chef, Puppet, and SaltStack.
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for ansible
|
||||
|
||||
# Copyright 2013 Alex Diaconu <alex.diaconu@gmx.com>
|
||||
# Copyright 2014 Alex Diaconu <alex.diaconu@gmx.com>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -23,7 +23,7 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=ansible
|
||||
VERSION=${VERSION:-1.2.1}
|
||||
VERSION=${VERSION:-1.7.2}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -67,44 +67,33 @@ find -L . \
|
|||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
patch -p1 < $CWD/Makefile.patch
|
||||
python setup.py install --root=$PKG
|
||||
|
||||
make docs
|
||||
python setup.py install $SLKFLAGS --root=$PKG
|
||||
|
||||
# Copy and compress manpages
|
||||
# We don't need these, do we?
|
||||
rm -r docs/man/man1/*asciidoc.in
|
||||
|
||||
# Copy docs, remove git traces, compress manpages
|
||||
cp -a docs/man $PKG/usr/man
|
||||
find $PKG/usr/man \
|
||||
\( -iname '.git*' \
|
||||
-o -iname 'man3' \) -delete # "man3" contains a single ".gitdir" file (yeah)
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
|
||||
# Remove git remnants
|
||||
find $PKG/usr/man -iname '.git*' -delete
|
||||
|
||||
# Remove redundant executable perms granted to some modules
|
||||
# 15 files (modules) out of 248 have their executable bit activated, while none
|
||||
# of them seems to require it. The command that follows simply assumes that
|
||||
# those files escaped upstream scrutiny and simply removes the executable
|
||||
# permissions.
|
||||
find $PKG/usr/share/ansible -type f -perm /111 -exec chmod -x {} \;
|
||||
|
||||
# Fix plugin paths and also remove the duplicated 'library' and 'hostfile' settings
|
||||
orig_path="/usr/share/ansible_plugins"
|
||||
site_packages="$(python2 -c 'from distutils.sysconfig import get_python_lib; print get_python_lib();')/ansible"
|
||||
plug_pat='(action|filter|connection|lookup)'
|
||||
sed -i -r \
|
||||
-e "s:$orig_path/${plug_pat}_plugins:$site_packages/runner/\1_plugins:" \
|
||||
-e "s:$orig_path/callback_plugins:$site_packages/callback_plugins:" \
|
||||
-e "s:$orig_path/vars_plugins:$site_packages/inventory/vars_plugins:" \
|
||||
-e "7,12d" \
|
||||
examples/ansible.cfg
|
||||
|
||||
mkdir -p $PKG/etc/ansible
|
||||
cp -a examples/ansible.cfg $PKG/etc/ansible/ansible.cfg.new
|
||||
cp -a examples/hosts $PKG/etc/ansible/hosts.new
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a \
|
||||
examples COPYING RELEASES.txt *.md \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a examples COPYING *.md $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="ansible"
|
||||
VERSION="1.2.1"
|
||||
HOMEPAGE="http://ansible.cc"
|
||||
DOWNLOAD="http://ponce.cc/slackware/sources/repo/ansible-1.2.1.tar.xz"
|
||||
MD5SUM="b77aa517fd1917324de178056aaab90a"
|
||||
VERSION="1.7.2"
|
||||
HOMEPAGE="http://ansible.com"
|
||||
DOWNLOAD="http://releases.ansible.com/ansible/ansible-1.7.2.tar.gz"
|
||||
MD5SUM="6c9112a2e7d7d1394c97e57290fc13be"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="paramiko PyYAML Jinja2"
|
||||
REQUIRES="paramiko PyYAML Jinja2 httplib2"
|
||||
MAINTAINER="Alex Diaconu"
|
||||
EMAIL="alex.diaconu@gmx.com"
|
||||
|
|
|
@ -11,7 +11,7 @@ ansible:
|
|||
ansible: A radically simple, model-driven orchestration solution that
|
||||
ansible: automates configuration, software deployment, and other IT needs.
|
||||
ansible:
|
||||
ansible: Homepage: http://ansible.cc
|
||||
ansible: Homepage: http://ansible.com
|
||||
ansible:
|
||||
ansible:
|
||||
ansible:
|
||||
|
|
Loading…
Reference in a new issue