mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
libraries/AMD: Updated for version 2.3.1.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
b312365c1c
commit
a9ed977d47
3 changed files with 79 additions and 37 deletions
|
@ -1,10 +1,29 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for AMD
|
||||
# Written by Kyle Guinn <elyk03@gmail.com>
|
||||
|
||||
# Copyright 2013 Kyle Guinn <elyk03@gmail.com>, USA
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=AMD
|
||||
VERSION=${VERSION:-2.2.2}
|
||||
VERSION=${VERSION:-2.3.1}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -70,9 +89,11 @@ FFLAGS="$SLKCFLAGS" \
|
|||
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||
--enable-shared \
|
||||
--disable-static \
|
||||
--disable-dependency-tracking \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
make
|
||||
make check
|
||||
make install-strip DESTDIR=$PKG
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="AMD"
|
||||
VERSION="2.2.2"
|
||||
HOMEPAGE="http://www.cise.ufl.edu/research/sparse/amd/"
|
||||
DOWNLOAD="http://www.cise.ufl.edu/research/sparse/amd/AMD-2.2.2.tar.gz"
|
||||
MD5SUM="76b870aaf5c98eb34579467dfed38b19"
|
||||
VERSION="2.3.1"
|
||||
HOMEPAGE="https://www.cise.ufl.edu/research/sparse/amd/"
|
||||
DOWNLOAD="https://www.cise.ufl.edu/research/sparse/amd/AMD-2.3.1.tar.gz"
|
||||
MD5SUM="ee402611aa672257752611cfac10d7cd"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="UFconfig"
|
||||
REQUIRES="SuiteSparse_config"
|
||||
MAINTAINER="Kyle Guinn"
|
||||
EMAIL="elyk03@gmail.com"
|
||||
|
|
|
@ -2,8 +2,8 @@ diff --git a/Demo/Makefile.am b/Demo/Makefile.am
|
|||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/Demo/Makefile.am
|
||||
@@ -0,0 +1,54 @@
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/Include $(UFCONFIG_CFLAGS)
|
||||
@@ -0,0 +1,53 @@
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/Include $(SUITESPARSECONFIG_CFLAGS)
|
||||
+LDADD = $(top_builddir)/Source/libamd.la
|
||||
+
|
||||
+EXTRA_DIST = \
|
||||
|
@ -48,39 +48,51 @@ new file mode 100644
|
|||
+ @for i in $(check_PROGRAMS); do \
|
||||
+ echo "Testing $$i"; \
|
||||
+ ./$$i$(EXEEXT) > my_$$i.out; \
|
||||
+ if diff -u $$i.out my_$$i.out; then \
|
||||
+ if diff -u $(srcdir)/$$i.out my_$$i.out; then \
|
||||
+ echo "Test $$i PASSED."; \
|
||||
+ else \
|
||||
+ echo "Test $$i FAILED."; \
|
||||
+ fi; \
|
||||
+ done
|
||||
+
|
||||
+clean-local:
|
||||
+ -$(RM) my_*.out
|
||||
+CLEANFILES = my_*.out
|
||||
diff --git a/Doc/Makefile.am b/Doc/Makefile.am
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/Doc/Makefile.am
|
||||
@@ -0,0 +1,13 @@
|
||||
@@ -0,0 +1,27 @@
|
||||
+EXTRA_DIST = ChangeLog License lesser.txt
|
||||
+
|
||||
+dist_noinst_DATA = AMD_UserGuide.tex AMD_UserGuide.bib
|
||||
+pdf_DATA = AMD_UserGuide.pdf
|
||||
+dist_pdf_DATA = AMD_UserGuide.pdf
|
||||
+
|
||||
+%.pdf: %.tex %.bib
|
||||
+ pdflatex $*
|
||||
+ bibtex $*
|
||||
+ pdflatex $*
|
||||
+ pdflatex $*
|
||||
+AMD_UserGuide.pdf AMD_UserGuide.aux: amd_h.tex
|
||||
+.INTERMEDIATE: AMD_UserGuide.aux amd_h.tex
|
||||
+
|
||||
+clean-local:
|
||||
+ -$(RM) *.aux *.bbl *.blg *.log *.toc
|
||||
+%_h.tex: $(top_srcdir)/Include/%.h
|
||||
+ echo '\begin{verbatim}' > $@
|
||||
+ expand -8 $< >> $@
|
||||
+ echo '\end{verbatim}' >> $@
|
||||
+
|
||||
+TEX = TEXINPUTS="$(srcdir):" pdflatex -interaction nonstopmode -file-line-error
|
||||
+BIB = BIBINPUTS="$(srcdir):" bibtex
|
||||
+%.pdf: %.tex %.bbl
|
||||
+ $(TEX) $*
|
||||
+ while grep -q "Rerun to get cross-references right" $*.log; do \
|
||||
+ $(TEX) $*; \
|
||||
+ done
|
||||
+%.bbl: %.aux %.bib
|
||||
+ $(BIB) $*
|
||||
+%.aux: %.tex
|
||||
+ $(TEX) $*
|
||||
+
|
||||
+CLEANFILES = *.aux *.bbl *.blg *.log *.toc *_h.tex
|
||||
+MAINTAINERCLEANFILES = $(dist_pdf_DATA)
|
||||
diff --git a/Include/Makefile.am b/Include/Makefile.am
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/Include/Makefile.am
|
||||
@@ -0,0 +1,2 @@
|
||||
+pkgincludedir = $(includedir)/amd
|
||||
@@ -0,0 +1 @@
|
||||
+pkginclude_HEADERS = amd.h amd_internal.h
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
new file mode 100644
|
||||
|
@ -97,7 +109,7 @@ new file mode 100644
|
|||
--- /dev/null
|
||||
+++ b/Source/Makefile.am
|
||||
@@ -0,0 +1,33 @@
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/Include $(UFCONFIG_CFLAGS)
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/Include $(SUITESPARSECONFIG_CFLAGS)
|
||||
+
|
||||
+AMDSRC = \
|
||||
+ amd_1.c \
|
||||
|
@ -126,15 +138,15 @@ new file mode 100644
|
|||
+
|
||||
+libamd_la_SOURCES = amd_global.c
|
||||
+libamd_la_LIBADD = libamdl.la libamdi.la
|
||||
+libamd_la_LDFLAGS = -no-undefined -version-info 4:2:2
|
||||
+libamd_la_LDFLAGS = -no-undefined -version-number 2:3:1
|
||||
+
|
||||
+libamdf77_la_SOURCES = amd.f amdbar.f
|
||||
+libamdf77_la_LDFLAGS = -no-undefined -version-info 4:2:2
|
||||
+libamdf77_la_LDFLAGS = -no-undefined -version-number 2:3:1
|
||||
diff --git a/amd.pc.in b/amd.pc.in
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/amd.pc.in
|
||||
@@ -0,0 +1,12 @@
|
||||
@@ -0,0 +1,13 @@
|
||||
+prefix=@prefix@
|
||||
+exec_prefix=@exec_prefix@
|
||||
+libdir=@libdir@
|
||||
|
@ -143,7 +155,8 @@ new file mode 100644
|
|||
+Name: @PACKAGE_NAME@
|
||||
+Description: Approximate minimum degree ordering
|
||||
+Version: @PACKAGE_VERSION@
|
||||
+Requires.private: ufconfig
|
||||
+URL: @PACKAGE_URL@
|
||||
+Requires.private: suitesparseconfig
|
||||
+Libs: -L${libdir} -lamd
|
||||
+Libs.private: -lm
|
||||
+Cflags: -I${includedir}/amd
|
||||
|
@ -151,31 +164,39 @@ diff --git a/configure.ac b/configure.ac
|
|||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/configure.ac
|
||||
@@ -0,0 +1,36 @@
|
||||
+AC_PREREQ([2.68])
|
||||
+AC_INIT([AMD],[2.2.2],[davis@cise.ufl.edu])
|
||||
@@ -0,0 +1,44 @@
|
||||
+# -*- Autoconf -*-
|
||||
+# Process this file with autoconf to produce a configure script.
|
||||
+
|
||||
+AC_PREREQ([2.69])
|
||||
+AC_INIT([AMD],[2.3.1],[DrTimothyAldenDavis@gmail.com],[amd],[http://www.suitesparse.com/])
|
||||
+AC_CONFIG_SRCDIR([Source/amd_global.c])
|
||||
+AC_CONFIG_HEADER([config.h])
|
||||
+AC_CONFIG_HEADERS([config.h])
|
||||
+AM_INIT_AUTOMAKE([foreign])
|
||||
+LT_INIT
|
||||
+
|
||||
+# Checks for programs.
|
||||
+AC_PROG_INSTALL
|
||||
+AC_PROG_CC
|
||||
+AC_PROG_F77
|
||||
+
|
||||
+LIBS_SAVED=$LIBS
|
||||
+
|
||||
+# Checks for libraries.
|
||||
+AC_CHECK_LIB([m], [sqrt])
|
||||
+
|
||||
+PKG_PROG_PKG_CONFIG
|
||||
+PKG_CHECK_MODULES([SUITESPARSECONFIG],[suitesparseconfig],
|
||||
+ [],
|
||||
+ [AC_MSG_ERROR([cannot find suitesparseconfig])])
|
||||
+
|
||||
+# Checks for header files.
|
||||
+AC_CHECK_HEADERS([limits.h stddef.h stdlib.h])
|
||||
+
|
||||
+PKG_PROG_PKG_CONFIG
|
||||
+PKG_CHECK_MODULES([UFCONFIG],[ufconfig],
|
||||
+ [],
|
||||
+ [AC_MSG_ERROR([cannot find ufconfig])])
|
||||
+
|
||||
+# Checks for typedefs, structures, and compiler characteristics.
|
||||
+AC_TYPE_SIZE_T
|
||||
+
|
||||
+# Checks for library functions.
|
||||
+AC_CHECK_FUNCS([sqrt])
|
||||
+
|
||||
+LIBS=$LIBS_SAVED
|
||||
|
|
Loading…
Reference in a new issue