libraries/BTF: Updated for version 1.2.0.

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Kyle Guinn 2013-11-25 02:22:30 -06:00 committed by Robby Workman
parent c845df2863
commit a953dce010
3 changed files with 52 additions and 19 deletions

View file

@ -1,10 +1,29 @@
#!/bin/sh
# Slackware build script for BTF
# Written by Kyle Guinn <elyk03@gmail.com>
# Copyright 2013 Kyle Guinn <elyk03@gmail.com>, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=BTF
VERSION=${VERSION:-1.1.2}
VERSION=${VERSION:-1.2.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -69,9 +88,11 @@ CFLAGS="$SLKCFLAGS" \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--enable-shared \
--disable-static \
--disable-dependency-tracking \
--build=$ARCH-slackware-linux
make
make check
make install-strip DESTDIR=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION

View file

@ -1,10 +1,10 @@
PRGNAM="BTF"
VERSION="1.1.2"
HOMEPAGE="http://www.cise.ufl.edu/research/sparse/btf/"
DOWNLOAD="http://www.cise.ufl.edu/research/sparse/btf/BTF-1.1.2.tar.gz"
MD5SUM="5ec8a33199518eb30d0ef8ad4b589e9e"
VERSION="1.2.0"
HOMEPAGE="https://www.cise.ufl.edu/research/sparse/btf/"
DOWNLOAD="https://www.cise.ufl.edu/research/sparse/btf/BTF-1.2.0.tar.gz"
MD5SUM="00ece872530408f3f5598b0eaa83c7fc"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="UFconfig"
REQUIRES="SuiteSparse_config"
MAINTAINER="Kyle Guinn"
EMAIL="elyk03@gmail.com"

View file

@ -3,8 +3,8 @@ new file mode 100644
--- /dev/null
+++ b/Include/Makefile.am
@@ -0,0 +1,2 @@
+pkgincludedir = $(includedir)/btf
+pkginclude_HEADERS = btf.h btf_internal.h
+pkginclude_HEADERS = btf.h
+noinst_HEADERS = btf_internal.h
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
--- /dev/null
@ -20,7 +20,7 @@ new file mode 100644
--- /dev/null
+++ b/Source/Makefile.am
@@ -0,0 +1,18 @@
+AM_CPPFLAGS = -I$(top_srcdir)/Include $(UFCONFIG_CFLAGS)
+AM_CPPFLAGS = -I$(top_srcdir)/Include $(SUITESPARSECONFIG_CFLAGS)
+
+BTFSRC = \
+ btf_maxtrans.c \
@ -37,12 +37,12 @@ new file mode 100644
+
+libbtf_la_SOURCES =
+libbtf_la_LIBADD = libbtfi.la libbtfl.la
+libbtf_la_LDFLAGS = -no-undefined -version-info 2:2:1
+libbtf_la_LDFLAGS = -no-undefined -version-number 1:2:0
diff --git a/btf.pc.in b/btf.pc.in
new file mode 100644
--- /dev/null
+++ b/btf.pc.in
@@ -0,0 +1,11 @@
@@ -0,0 +1,12 @@
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@
@ -51,28 +51,40 @@ new file mode 100644
+Name: @PACKAGE_NAME@
+Description: Permutation to block triangular form
+Version: @PACKAGE_VERSION@
+Requires.private: ufconfig
+URL: @PACKAGE_URL@
+Requires.private: suitesparseconfig
+Libs: -L${libdir} -lbtf
+Cflags: -I${includedir}/btf
diff --git a/configure.ac b/configure.ac
new file mode 100644
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,21 @@
+AC_PREREQ([2.68])
+AC_INIT([BTF],[1.1.2],[davis@cise.ufl.edu])
@@ -0,0 +1,32 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.69])
+AC_INIT([BTF],[1.2.0],[DrTimothyAldenDavis@gmail.com],[btf],[http://www.suitesparse.com/])
+AC_CONFIG_SRCDIR([Source/btf_order.c])
+AC_CONFIG_HEADER([config.h])
+AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([foreign])
+LT_INIT
+
+# Checks for programs.
+AC_PROG_INSTALL
+AC_PROG_CC
+
+# Checks for libraries.
+PKG_PROG_PKG_CONFIG
+PKG_CHECK_MODULES([UFCONFIG],[ufconfig],
+PKG_CHECK_MODULES([SUITESPARSECONFIG],[suitesparseconfig],
+ [],
+ [AC_MSG_ERROR([cannot find ufconfig])])
+ [AC_MSG_ERROR([cannot find suitesparseconfig])])
+
+# Checks for header files.
+
+# Checks for typedefs, structures, and compiler characteristics.
+
+# Checks for library functions.
+
+AC_CONFIG_FILES([
+ btf.pc