libraries/VTK: Patch for gcc >= 10.x.

Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
This commit is contained in:
Matteo Bernardini 2020-12-17 18:05:09 +01:00 committed by Robby Workman
parent 0f7e69edc1
commit a8e1115653
2 changed files with 45 additions and 0 deletions

View file

@ -105,6 +105,11 @@ else
proj=""
fi
# https://github.com/archlinux/svntogit-community/blob/packages/vtk/trunk/PKGBUILD
( cd ThirdParty/exodusII/vtkexodusII
patch -p1 < $CWD/patch-gcc10.diff )
sed -i 's|REGEX MATCH \"\[3-9\]|REGEX MATCH \"[1-9][0-9]|' CMake/VTKGenerateExportHeader.cmake
mkdir -p build
cd build
cmake \

View file

@ -0,0 +1,40 @@
From a9079bdccbb2165583d6773a5ed848427e2a38a8 Mon Sep 17 00:00:00 2001
From: Seacas Upstream <kwrobot@kitware.com>
Date: Tue, 28 Jan 2020 09:13:38 -0500
Subject: [PATCH] exodusII 2020-01-28 (d97eb08d)
Code extracted from:
https://gitlab.kitware.com/third-party/seacas.git
at commit d97eb08d79e87c82facfae39bc75deb60c0a2d83 (for/vtk-20200128-7.24f-v2019-12-18).
---
src/ex_create_par.c | 2 +-
src/ex_open_par.c | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/ex_create_par.c b/src/ex_create_par.c
index 8d5d6734f0..ef439618da 100644
--- a/src/ex_create_par.c
+++ b/src/ex_create_par.c
@@ -216,5 +216,5 @@ int ex_create_par_int(const char *path, int cmode, int *comp_ws, int *io_ws, MPI
* Prevent warning in some versions of ranlib(1) because the object
* file has no symbols.
*/
-const char exodus_unused_symbol_dummy_1;
+const char exodus_unused_symbol_dummy_ex_create_par;
#endif
diff --git a/src/ex_open_par.c b/src/ex_open_par.c
index b2faa22c29..9df4818767 100644
--- a/src/ex_open_par.c
+++ b/src/ex_open_par.c
@@ -459,5 +459,5 @@ int ex_open_par_int(const char *path, int mode, int *comp_ws, int *io_ws, float
* Prevent warning in some versions of ranlib(1) because the object
* file has no symbols.
*/
-const char exodus_unused_symbol_dummy_1;
+const char exodus_unused_symbol_dummy_ex_open_par;
#endif
--
GitLab