mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-29 13:00:32 +01:00
network/offlineimap: Updated for version 6.4.0
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
This commit is contained in:
parent
534b7b8c71
commit
a60ade5735
6 changed files with 17 additions and 37 deletions
|
@ -11,5 +11,4 @@ config() {
|
||||||
fi
|
fi
|
||||||
# Otherwise, we leave the .new copy for the admin to consider...
|
# Otherwise, we leave the .new copy for the admin to consider...
|
||||||
}
|
}
|
||||||
|
|
||||||
config etc/offlineimap.conf.new
|
config etc/offlineimap.conf.new
|
||||||
|
|
|
@ -3,7 +3,8 @@
|
||||||
# Slackware build script for OfflineIMAP
|
# Slackware build script for OfflineIMAP
|
||||||
# Home Page https://github.com/nicolas33/offlineimap
|
# Home Page https://github.com/nicolas33/offlineimap
|
||||||
|
|
||||||
# Copyright (c) 2008-2011, Nishant Limbachia, Hoffman Estates, IL, USA <nishant _AT_ mnspace _DOT_ net>
|
# Copyright (c) 2008-2011, Nishant Limbachia, Hoffman Estates, IL, USA
|
||||||
|
# <nishant _AT_ mnspace _DOT_ net>
|
||||||
# All rights reserved.
|
# All rights reserved.
|
||||||
#
|
#
|
||||||
# Redistribution and use of this script, with or without modification, is
|
# Redistribution and use of this script, with or without modification, is
|
||||||
|
@ -24,9 +25,9 @@
|
||||||
# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
|
# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
|
||||||
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||||
|
|
||||||
SRCNAM="nicolas33-offlineimap-v6.3.4-0-g61e50b3"
|
SRCNAM="nicolas33-offlineimap-v6.4.0-0-gc1120c9"
|
||||||
PRGNAM="offlineimap"
|
PRGNAM="offlineimap"
|
||||||
VERSION=${VERSION:-6.3.4}
|
VERSION=${VERSION:-6.4.0}
|
||||||
BUILD=${BUILD:-1}
|
BUILD=${BUILD:-1}
|
||||||
TAG=${TAG:-_SBo}
|
TAG=${TAG:-_SBo}
|
||||||
|
|
||||||
|
@ -45,11 +46,14 @@ OUTPUT=${OUTPUT:-/tmp}
|
||||||
|
|
||||||
set -e # Exit on most errors
|
set -e # Exit on most errors
|
||||||
|
|
||||||
|
# In case the source was fetched with wget or some other downloader:
|
||||||
|
[ -e v${VERSION} ] && mv v${VERSION} $SRCNAM.tar.gz
|
||||||
|
|
||||||
rm -fr $TMP/$PRGNAM-$VERSION $PKG
|
rm -fr $TMP/$PRGNAM-$VERSION $PKG
|
||||||
mkdir -p $TMP $PKG $OUTPUT
|
mkdir -p $TMP $PKG $OUTPUT
|
||||||
cd $TMP
|
cd $TMP
|
||||||
tar xvf $CWD/$SRCNAM.tar.gz
|
tar xvf $CWD/$SRCNAM.tar.gz
|
||||||
mv nicolas33-offlineimap-94450e9 $PRGNAM-$VERSION
|
mv nicolas33-offlineimap-b1bff15 $PRGNAM-$VERSION
|
||||||
cd $PRGNAM-$VERSION
|
cd $PRGNAM-$VERSION
|
||||||
|
|
||||||
chown -R root.root .
|
chown -R root.root .
|
||||||
|
@ -59,11 +63,8 @@ find . \
|
||||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||||
-exec chmod 644 {} \;
|
-exec chmod 644 {} \;
|
||||||
|
|
||||||
### fix the manual file to build correctly
|
|
||||||
patch -p0 < $CWD/patches/manual.rst.patch
|
|
||||||
|
|
||||||
### Patch makefile to disable building dev docs
|
### Patch makefile to disable building dev docs
|
||||||
patch -p0 < $CWD/patches/doc_generation_fix.patch
|
patch -p0 < $CWD/patches/Makefile.doc.patch
|
||||||
|
|
||||||
### build and install
|
### build and install
|
||||||
python setup.py install --root=$PKG
|
python setup.py install --root=$PKG
|
||||||
|
|
|
@ -1,8 +1,8 @@
|
||||||
PRGNAM="offlineimap"
|
PRGNAM="offlineimap"
|
||||||
VERSION="6.3.4"
|
VERSION="6.4.0"
|
||||||
HOMEPAGE="https://github.com/nicolas33/offlineimap"
|
HOMEPAGE="https://github.com/nicolas33/offlineimap"
|
||||||
DOWNLOAD="https://github.com/nicolas33/offlineimap/tarball/v6.3.4"
|
DOWNLOAD="https://github.com/nicolas33/offlineimap/tarball/v6.4.0"
|
||||||
MD5SUM="84c42088ffcc7092473fef76e17c082b"
|
MD5SUM="b7596598ca61347b8c96f8412cfd7dc0"
|
||||||
DOWNLOAD_x86_64=""
|
DOWNLOAD_x86_64=""
|
||||||
MD5SUM_x86_64=""
|
MD5SUM_x86_64=""
|
||||||
MAINTAINER="Nishant Limbachia"
|
MAINTAINER="Nishant Limbachia"
|
||||||
|
|
|
@ -1,5 +1,5 @@
|
||||||
--- Makefile.orig 2011-09-09 16:00:42.784605863 -0500
|
--- Makefile.orig 2011-12-03 12:09:16.547477510 -0600
|
||||||
+++ Makefile 2011-09-09 16:00:50.423804120 -0500
|
+++ Makefile 2011-12-03 12:09:45.284443743 -0600
|
||||||
@@ -44,7 +44,6 @@
|
@@ -44,7 +44,6 @@
|
||||||
@$(MAKE) -C docs man
|
@$(MAKE) -C docs man
|
||||||
|
|
|
@ -1,20 +0,0 @@
|
||||||
--- docs/MANUAL.rst.orig 2011-08-10 14:44:58.000000000 -0500
|
|
||||||
+++ docs/MANUAL.rst 2011-09-09 15:43:23.813649765 -0500
|
|
||||||
@@ -380,7 +380,7 @@
|
|
||||||
default.
|
|
||||||
|
|
||||||
Certificate checking
|
|
||||||
-^^^^^^^^^^^^^^^^^^^^
|
|
||||||
+====================
|
|
||||||
|
|
||||||
Unfortunately, by default we will not verify the certificate of an IMAP
|
|
||||||
TLS/SSL server we connect to, so connecting by SSL is no guarantee
|
|
||||||
@@ -397,7 +397,7 @@
|
|
||||||
certificate and CA certificate.
|
|
||||||
|
|
||||||
StartTLS
|
|
||||||
-^^^^^^^^
|
|
||||||
+========
|
|
||||||
|
|
||||||
If you have not configured your account to connect via SSL anyway,
|
|
||||||
OfflineImap will still attempt to set up an SSL connection via the
|
|
|
@ -5,15 +5,15 @@
|
||||||
# make exactly 11 lines for the formatting to be correct. It's also
|
# make exactly 11 lines for the formatting to be correct. It's also
|
||||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||||
|
|
||||||
|-----handy-ruler------------------------------------------------------|
|
|-----handy-ruler-----------------------------------------------|
|
||||||
offlineimap: offlineimap (IMAP sync tool)
|
offlineimap: offlineimap (IMAP sync tool)
|
||||||
offlineimap:
|
offlineimap:
|
||||||
offlineimap: OfflineIMAP allows you to sync imap mailboxes between remote
|
offlineimap: OfflineIMAP allows you to sync imap mailboxes between remote
|
||||||
offlineimap: and local machines. It is most useful in syncing user
|
offlineimap: and local machines. It is most useful in syncing user
|
||||||
offlineimap: mailboxes between imap servers.
|
offlineimap: mailboxes between imap servers.
|
||||||
offlineimap:
|
offlineimap:
|
||||||
|
offlineimap:
|
||||||
|
offlineimap:
|
||||||
offlineimap: Homepage: https://github.com/nicolas33/offlineimap
|
offlineimap: Homepage: https://github.com/nicolas33/offlineimap
|
||||||
offlineimap:
|
offlineimap:
|
||||||
offlineimap:
|
offlineimap:
|
||||||
offlineimap:
|
|
||||||
offlineimap:
|
|
||||||
|
|
Loading…
Reference in a new issue