mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-24 10:02:29 +01:00
libraries/SPIRV-Headers: Added (SPIRV Header files)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
f72a7c2963
commit
a5b1414db9
5 changed files with 123 additions and 0 deletions
1
libraries/SPIRV-Headers/README
Normal file
1
libraries/SPIRV-Headers/README
Normal file
|
@ -0,0 +1 @@
|
|||
Machine-readable files for the SPIR-V Registry.
|
74
libraries/SPIRV-Headers/SPIRV-Headers.SlackBuild
Normal file
74
libraries/SPIRV-Headers/SPIRV-Headers.SlackBuild
Normal file
|
@ -0,0 +1,74 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for SPIRV-Headers
|
||||
|
||||
# Copyright 2020 Hunter Sezen California, USA
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=SPIRV-Headers
|
||||
VERSION=${VERSION:-1.5.4}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
ARCH=noarch
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
set -eu
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# cmake: Install cmake files to CMAKE_INSTALL_DATADIR
|
||||
# https://github.com/KhronosGroup/SPIRV-Headers/pull/178
|
||||
patch -p1 < $CWD/datadir.patch
|
||||
|
||||
mkdir -p build
|
||||
cd build
|
||||
cmake \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DSPIRV_HEADERS_SKIP_EXAMPLES=ON \
|
||||
-DCMAKE_BUILD_TYPE=Release ..
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
cd ..
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a CODE_OF_CONDUCT.md LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
10
libraries/SPIRV-Headers/SPIRV-Headers.info
Normal file
10
libraries/SPIRV-Headers/SPIRV-Headers.info
Normal file
|
@ -0,0 +1,10 @@
|
|||
PRGNAM="SPIRV-Headers"
|
||||
VERSION="1.5.4"
|
||||
HOMEPAGE="https://github.com/KhronosGroup/SPIRV-Headers"
|
||||
DOWNLOAD="https://github.com/KhronosGroup/SPIRV-Headers/archive/1.5.4/SPIRV-Headers-1.5.4.tar.gz"
|
||||
MD5SUM="34773eccf945a384946000799be6687e"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
MAINTAINER="Hunter Sezen"
|
||||
EMAIL="orbea@riseup.net"
|
19
libraries/SPIRV-Headers/datadir.patch
Normal file
19
libraries/SPIRV-Headers/datadir.patch
Normal file
|
@ -0,0 +1,19 @@
|
|||
commit eae955f0525724526fa602fd126623b9d84599fa
|
||||
Author: orbea <orbea@riseup.net>
|
||||
Date: Thu Nov 5 22:08:24 2020 -0800
|
||||
|
||||
cmake: Install cmake files to CMAKE_INSTALL_DATADIR
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index eb46947..6f01ef0 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -79,7 +79,7 @@ target_include_directories(${PROJECT_NAME} INTERFACE
|
||||
if (SPIRV_HEADERS_ENABLE_INSTALL)
|
||||
message(STATUS "Installing SPIRV-Header")
|
||||
|
||||
- set(config_install_dir "${CMAKE_INSTALL_LIBDIR}/cmake/${PROJECT_NAME}")
|
||||
+ set(config_install_dir "${CMAKE_INSTALL_DATADIR}/cmake/${PROJECT_NAME}")
|
||||
|
||||
set(generated_dir "${CMAKE_CURRENT_BINARY_DIR}/generated")
|
||||
|
19
libraries/SPIRV-Headers/slack-desc
Normal file
19
libraries/SPIRV-Headers/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description.
|
||||
# Line up the first '|' above the ':' following the base package name, and
|
||||
# the '|' on the right side marks the last column you can put a character in.
|
||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
SPIRV-Headers: SPIRV-Headers (SPIRV Header files)
|
||||
SPIRV-Headers:
|
||||
SPIRV-Headers: Machine-readable files for the SPIR-V Registry.
|
||||
SPIRV-Headers:
|
||||
SPIRV-Headers: Homepage: https://github.com/KhronosGroup/SPIRV-Headers
|
||||
SPIRV-Headers:
|
||||
SPIRV-Headers:
|
||||
SPIRV-Headers:
|
||||
SPIRV-Headers:
|
||||
SPIRV-Headers:
|
||||
SPIRV-Headers:
|
Loading…
Reference in a new issue