academic/sage: Updated for version 7.5.1.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Willy Sudiarto Raharjo 2017-03-09 19:34:45 +07:00
parent dc1daa2e54
commit a58f639ff2
3 changed files with 50 additions and 5 deletions

View file

@ -0,0 +1,40 @@
From fdb590023f7ca4b2e881a2e9573718e7ed180f03 Mon Sep 17 00:00:00 2001
From: Tommy Hofmann <thofma@gmail.com>
Date: Fri, 13 Jan 2017 08:30:56 +0100
Subject: [PATCH] Adjust to new sed version
Change [:space] to [[:space]].
sed requires character classes to be inside square brackets.
As of sed 4.3, missing the brackets raises an error.
---
configure | 2 +-
configure.ac | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/configure b/configure
index 4d010b7..9faebcd 100755
--- a/configure
+++ b/configure
@@ -24301,7 +24301,7 @@ esac
sed -n 's/^[ ]*MULFUNC_PROLOGUE(\(.*\))/\1/p' $tmp_file ;
sed -n 's/^[ ]*PROLOGUE(\([^,]*\).*)/\1/p' $tmp_file ;
sed -n 's/^;[ ]*PROLOGUE(\([^,]*\).*)/\1/p' $tmp_file ;
- sed -n 's/[^G]*GLOBAL_FUNC[:space:]*\(.*\)/\1/p' $tmp_file ;
+ sed -n 's/[^G]*GLOBAL_FUNC[[:space:]]*\(.*\)/\1/p' $tmp_file ;
`
for gmp_tmp in $gmp_ep; do
cat >>confdefs.h <<_ACEOF
diff --git a/configure.ac b/configure.ac
index bde9f09..170b9e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2595,7 +2595,7 @@ for tmp_fn in $gmp_mpn_functions; do
sed -n 's/^[ ]*MULFUNC_PROLOGUE(\(.*\))/\1/p' $tmp_file ;
sed -n 's/^[ ]*PROLOGUE(\([^,]*\).*)/\1/p' $tmp_file ;
sed -n 's/^;[ ]*PROLOGUE(\([^,]*\).*)/\1/p' $tmp_file ;
- sed -n 's/[^G]*GLOBAL_FUNC[:space:]*\(.*\)/\1/p' $tmp_file ;
+ sed -n 's/[^G]*GLOBAL_FUNC[[:space:]]*\(.*\)/\1/p' $tmp_file ;
`]
for gmp_tmp in $gmp_ep; do
AC_DEFINE_UNQUOTED(HAVE_NATIVE_$gmp_tmp)

View file

@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=sage
VERSION=${VERSION:-7.2}
VERSION=${VERSION:-7.5.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -67,7 +67,12 @@ patch -p0 < $CWD/pynac.patch
patch -p1 < $CWD/sage-build-root.patch
# Thanks to Philip Lacroix <slackph@posteo.de>
rm build/pkgs/python2/patches/sys_path_security.patch
rm build/pkgs/python2/patches/sys_path_security-issue_16202.patch
# Fix mpir sed issue in -current but works as well for 14.2
# https://github.com/wbhart/mpir/commit/fdb590023f7ca4b2e881a2e9573718e7ed180f03.patch
mkdir $TMP/$PRGNAM-$VERSION/build/pkgs/mpir/patches
cp $CWD/mpir-sed-fix.patch $TMP/$PRGNAM-$VERSION/build/pkgs/mpir/patches
make

View file

@ -1,8 +1,8 @@
PRGNAM="sage"
VERSION="7.2"
VERSION="7.5.1"
HOMEPAGE="http://www.sagemath.org"
DOWNLOAD="http://mirrors.mit.edu/sage/src/sage-7.2.tar.gz"
MD5SUM="d0c5e81683dc79a7654206e57e6e727a"
DOWNLOAD="http://mirrors.mit.edu/sage/src/sage-7.5.1.tar.gz"
MD5SUM="7d26a9f7cb354de22dd9f968d7181b14"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""