audio/id3v2: Updated for version 0.1.11

This commit is contained in:
Paul Wisehart 2010-05-13 00:21:19 +02:00 committed by David Somero
parent 2ff64854a8
commit a4e196804b
5 changed files with 29 additions and 5 deletions

View file

@ -1,3 +1,3 @@
id3v2 is a command line editor for id3v2 tags.
This requires id3lib, which is also available from SlackBuilds.org.
This requires id3lib.

View file

@ -0,0 +1,15 @@
diff -Nur id3v2-0.1.11.orig/Makefile id3v2-0.1.11/Makefile
--- id3v2-0.1.11.orig/Makefile 2004-05-04 13:33:53.000000000 -0500
+++ id3v2-0.1.11/Makefile 2009-07-29 00:36:39.438041437 -0500
@@ -2,8 +2,10 @@
VERSION=0.1.11
+OPT= -O2
+
PREFIX= /usr/local
-CXXFLAGS+= -I${PREFIX}/include/ -DVERSION="\"${VERSION}\"" #-DSORT_RUNTIME
+CXXFLAGS+= $(OPT) -I${PREFIX}/include/ -DVERSION="\"${VERSION}\"" #-DSORT_RUNTIME
LDFLAGS+= -L${PREFIX}/lib/
id3v2: convert.o list.o id3v2.o genre.o

View file

@ -17,8 +17,13 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
fi
set -e
@ -29,7 +34,6 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
patch -p1 < $CWD/id3v2-track_no-segfault.patch
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@ -37,12 +41,15 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
patch -p1 < $CWD/id3v2-0.1.11-fixup_Makefile.patch
patch -p1 < $CWD/id3v2-0.1.11-track_no-segfault.patch
# The Makefile doesnt use DESTDIR, but the program is just an
# executable and a man page (there's no apparent path-info compiled
# into the binary). So we can fake it be using PREFIX and manually
# creating the direcories needed in $PKG
mkdir -p $PKG/usr/{bin,man/man1}
make
make OPT="$SLKCFLAGS"
make install PREFIX=$PKG/usr
strip --strip-unneeded $PKG/usr/bin/id3v2
@ -60,4 +67,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View file

@ -3,6 +3,8 @@ VERSION="0.1.11"
HOMEPAGE="http://id3v2.sourceforge.net/"
DOWNLOAD="http://downloads.sourceforge.net/id3v2/id3v2-0.1.11.tar.gz"
MD5SUM="68afc3827cf01501dfb22949f901f1d8"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="paul wisehart"
EMAIL="wise@lupulin.net"
APPROVED="David Somero"
APPROVED="dsomero"