mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
graphics/dia: Updated for version 0.97.1 (+new maintainer)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
This commit is contained in:
parent
7af79e748c
commit
a36bef798f
5 changed files with 19 additions and 30 deletions
|
@ -1,12 +0,0 @@
|
|||
diff -Nur dia-0.97.orig/doc/fr/Makefile.in dia-0.97/doc/fr/Makefile.in
|
||||
--- dia-0.97.orig/doc/fr/Makefile.in 2009-05-03 13:12:41.000000000 -0500
|
||||
+++ dia-0.97/doc/fr/Makefile.in 2009-10-12 17:44:25.949545398 -0500
|
||||
@@ -298,7 +298,7 @@
|
||||
libexecdir = @libexecdir@
|
||||
localedir = @localedir@
|
||||
localstatedir = @localstatedir@
|
||||
-mandir = $(datadir)/man/$(lang)
|
||||
+mandir = @mandir@/$(lang)
|
||||
mkdir_p = @mkdir_p@
|
||||
oldincludedir = @oldincludedir@
|
||||
pdfdir = @pdfdir@
|
|
@ -3,18 +3,17 @@
|
|||
# Slackware build script for dia
|
||||
# Written by Matt Hayes (dominian@slackadelic.com
|
||||
# Updated for 64bit by Ash Wiren (ash@spooksoftware.com 19-08-2009
|
||||
# Currently mantained by Dugan Chen (dugan [underscore] c [at] fastmail [dot] fm)))
|
||||
|
||||
PRGNAM=dia
|
||||
VERSION=0.97
|
||||
VERSION=0.97.1
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
# Automatically determine the architecture we're building on:
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
# Unless $ARCH is already set, use uname -m for all other archs:
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
@ -49,8 +48,8 @@ cd $PRGNAM-$VERSION
|
|||
chown -R root:root .
|
||||
chmod -R u+w,go+r-w,a-s .
|
||||
|
||||
# Fixup the fr mandir
|
||||
patch -p1 < $CWD/dia-0.97-fixup_fr_mandir.patch
|
||||
# Fix the location of the French manpages.
|
||||
sed -i 's/$(datadir)\/man/@mandir@/' doc/fr/Makefile.in
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
|
@ -67,14 +66,12 @@ make install DESTDIR=$PKG
|
|||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
( cd $PKG/usr/man
|
||||
find . -type f -exec gzip -9 {} \;
|
||||
for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
|
||||
)
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
|
||||
# docdir already exists :-)
|
||||
cp -a \
|
||||
AUTHORS COPYING ChangeLog KNOWN_BUGS MAINTAINERS NEWS README THANKS TODO \
|
||||
AUTHORS COPYING ChangeLog ChangeLog.pre-git KNOWN_BUGS MAINTAINERS NEWS README RELEASE-PROCESS THANKS TODO \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="dia"
|
||||
VERSION="0.97"
|
||||
HOMEPAGE="http://www.gnome.org/projects/dia/"
|
||||
DOWNLOAD="http://ftp.gnome.org/pub/gnome/sources/dia/0.97/dia-0.97.tar.bz2"
|
||||
MD5SUM="3d11f9aaa5a4923f0a5533962c87bdfb"
|
||||
VERSION="0.97.1"
|
||||
HOMEPAGE="http://live.gnome.org/Dia"
|
||||
DOWNLOAD="http://ftp.gnome.org/pub/gnome/sources/dia/0.97/dia-0.97.1.tar.bz2"
|
||||
MD5SUM="57e44bb9f387559a0506b52a134deaf0"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Ash Wiren"
|
||||
EMAIL="ash@spooksoftware.com"
|
||||
APPROVED="rworkman"
|
||||
MAINTAINER="Dugan Chen"
|
||||
EMAIL="dugan [underscore] c [at] fastmail [dot] fm"
|
||||
APPROVED="rworkman,Niels Horn"
|
||||
|
|
|
@ -2,6 +2,10 @@ if [ -x /usr/bin/update-desktop-database ]; then
|
|||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -x /usr/bin/update-mime-database ]; then
|
||||
/usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
|
||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
|
||||
|
|
|
@ -16,4 +16,4 @@ dia: flowcharts, network diagrams, and many other diagrams. It is also
|
|||
dia: possible to add support for new shapes by writing simple XML files,
|
||||
dia: using a subset of SVG to draw the shape.
|
||||
dia:
|
||||
dia: Homepage: http://www.gnome.org/projects/dia/
|
||||
dia: Homepage: http://live.gnome.org/Dia
|
||||
|
|
Loading…
Reference in a new issue