libraries/ring-daemon: Removed (superseded by jami).

Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>

Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com>

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Johannes Schoepfer 2022-03-06 11:54:18 +01:00 committed by Willy Sudiarto Raharjo
parent 99b0463861
commit a0440b0baf
No known key found for this signature in database
GPG key ID: 3F617144D7238786
7 changed files with 0 additions and 284 deletions

View file

@ -1,19 +0,0 @@
Ring is free software which allows its users to communicate in multiple ways.
What is Ring?
A telephone: a simple tool to connect, communicate and share.
A teleconferencing tool: easily join calls to create conferences with
multiple participants.
A media sharing tool: Ring supports a variety of video input options,
including mutliple cameras and image and video files, and the selection of
audio inputs and outputs; all this is supported by multiple high quality
audio and video codecs.
A messenger: send text messeges during calls or out of calls (as long as
your peer is connected).
A building block for your IoT project: re-use the universal communications
technology of Ring with its portable library on your system of choice.

View file

@ -1,15 +0,0 @@
--- ring-daemon-20181026_114c66440/contrib/src/libressl/rules.mak.orig 2018-10-26 17:20:13.000000000 +0200
+++ ring-daemon-20181026_114c66440/contrib/src/libressl/rules.mak 2018-10-27 22:36:00.608283629 +0200
@@ -25,9 +25,9 @@
OPENBSD_URL := https://github.com/libressl-portable/openbsd/archive/$(OPENBSD_VERSION).tar.gz
# Check if openssl or libressl is already present on the system
-ifeq ($(call need_pkg,"openssl >= 1.0.0" || call need_pkg,"libressl >= 1.0.0"),)
-PKGS_FOUND += libressl
-endif
+#ifeq ($(call need_pkg,"openssl >= 1.0.0" || call need_pkg,"libressl >= 1.0.0"),)
+#PKGS_FOUND += libressl
+#endif
# Pure dependency of restbed: do not add to PKGS.

View file

@ -1,15 +0,0 @@
--- ring-daemon-4.0.0/src/ringdht/namedirectory.cpp.orig 2017-07-19 23:27:21.000000000 +0200
+++ ring-daemon-4.0.0/src/ringdht/namedirectory.cpp 2017-08-01 15:50:13.311715765 +0200
@@ -90,9 +90,9 @@
size_t getContentLength(restbed::Response& reply)
{
size_t length = 0;
-#ifndef RESTBED_OLD_API
- length =
-#endif
+//#ifndef RESTBED_OLD_API
+// length =
+//#endif
reply.get_header("Content-Length", length);
return length;
}

View file

@ -1,39 +0,0 @@
--- ring-daemon-4.0.0/configure.ac.orig 2017-07-19 23:27:21.000000000 +0200
+++ ring-daemon-4.0.0/configure.ac 2017-08-01 16:34:48.826571353 +0200
@@ -368,8 +368,8 @@
AS_IF([test "x$with_dbus" = "xyes"], [
PKG_CHECK_MODULES(DBUSCPP, dbus-c++-1,, AC_MSG_WARN([Missing dbus development files]))
- AS_AC_EXPAND(LIBDIR, $libdir)
- AC_SUBST(LIBDIR)
+ AS_AC_EXPAND(LIBEXECDIR, $libexecdir)
+ AC_SUBST(LIBEXECDIR)
AC_CONFIG_FILES([bin/dbus/Makefile
bin/dbus/cx.ring.Ring.service])
--- ring-daemon-4.0.0/globals.mk.orig 2017-07-19 23:27:21.000000000 +0200
+++ ring-daemon-4.0.0/globals.mk 2017-08-01 16:36:01.520567429 +0200
@@ -1,7 +1,7 @@
# Global variables
src=$(abs_top_srcdir)
-ringlibdir=$(DESTDIR)$(libdir)/ring
+ringlibdir=$(DESTDIR)$(libexecdir)/ring
ASTYLERC="$(top_srcdir)/../astylerc"
indent="/usr/bin/astyle"
--- ring-daemon-4.0.0/bin/dbus/cx.ring.Ring.service.in.orig 2017-07-19 23:27:21.000000000 +0200
+++ ring-daemon-4.0.0/bin/dbus/cx.ring.Ring.service.in 2017-08-01 16:39:22.606556575 +0200
@@ -1,3 +1,3 @@
[D-BUS Service]
Name=cx.ring.Ring
-Exec=@LIBDIR@/ring/dring
+Exec=@LIBEXECDIR@/ring/dring
--- ring-daemon-4.0.0/bin/Makefile.am.orig 2017-07-19 23:27:21.000000000 +0200
+++ ring-daemon-4.0.0/bin/Makefile.am 2017-08-01 16:51:06.985518556 +0200
@@ -1,4 +1,4 @@
-ringlibdir = $(libdir)/ring
+ringlibdir = $(libexecdir)/ring
if HAVE_WIN32
ringlib_PROGRAMS = ringcli

View file

@ -1,137 +0,0 @@
#!/bin/bash
# Slackware build script for ring-daemon
# Copyright 2017, 2018 Mario Preksavec, Zagreb, Croatia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=ring-daemon
VERSION=${VERSION:-20181026_114c6644}
COMMIT=${COMMIT:-114c6644004ab8667a5403a0f2578b249a57ee46}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$COMMIT
tar xvf $CWD/$PRGNAM-$COMMIT.tar.gz
cd $PRGNAM-$COMMIT
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch -p1 <$CWD/patches/namedirectory.cpp.diff
patch -p1 <$CWD/patches/use_libexecdir.diff
patch -p1 <$CWD/patches/libressl-rules.mak.diff
# Copy already present source tarballs
for src in libdbus jsoncpp msgpack libnatpmp argon2 asio portable \
openbsd restbed opendht pjproject secp256k1 gmp pupnp yaml-cpp; do
cp $CWD/$src-*.tar.gz contrib/tarballs \
|| cp $CWD/$src-*.tar.bz2 contrib/tarballs
done
# Compile the dependencies
( mkdir contrib/build
cd contrib/build
../bootstrap
make
)
./autogen.sh
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--enable-ipv6 \
--build=$ARCH-slackware-linux
# This is where dependencies ended up
export PATH=$PATH:$TMP/$PRGNAM-$COMMIT/contrib/$ARCH-slackware-linux/bin
make
make install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS CODING COPYING NEWS README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
rm -f $PKG/usr/lib*/*.la
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE

View file

@ -1,40 +0,0 @@
PRGNAM="ring-daemon"
VERSION="20181026_114c6644"
HOMEPAGE="https://ring.cx/"
DOWNLOAD="https://github.com/savoirfairelinux/ring-daemon/archive/114c66440/ring-daemon-114c6644004ab8667a5403a0f2578b249a57ee46.tar.gz \
https://kent.dl.sourceforge.net/project/dbus-cplusplus/dbus-c++/0.9.0/libdbus-c++-0.9.0.tar.gz \
https://github.com/open-source-parsers/jsoncpp/archive/1.7.2/jsoncpp-1.7.2.tar.gz \
https://github.com/msgpack/msgpack-c/archive/cpp-2.1.5/msgpack-c-cpp-2.1.5.tar.gz \
http://miniupnp.free.fr/files/libnatpmp-20150609.tar.gz \
https://github.com/P-H-C/phc-winner-argon2/archive/1eea010/argon2-1eea0104e7cb2a38c617cf90ffa46ce5db6aceda.tar.gz \
https://github.com/hlysunnaram/asio/archive/b0926b6/asio-b0926b61b057ce563241d609cae5768ed3a4e1b1.tar.gz \
https://github.com/libressl-portable/portable/archive/0974145/portable-0974145a9e62d844b5b159cddbce36552bca30df.tar.gz \
https://github.com/libressl-portable/openbsd/archive/OPENBSD_6_3/openbsd-OPENBSD_6_3.tar.gz \
https://github.com/aberaud/restbed/archive/c3e28ad/restbed-c3e28adaf8b15b34162da6c1ed5514606288f91b.tar.gz \
https://github.com/savoirfairelinux/opendht/archive/1.7.5rc3/opendht-1.7.5rc3.tar.gz \
https://github.com/pjsip/pjproject/archive/2.8/pjproject-2.8.tar.gz \
https://github.com/bitcoin-core/secp256k1/archive/0b70241/secp256k1-0b7024185045a49a1a6a4c5615bf31c94f63d9c4.tar.gz \
https://ftpmirror.gnu.org/gmp/gmp-6.1.2.tar.bz2 \
https://github.com/mrjimenez/pupnp/archive/release-1.6.25/pupnp-release-1.6.25.tar.gz \
https://github.com/jbeder/yaml-cpp/archive/24fa1b3/yaml-cpp-24fa1b33805c9a91df0f32c46c28e314dd7ad96f.tar.gz"
MD5SUM="2df7e66cabca695c147f0ca891b6ec2e \
e752116f523fa88ef041e63d3dee4de2 \
3989402269147d1f853b57c542037536 \
6536e2072a1006e2004e2963081692a2 \
7bd1af6710271e1743df5422be350bd8 \
c65e2070180a65c34db7190a6a932f3c \
54d7426e25ee9067b054e20b0e6a5ef8 \
f2709fc74fd79304fba779cf5dce6d87 \
d13111290b28c276ab72988bf92ac9bc \
b88fe85299811b3232fd2b66a7aa887e \
ff2cb351e51ee868b6a062283adec2e1 \
84ba9ecb5ceed1fde03bbeb5f5fc455b \
379b867ce2491314219a606bd7ac112f \
8ddbb26dc3bd4e2302984debba1406a5 \
1b07074b282af509c8d384f8b3751233 \
3aa5de709713385ca2e49037e4a12b6e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="Mario Preksavec"
EMAIL="mario at slackware dot hr"

View file

@ -1,19 +0,0 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description.
# Line up the first '|' above the ':' following the base package name, and
# the '|' on the right side marks the last column you can put a character in.
# You must make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
ring-daemon: ring-daemon (LibRing - daemon)
ring-daemon:
ring-daemon: Ring is a free and universal communication platform which preserves
ring-daemon: the users' privacy and freedoms.
ring-daemon:
ring-daemon: Homepage: https://ring.cx/
ring-daemon:
ring-daemon:
ring-daemon:
ring-daemon:
ring-daemon: