system/alacritty: Include upstream patch for crates.io winpty-sys.

Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com>
This commit is contained in:
Andrew Clemons 2018-11-30 07:47:34 +13:00 committed by Willy Sudiarto Raharjo
parent f02ac13745
commit 9ff9002f20
No known key found for this signature in database
GPG key ID: 887B8374D7333381
4 changed files with 9 additions and 93 deletions

View file

@ -69,8 +69,7 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
# force offline for git crate dependencies
patch -p1 < $CWD/offline_build.diff
zcat $CWD/6f4ad9bb4f82bfdc4d8aac883a65ddd8c6acd45d.patch.gz | patch -p1
# build offline
# configuration tells cargo to use the configured directory
@ -385,6 +384,7 @@ mkdir vendor
winapi=0.3.6 \
wincolor=1.0.1 \
winit=0.18.0 \
winpty-sys=0.4.3 \
winreg=0.4.0 \
ws2_32-sys=0.2.1 \
x11-clipboard=0.2.2 \
@ -394,17 +394,11 @@ mkdir vendor
xml-rs=0.7.0 \
xml-rs=0.8.0 \
yaml-rust=0.4.2 \
zip=0.4.2 \
winpty=1.1.0 ; do
zip=0.4.2; do
dep="$(echo "$dependency" | cut -d= -f1)"
ver="$(echo "$dependency" | cut -d= -f2)"
if [ "$dep" = "winpty" ] ; then
tar xvf "$CWD/winpty-9ccec6459c2c8b7555846910c12ba697b688f44d.tar.gz"
mv winpty-9ccec6459c2c8b7555846910c12ba697b688f44d winpty-1.1.0
else
tar xvf $CWD/$dep-$ver.crate
fi
tar xvf $CWD/$dep-$ver.crate
touch $dep-$ver/.cargo-ok
@ -421,11 +415,7 @@ mkdir vendor
printf " },\n"
printf ' "package": "'
if [ "$dep" = "winpty" ] ; then
printf "%s\"\\n" "bd075c24ae8cc8cfa57fd188683118d302c024a6b2413cc6c8d5406a59eca2e2"
else
sha256sum "$CWD/$dep-$ver.crate" | cut -f1 -d' ' | sed 's/$/"/'
fi
sha256sum "$CWD/$dep-$ver.crate" | cut -f1 -d' ' | sed 's/$/"/'
printf "}\n"
} | python -c "import sys, json; data = sys.stdin.read(); print json.dumps(json.loads(data), sort_keys=True, indent=4, separators=(',', ' : '))" > $dep-$ver/.cargo-checksum.json

View file

@ -296,6 +296,7 @@ DOWNLOAD="https://github.com/jwilm/alacritty/archive/v0.2.3/alacritty-0.2.3.tar.
https://crates-io.s3-us-west-1.amazonaws.com/crates/winapi/winapi-0.3.6.crate \
https://crates-io.s3-us-west-1.amazonaws.com/crates/wincolor/wincolor-1.0.1.crate \
https://crates-io.s3-us-west-1.amazonaws.com/crates/winit/winit-0.18.0.crate \
https://crates-io.s3-us-west-1.amazonaws.com/crates/winpty-sys/winpty-sys-0.4.3.crate \
https://crates-io.s3-us-west-1.amazonaws.com/crates/winreg/winreg-0.4.0.crate \
https://crates-io.s3-us-west-1.amazonaws.com/crates/ws2_32-sys/ws2_32-sys-0.2.1.crate \
https://crates-io.s3-us-west-1.amazonaws.com/crates/x11-clipboard/x11-clipboard-0.2.2.crate \
@ -305,8 +306,7 @@ DOWNLOAD="https://github.com/jwilm/alacritty/archive/v0.2.3/alacritty-0.2.3.tar.
https://crates-io.s3-us-west-1.amazonaws.com/crates/xml-rs/xml-rs-0.7.0.crate \
https://crates-io.s3-us-west-1.amazonaws.com/crates/xml-rs/xml-rs-0.8.0.crate \
https://crates-io.s3-us-west-1.amazonaws.com/crates/yaml-rust/yaml-rust-0.4.2.crate \
https://crates-io.s3-us-west-1.amazonaws.com/crates/zip/zip-0.4.2.crate \
https://github.com/zacps/winpty/archive/9ccec6459c2c8b7555846910c12ba697b688f44d/winpty-9ccec6459c2c8b7555846910c12ba697b688f44d.tar.gz"
https://crates-io.s3-us-west-1.amazonaws.com/crates/zip/zip-0.4.2.crate"
MD5SUM="c08b8fa3811275cdc74bd384a44a7653 \
94e5e4da83397101dcac50eba7f31787 \
0a69ff70029371bf4d7fa89e2fe6c10b \
@ -602,6 +602,7 @@ MD5SUM="c08b8fa3811275cdc74bd384a44a7653 \
40909511b3d0e2dba891f438715808d0 \
2f9f840bd479751f715a8f530976b6bf \
5442b7076e8374e9fa8964a35ed0aaa3 \
35dc54bd806e940d9fd1fcdab28a5fc3 \
18eb1711b907c34969353a721a0ca533 \
38346bab0933c9eb1e36d22fe4220ba7 \
cc007d1ed803de8e399518daeec6d4cd \
@ -611,8 +612,7 @@ MD5SUM="c08b8fa3811275cdc74bd384a44a7653 \
3330bd5ad46e2b2a7276a954cdc60a62 \
9039399ab9632e189ce70d8008011d34 \
12a788ed8a569a3011f52e501ba01225 \
50b73de2605159fd629475fa86628fd4 \
a5e3167c844289b5382edb2a6ead9507"
50b73de2605159fd629475fa86628fd4"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="xclip"

View file

@ -1,74 +0,0 @@
diff -Naur alacritty-0.2.3.orig/Cargo.lock alacritty-0.2.3/Cargo.lock
--- alacritty-0.2.3.orig/Cargo.lock 2018-11-14 05:58:10.000000000 +1300
+++ alacritty-0.2.3/Cargo.lock 2018-11-19 08:04:21.433394423 +1300
@@ -60,7 +60,7 @@
"url 1.7.2 (registry+https://github.com/rust-lang/crates.io-index)",
"vte 0.3.3 (registry+https://github.com/rust-lang/crates.io-index)",
"winapi 0.3.6 (registry+https://github.com/rust-lang/crates.io-index)",
- "winpty 0.1.0",
+ "winpty 0.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"x11-dl 2.18.3 (registry+https://github.com/rust-lang/crates.io-index)",
"xdg 2.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
"zip 0.4.2 (registry+https://github.com/rust-lang/crates.io-index)",
@@ -2662,13 +2662,13 @@
"named_pipe 0.3.0 (registry+https://github.com/rust-lang/crates.io-index)",
"widestring 0.2.2 (registry+https://github.com/rust-lang/crates.io-index)",
"winapi 0.3.6 (registry+https://github.com/rust-lang/crates.io-index)",
- "winpty-sys 1.1.0 (git+https://github.com/zacps/winpty?branch=rust)",
+ "winpty-sys 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
]
[[package]]
name = "winpty-sys"
version = "1.1.0"
-source = "git+https://github.com/zacps/winpty?branch=rust#9ccec6459c2c8b7555846910c12ba697b688f44d"
+source = "registry+https://github.com/rust-lang/crates.io-index"
dependencies = [
"bindgen 0.33.2 (registry+https://github.com/rust-lang/crates.io-index)",
"cc 1.0.25 (registry+https://github.com/rust-lang/crates.io-index)",
@@ -3054,7 +3054,7 @@
"checksum winapi-x86_64-pc-windows-gnu 0.4.0 (registry+https://github.com/rust-lang/crates.io-index)" = "712e227841d057c1ee1cd2fb22fa7e5a5461ae8e48fa2ca79ec42cfc1931183f"
"checksum wincolor 1.0.1 (registry+https://github.com/rust-lang/crates.io-index)" = "561ed901ae465d6185fa7864d63fbd5720d0ef718366c9a4dc83cf6170d7e9ba"
"checksum winit 0.18.0 (registry+https://github.com/rust-lang/crates.io-index)" = "27aa86a5723951d6a08c2acb9f10e25cb39ceb5b1987d7daf74e181b21f8f50b"
-"checksum winpty-sys 1.1.0 (git+https://github.com/zacps/winpty?branch=rust)" = "<none>"
+"checksum winpty-sys 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)" = "bd075c24ae8cc8cfa57fd188683118d302c024a6b2413cc6c8d5406a59eca2e2"
"checksum winreg 0.4.0 (registry+https://github.com/rust-lang/crates.io-index)" = "cbf285379f20d7f26abd990d9a566be9d31ab7a9d335299baaa1f0604f5f96af"
"checksum ws2_32-sys 0.2.1 (registry+https://github.com/rust-lang/crates.io-index)" = "d59cefebd0c892fa2dd6de581e937301d8552cb44489cdff035c6187cb63fa5e"
"checksum x11-clipboard 0.2.2 (registry+https://github.com/rust-lang/crates.io-index)" = "2e7374c7699210cca7084ca61d57e09640fc744d1391808cb9ae2fe4ca9bd1df"
diff -Naur alacritty-0.2.3.orig/winpty/Cargo.lock alacritty-0.2.3/winpty/Cargo.lock
--- alacritty-0.2.3.orig/winpty/Cargo.lock 2018-11-14 05:58:10.000000000 +1300
+++ alacritty-0.2.3/winpty/Cargo.lock 2018-11-19 08:11:07.625659599 +1300
@@ -497,13 +497,13 @@
"named_pipe 0.3.0 (registry+https://github.com/rust-lang/crates.io-index)",
"widestring 0.2.2 (registry+https://github.com/rust-lang/crates.io-index)",
"winapi 0.3.5 (registry+https://github.com/rust-lang/crates.io-index)",
- "winpty-sys 1.1.0 (git+https://github.com/zacps/winpty?branch=rust)",
+ "winpty-sys 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)",
]
[[package]]
name = "winpty-sys"
version = "1.1.0"
-source = "git+https://github.com/zacps/winpty?branch=rust#be5fd7323b588b81294b1d0a670d2dbd5322ff00"
+source = "registry+https://github.com/rust-lang/crates.io-index"
dependencies = [
"bindgen 0.33.2 (registry+https://github.com/rust-lang/crates.io-index)",
"cc 1.0.17 (registry+https://github.com/rust-lang/crates.io-index)",
@@ -574,4 +574,4 @@
"checksum winapi-i686-pc-windows-gnu 0.4.0 (registry+https://github.com/rust-lang/crates.io-index)" = "ac3b87c63620426dd9b991e5ce0329eff545bccbbb34f3be09ff6fb6ab51b7b6"
"checksum winapi-x86_64-pc-windows-gnu 0.4.0 (registry+https://github.com/rust-lang/crates.io-index)" = "712e227841d057c1ee1cd2fb22fa7e5a5461ae8e48fa2ca79ec42cfc1931183f"
"checksum wincolor 0.1.6 (registry+https://github.com/rust-lang/crates.io-index)" = "eeb06499a3a4d44302791052df005d5232b927ed1a9658146d842165c4de7767"
-"checksum winpty-sys 1.1.0 (git+https://github.com/zacps/winpty?branch=rust)" = "<none>"
+"checksum winpty-sys 1.1.0 (registry+https://github.com/rust-lang/crates.io-index)" = "bd075c24ae8cc8cfa57fd188683118d302c024a6b2413cc6c8d5406a59eca2e2"
diff -Naur alacritty-0.2.3.orig/winpty/Cargo.toml alacritty-0.2.3/winpty/Cargo.toml
--- alacritty-0.2.3.orig/winpty/Cargo.toml 2018-11-14 05:58:10.000000000 +1300
+++ alacritty-0.2.3/winpty/Cargo.toml 2018-11-19 08:11:27.836348072 +1300
@@ -7,7 +7,7 @@
[target.'cfg(windows)'.dependencies]
# TODO: Replace with official repo
-winpty-sys = { git = "https://github.com/zacps/winpty", branch = "rust" }
+winpty-sys = "1.1.0"
bitflags = "1.0"
widestring = "0.2.2"