mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
development/valgrind: Updated for version 3.6.0.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
This commit is contained in:
parent
e6f8608b28
commit
9f8ebd0245
4 changed files with 18 additions and 72 deletions
|
@ -1,12 +1,13 @@
|
|||
Valgrind is an award-winning instrumentation framework for building dynamic
|
||||
analysis tools. There are Valgrind tools that can automatically detect many
|
||||
memory management and threading bugs, and profile your programs in detail.
|
||||
You can also use Valgrind to build new tools.
|
||||
Valgrind is a framework for building dynamic analysis tools. There are
|
||||
Valgrind tools that can automatically detect many memory management
|
||||
and threading bugs, and profile your programs in detail. You can also
|
||||
use Valgrind to build new tools.
|
||||
|
||||
The Valgrind distribution currently includes six production-quality tools: a
|
||||
memory error detector, two thread error detectors, a cache and
|
||||
branch-prediction profiler, a call-graph generating cache profiler, and a
|
||||
heap profiler. It also includes two experimental tools: a heap/stack/global
|
||||
array overrun detector, and a SimPoint basic block vector generator. It runs
|
||||
on the following platforms: X86/Linux, AMD64/Linux, PPC32/Linux, PPC64/Linux,
|
||||
and X86/Darwin (Mac OS X).
|
||||
The Valgrind distribution currently includes six production-quality
|
||||
tools: a memory error detector, two thread error detectors, a cache
|
||||
and branch-prediction profiler, a call-graph generating cache and
|
||||
branch-prediction profiler, and a heap profiler. It also includes
|
||||
three experimental tools: a heap/stack/global array overrun detector,
|
||||
a different kind of heap profiler, and a SimPoint basic block vector
|
||||
generator. It runs on the following platforms: x86/Linux, AMD64/Linux,
|
||||
PPC32/Linux, PPC64/Linux, ARM/Linux, x86/MacOSX and AMD64/MacOSX.
|
||||
|
|
|
@ -1,51 +0,0 @@
|
|||
From valgrind SVN
|
||||
------------------------------------------------------------------------
|
||||
r10941 | bart | 2009-11-16 06:11:19 +1100 (Mon, 16 Nov 2009) | 2 lines
|
||||
|
||||
Added support for glibc 2.11.
|
||||
|
||||
------------------------------------------------------------------------
|
||||
Index: configure.in
|
||||
===================================================================
|
||||
--- configure.in (revision 10940)
|
||||
+++ configure.in (revision 10941)
|
||||
@@ -656,6 +656,16 @@
|
||||
],
|
||||
GLIBC_VERSION="2.10")
|
||||
|
||||
+AC_EGREP_CPP([GLIBC_211], [
|
||||
+#include <features.h>
|
||||
+#ifdef __GNU_LIBRARY__
|
||||
+ #if (__GLIBC__ == 2 && __GLIBC_MINOR__ == 11)
|
||||
+ GLIBC_211
|
||||
+ #endif
|
||||
+#endif
|
||||
+],
|
||||
+GLIBC_VERSION="2.11")
|
||||
+
|
||||
AC_EGREP_CPP([AIX5_LIBC], [
|
||||
#include <standards.h>
|
||||
#if defined(_AIXVERSION_510) || defined(_AIXVERSION_520) || defined(_AIXVERSION_530)
|
||||
@@ -742,6 +752,13 @@
|
||||
DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
|
||||
DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
|
||||
;;
|
||||
+ 2.11)
|
||||
+ AC_MSG_RESULT(2.11 family)
|
||||
+ AC_DEFINE([GLIBC_2_11], 1, [Define to 1 if you're using glibc 2.11.x])
|
||||
+ DEFAULT_SUPP="glibc-2.X.supp ${DEFAULT_SUPP}"
|
||||
+ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
|
||||
+ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
|
||||
+ ;;
|
||||
aix5)
|
||||
AC_MSG_RESULT(AIX 5.1 or 5.2 or 5.3)
|
||||
AC_DEFINE([AIX5_LIBC], 1, [Define to 1 if you're using AIX 5.1 or 5.2 or 5.3])
|
||||
@@ -755,7 +772,7 @@
|
||||
|
||||
*)
|
||||
AC_MSG_RESULT(unsupported version)
|
||||
- AC_MSG_ERROR([Valgrind requires glibc version 2.2 - 2.10])
|
||||
+ AC_MSG_ERROR([Valgrind requires glibc version 2.2 - 2.11])
|
||||
AC_MSG_ERROR([or AIX 5.1 or 5.2 or 5.3 GLIBC_VERSION])
|
||||
AC_MSG_ERROR([or Darwin libc])
|
||||
;;
|
|
@ -5,8 +5,8 @@
|
|||
# Updated by Peter Wang <novalazy@gmail.com>
|
||||
|
||||
PRGNAM=valgrind
|
||||
VERSION=3.5.0
|
||||
BUILD=${BUILD:-2}
|
||||
VERSION=3.6.0
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
# Automatically determine the architecture we're building on:
|
||||
|
@ -47,10 +47,6 @@ cd $PRGNAM-$VERSION || exit 1
|
|||
chown -R root:root .
|
||||
chmod -R u+w,go+r-w,a-s .
|
||||
|
||||
# For compatibility with -current; thanks to Arne Welzel for the report.
|
||||
patch -p0 < $CWD/valgrind-3.5.0-glibc-2.11.patch || exit 1
|
||||
autoconf || exit 1
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="valgrind"
|
||||
VERSION="3.5.0"
|
||||
VERSION="3.6.0"
|
||||
HOMEPAGE="http://www.valgrind.org/"
|
||||
DOWNLOAD="http://www.valgrind.org/downloads/valgrind-3.5.0.tar.bz2"
|
||||
MD5SUM="f03522a4687cf76c676c9494fcc0a517"
|
||||
DOWNLOAD="http://www.valgrind.org/downloads/valgrind-3.6.0.tar.bz2"
|
||||
MD5SUM="b289c5f4ab8e39741602445f1dd09b34"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Peter Wang"
|
||||
EMAIL="novalazy@gmail.com"
|
||||
APPROVED="pprkut"
|
||||
APPROVED="dsomero"
|
||||
|
|
Loading…
Reference in a new issue