libraries/stfl: Added (Structured Terminal Forms Language/Library)

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Benjamin Trigona-Harany 2011-01-11 22:36:22 -06:00 committed by Robby Workman
parent bea5266ea5
commit 9d3e77a0b4
5 changed files with 128 additions and 0 deletions

7
libraries/stfl/README Normal file
View file

@ -0,0 +1,7 @@
The Structured Terminal Forms Language/Library
STFL is a library which implements a curses-based widget set for text
terminals. The STFL API can be used from C, SPL, Python, Perl and
Ruby. The public STFL API is only 14 simple function calls big and
and there are already generic SWIG bindings; thus it is very easy to
port to additional scripting languages.

View file

@ -0,0 +1,13 @@
diff -Nur stfl-0.21.orig//Makefile stfl-0.21/Makefile
--- stfl-0.21.orig//Makefile 2009-06-19 12:30:52.000000000 -0500
+++ stfl-0.21/Makefile 2011-01-11 22:21:10.623044411 -0600
@@ -21,7 +21,8 @@
include Makefile.cfg
export CC = gcc -pthread
-export CFLAGS += -I. -Wall -Os -ggdb -D_GNU_SOURCE -fPIC
+OPTS = -Os
+export CFLAGS += -I. -Wall $(OPTS) -ggdb -D_GNU_SOURCE -fPIC
export LDLIBS += -lncursesw
SONAME := libstfl.so.0

19
libraries/stfl/slack-desc Normal file
View file

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler--------------------------------------------------------|
stfl: STFL (the Structured Terminal Forms Language/Library)
stfl:
stfl: STFL is a library which implements a curses-based widget set for text
stfl: terminals. The STFL API can be used from C, SPL, Python, Perl and
stfl: Ruby. The public STFL API is only 14 simple function calls big and and
stfl: there are already generic SWIG bindings. Thus it is very easy to port
stfl: to additional scripting languages.
stfl:
stfl: Homepage: http://www.clifford.at/stfl/
stfl:
stfl:

View file

@ -0,0 +1,79 @@
#!/bin/sh
# Slackware build script for stfl
# Originally written by slakmagik <jsun@freeshell.org>
# Maintained by Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
# Released under the WTFPL
PRGNAM=stfl
VERSION=${VERSION:-0.21}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
-o -perm 400 \) -exec chmod 644 {} \;
# Allow custom options in Makefile
patch -p1 < $CWD/allow-custom-opts-in-Makefile.patch
make install \
OPTS="$SLKCFLAGS" \
prefix=/usr \
mandir=/usr/man \
libdir=lib${LIBDIRSUFFIX} \
DESTDIR=$PKG
find $PKG -name perllocal.pod -o -name ".packlist" -o -name "*.bs" | xargs rm -f || true
find $PKG -depth -type d -empty -delete || true
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

10
libraries/stfl/stfl.info Normal file
View file

@ -0,0 +1,10 @@
PRGNAM="stfl"
VERSION="0.21"
HOMEPAGE="http://www.clifford.at/stfl/"
DOWNLOAD="http://www.clifford.at/stfl/stfl-0.21.tar.gz"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MD5SUM="888502c3f332a0ee66e490690d79d404"
MAINTAINER="Benjamin Trigona-Harany"
EMAIL="bosth@alumni.sfu.ca"
APPROVED="rworkman"