development/4th: Updated for version 3.64.1.

Signed-off-by: Dave Woodfall <dave@slackbuilds.org>
This commit is contained in:
Zbigniew Baniewski 2022-09-08 22:20:33 +01:00 committed by Dave Woodfall
parent f3528ad44c
commit 9bd2d4882c
5 changed files with 32 additions and 28 deletions

View file

@ -1,6 +1,6 @@
diff -Nur 4th-3.62.5-unix/sources/Makefile 4th-3.62.5-unix.new/sources/Makefile
--- 4th-3.62.5-unix/sources/Makefile 2015-04-23 07:59:18.000000000 +0200
+++ 4th-3.62.5-unix.new/sources/Makefile 2018-01-27 01:39:36.000000000 +0100
diff -Nur 4th-3.64.1/sources/Makefile 4th-3.64.1.new/sources/Makefile
--- 4th-3.64.1/sources/Makefile 2021-07-25 11:38:40.000000000 +0200
+++ 4th-3.64.1.new/sources/Makefile 2022-01-20 18:41:25.393103893 +0100
@@ -13,13 +13,13 @@
# The following variables may need to be changed
@ -26,7 +26,7 @@ diff -Nur 4th-3.62.5-unix/sources/Makefile 4th-3.62.5-unix.new/sources/Makefile
install: mostlyinstall
install -Dm644 ../documentation/4th.1 $(MANDIR)/man1/4th.1
- install -Dm644 ../documentation/4tHmanual.txt $(DOCDIR)/4th/
+ install -Dm644 ../documentation/4tHmanual.txt $(DOCDIR)/4th-3.62.5/
+ install -Dm644 ../documentation/4tHmanual.pdf $(DOCDIR)/4th-3.64.1/
+ install -Dm644 ../sources/4th.h $(INCLUDES)/4th.h
uninstall:

View file

@ -1,7 +1,7 @@
diff -Nur 4th-3.62.5-unix/sources/4th.h 4th-3.62.5-unix.new/sources/4th.h
--- 4th-3.62.5-unix/sources/4th.h 2012-04-09 18:15:03.000000000 +0200
+++ 4th-3.62.5-unix.new/sources/4th.h 2014-04-13 16:23:07.122971512 +0200
@@ -62,8 +62,8 @@
diff -Nur 4th-3.64.1/sources/4th.h 4th-3.64.1.new/sources/4th.h
--- 4th-3.64.1/sources/4th.h 2019-03-17 17:32:08.000000000 +0100
+++ 4th-3.64.1.new/sources/4th.h 2022-01-20 19:38:11.022969349 +0100
@@ -62,12 +62,12 @@
#define M4BADNAM 28
#define M4CABORT 29
@ -10,5 +10,10 @@ diff -Nur 4th-3.62.5-unix/sources/4th.h 4th-3.62.5-unix.new/sources/4th.h
+#define CELL_MIN INT_MIN
+#define CELL_MAX INT_MAX
typedef long cell;
#define SYMLEN 24 /* length of word name (incl. \0) */
-typedef long cell;
+typedef int cell;
typedef unsigned char unit;
typedef struct {

View file

@ -4,13 +4,11 @@
# Written by Zbigniew Baniewski <Zbigniew [dot] Baniewski [at] gmail [dot] com>
# 20220407 bkw: Modified by SlackBuilds.org, BUILD=2: fix doc permissions.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=4th
VERSION=${VERSION:-3.62.5}
BUILD=${BUILD:-2}
VERSION=${VERSION:-3.64.1}
BUILD=${BUILD:-0}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@ -50,10 +48,10 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION-unix
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION-unix.tar.gz
cat $CWD/01-directories.patch | patch -p0 || exit
cd $PRGNAM-$VERSION-unix/sources
cd $PRGNAM-$VERSION/sources
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@ -63,7 +61,6 @@ find -L . \
if [ "$ARCH" = "x86_64" ]; then
cat $CWD/02-to_preserve_32bit_compatibility.patch | patch -p2 || exit
cp include/* .
fi
mkdir -p $PKG/usr/lib$LIBDIRSUFFIX
@ -76,20 +73,22 @@ make install DESTDIR="$PKG" LIBSUFFIX="$LIBDIRSUFFIX"
gzip -9 $PKG/usr/man/man*/*
strip $PKG/usr/bin/*
cp $TMP/$PRGNAM-$VERSION-unix/documentation/*.txt $PKG/usr/doc/$PRGNAM-$VERSION
cp $TMP/$PRGNAM-$VERSION-unix/4th/.directory $PKG/usr/doc/$PRGNAM-$VERSION
cp $TMP/$PRGNAM-$VERSION-unix/COPYING $PKG/usr/doc/$PRGNAM-$VERSION
cp $TMP/$PRGNAM-$VERSION-unix/README $PKG/usr/doc/$PRGNAM-$VERSION
cp -r $TMP/$PRGNAM-$VERSION-unix/4th/* $PKG/usr/doc/$PRGNAM-$VERSION/examples
cp $TMP/$PRGNAM-$VERSION/documentation/4th.1 $PKG/usr/man/man1
cp $TMP/$PRGNAM-$VERSION/documentation/*.txt $PKG/usr/doc/$PRGNAM-$VERSION
cp $TMP/$PRGNAM-$VERSION/COPYING $PKG/usr/doc/$PRGNAM-$VERSION
cp $TMP/$PRGNAM-$VERSION/README $PKG/usr/doc/$PRGNAM-$VERSION
cp -r $TMP/$PRGNAM-$VERSION/4th/* $PKG/usr/doc/$PRGNAM-$VERSION/examples
# 20220407 bkw: junk files and bad permissions...
find $PKG/usr/doc/$PRGNAM-$VERSION -name .directory -exec rm -rf {} \+
find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 0644 {} \+
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
chmod 644 $PKG/usr/doc/$PRGNAM-$VERSION/examples/apps/graphics/hans.ppm
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
rm $PKG/usr/man/man1/4th.1
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE

View file

@ -1,8 +1,8 @@
PRGNAM="4th"
VERSION="3.62.5"
HOMEPAGE="http://thebeez.home.xs4all.nl/4tH/"
DOWNLOAD="http://downloads.sourceforge.net/project/forth-4th/4th-3.62.5/4th-3.62.5-unix.tar.gz"
MD5SUM="caf85244354320daecec58b9451ce0cd"
VERSION="3.64.1"
HOMEPAGE="https://thebeez.home.xs4all.nl/4tH/4thfaces.html"
DOWNLOAD="http://downloads.sourceforge.net/project/forth-4th/4th-3.64.1/4th-3.64.1-unix.tar.gz"
MD5SUM="82fa4fbe11e3b004affb1c374c75093e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""

View file

@ -11,7 +11,7 @@
4th: It detects virtually every error and reports what and where
4th: they occur, but is still fast and compact.
4th:
4th: http://www.gnu.org/software/4th/
4th: https://thebeez.home.xs4all.nl/4tH/4thfaces.html
4th:
4th: Licence: GNU LGPL V3
4th: