mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
audio/plug: Updated for version 1.4.5.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
f38b4f0a4f
commit
9b65a74ecb
3 changed files with 20 additions and 8 deletions
11
audio/plug/CMakeLists.txt.patch
Normal file
11
audio/plug/CMakeLists.txt.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- CMakeLists.txt 2023-12-03 14:22:05.000000000 +0000
|
||||
+++ CMakeLists.txt.new 2023-12-04 22:05:56.210467471 +0000
|
||||
@@ -4,7 +4,7 @@
|
||||
message(STATUS "~~~ ${PROJECT_NAME} v${PROJECT_VERSION} ~~~")
|
||||
|
||||
list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
|
||||
-option(PLUG_UNITTEST "Build Unit Tests" ON)
|
||||
+option(PLUG_UNITTEST "Build Unit Tests" OFF)
|
||||
message(STATUS "Unit Tests : ${PLUG_UNITTEST}")
|
||||
|
||||
option(PLUG_COVERAGE "Enable Coverage" OFF)
|
9
audio/plug/plug.SlackBuild
Normal file → Executable file
9
audio/plug/plug.SlackBuild
Normal file → Executable file
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for plug
|
||||
|
||||
# Copyright 2022 Antonio Leal, Lisbon, Portugal
|
||||
# Copyright 2022-2023 Antonio Leal, Porto Salvo, Oeiras, Portugal
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -26,7 +26,7 @@
|
|||
cd $(dirname $0) ; CWD=$(pwd)
|
||||
|
||||
PRGNAM=plug
|
||||
VERSION=${VERSION:-1.4.3}
|
||||
VERSION=${VERSION:-1.4.5}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
|
@ -79,17 +79,18 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
patch CMakeLists.txt $CWD/CMakeLists.txt.patch
|
||||
|
||||
mkdir build
|
||||
cd build
|
||||
cmake ..
|
||||
make
|
||||
make unittest
|
||||
#make unittest
|
||||
|
||||
mkdir -p $PKG/usr/bin
|
||||
cp $BUILDDIR/build/src/plug $PKG/usr/bin
|
||||
mkdir -p $PKG/lib/udev/rules.d
|
||||
cp $BUILDDIR/cmake/50-mustang.rules $PKG/lib/udev/rules.d
|
||||
cp $BUILDDIR/cmake/*.rules $PKG/lib/udev/rules.d
|
||||
mkdir -p $PKG/usr/share/pixmaps
|
||||
cp $CWD/plug.png $PKG/usr/share/pixmaps
|
||||
mkdir -p $PKG/usr/share/applications
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="plug"
|
||||
VERSION="1.4.3"
|
||||
VERSION="1.4.5"
|
||||
HOMEPAGE="https://github.com/offa/plug"
|
||||
DOWNLOAD="https://github.com/offa/plug/archive/v1.4.3/plug-1.4.3.tar.gz"
|
||||
MD5SUM="69b7dfffaecc0ceec038267ae9981750"
|
||||
DOWNLOAD="https://github.com/offa/plug/archive/v1.4.5/plug-1.4.5.tar.gz"
|
||||
MD5SUM="c86d1dc7f4c44a8247199eaf3b6c448b"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="gtest"
|
||||
REQUIRES=""
|
||||
MAINTAINER="Antonio Leal"
|
||||
EMAIL="antonioleal@yahoo.com"
|
||||
|
|
Loading…
Reference in a new issue