mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-20 19:41:34 +01:00
accessibility/flite: Updated for version 1.3
This commit is contained in:
parent
48a95b3b85
commit
9a530f53d2
5 changed files with 46 additions and 31 deletions
|
@ -1,6 +1,3 @@
|
|||
Flite is a small, fast run-time synthesis engine, designed for
|
||||
embedded systems and servers. Flite was developed by Alan W Black and
|
||||
Kevin Lenzo at Carnegie Mellon University, in Pittsburgh. The
|
||||
city with TTS at its heart.
|
||||
|
||||
This script builds flite with the 16bit voice enabled my default.
|
||||
Kevin Lenzo at Carnegie Mellon University, in Pittsburgh.
|
||||
|
|
12
accessibility/flite/flite-1.3-install_libs.diff
Normal file
12
accessibility/flite/flite-1.3-install_libs.diff
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -Nur flite-1.3-release.orig/Makefile flite-1.3-release/Makefile
|
||||
--- flite-1.3-release.orig/Makefile 2005-11-01 07:40:45.000000000 -0600
|
||||
+++ flite-1.3-release/Makefile 2009-07-12 17:40:07.408702338 -0500
|
||||
@@ -109,7 +109,7 @@
|
||||
mkdir -p $(INSTALLLIBDIR)
|
||||
mkdir -p $(INSTALLINCDIR)
|
||||
$(INSTALL) -m 644 include/*.h $(INSTALLINCDIR)
|
||||
- @ $(MAKE) -C lib --no-print-directory install
|
||||
+ $(INSTALL) -m 644 $(LIBDIR)/*.a $(INSTALLLIBDIR)
|
||||
$(INSTALL) -m 755 bin/flite $(INSTALLBINDIR)
|
||||
$(INSTALL) -m 755 bin/flite_time $(INSTALLBINDIR)
|
||||
|
|
@ -3,14 +3,12 @@
|
|||
# Slackware build script for flite
|
||||
# Written by Martin Lefebvre (dadexter@sekurity.com)
|
||||
|
||||
# Exit on most errors
|
||||
set -e
|
||||
|
||||
PRGNAM=flite
|
||||
VERSION=1.3
|
||||
ARCH=${ARCH:-i486}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
|
@ -18,49 +16,55 @@ OUTPUT=${OUTPUT:-/tmp}
|
|||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION-release
|
||||
tar -xzvf $CWD/$PRGNAM-$VERSION-release.tar.gz
|
||||
tar xvf $CWD/$PRGNAM-$VERSION-release.tar.gz
|
||||
cd $PRGNAM-$VERSION-release
|
||||
chown -R root:root . || true
|
||||
chown -R root:root .
|
||||
chmod -R u+w,go+r-w,a-s .
|
||||
|
||||
patch -p1 < $CWD/flite-1.3-install_libs.diff
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--with-vox=cmu_us_kal16
|
||||
|
||||
sed -i 's#@ $(MAKE) -C lib --no-print-directory install#$(INSTALL) -m 644 build/i386-linux-gnu/lib/*.a $(INSTALLLIBDIR)#g' Makefile
|
||||
--with-vox=cmu_us_kal16 \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
make
|
||||
make install prefix=$PKG/usr
|
||||
make install prefix=$PKG/usr INSTALLLIBDIR=$PKG/usr/lib${LIBDIRSUFFIX}
|
||||
|
||||
( cd $PKG
|
||||
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
||||
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
||||
)
|
||||
|
||||
( cd $PKG/usr/man
|
||||
find . -type f -exec gzip -9 {} \;
|
||||
for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
|
||||
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
|
||||
xargs strip --strip-unneeded 2> /dev/null
|
||||
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
|
||||
xargs strip --strip-unneeded 2> /dev/null
|
||||
)
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a ACKNOWLEDGEMENTS COPYING README doc/* $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
rm $PKG/usr/doc/$PRGNAM-$VERSION/Makefile
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
rm -f $PKG/usr/doc/$PRGNAM-$VERSION/Makefile*
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
||||
|
|
|
@ -1,8 +1,10 @@
|
|||
PRGNAM="flite"
|
||||
VERSION="1.3"
|
||||
HOMEPAGE="http://fife.speech.cs.cmu.edu/flite/"
|
||||
DOWNLOAD="http://fife.speech.cs.cmu.edu/flite/packed/flite-1.3/flite-1.3-release.tar.gz"
|
||||
HOMEPAGE="http://www.speech.cs.cmu.edu/flite/"
|
||||
DOWNLOAD="http://www.speech.cs.cmu.edu/flite/packed/flite-1.3/flite-1.3-release.tar.gz"
|
||||
MD5SUM="ae0aca1cb7b4801f4372f3a75a9e52b5"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Martin Lefebvre"
|
||||
EMAIL="dadexter@sekurity.com.com"
|
||||
APPROVED="rworkman"
|
||||
|
|
|
@ -7,13 +7,13 @@
|
|||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
flite: flite (speech synthesis engine)
|
||||
flite:
|
||||
flite:
|
||||
flite: Flite is a small and fast run-time synthesis engine designed for
|
||||
flite: embedded systems and servers. Flite was developed by Alan W Black
|
||||
flite: and Kevin Lenzo at Carnegie Mellon University, in Pittsburgh.
|
||||
flite:
|
||||
flite:
|
||||
flite:
|
||||
flite:
|
||||
flite:
|
||||
flite:
|
||||
flite:
|
||||
flite:
|
||||
flite:
|
||||
flite:
|
||||
flite:
|
||||
flite:
|
||||
|
|
Loading…
Reference in a new issue