games/unknown-horizons: Updated for version 2014.1.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Dimitris Zlatanidis 2015-01-09 22:53:54 +07:00 committed by Willy Sudiarto Raharjo
parent d8221c02dc
commit 9a132a1562
4 changed files with 34 additions and 5 deletions

View file

@ -4,3 +4,6 @@ settlement to a strong and wealthy colony, collect taxes and
supply your inhabitants with valuable goods. Increase your
power with a well balanced economy and with strategic trade
and diplomacy.
Optional: pynet (feature for multiplayer)
not available from SBo

View file

@ -0,0 +1,24 @@
From 405c514eab9e2abffe8d1a8912646447e6a29cfa Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Kilian=20K=C3=B6ppchen?= <kiliankoeppchen@googlemail.com>
Date: Fri, 2 Jan 2015 22:52:54 +0100
Subject: [PATCH] Use animationloader instead of imagemanager to
retrieve images. The imagemanager isn't necessarily aware of
the files available as animations.
---
horizons/component/coloroverlaycomponent.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/horizons/component/coloroverlaycomponent.py b/horizons/component/coloroverlaycomponent.py
index 23d138b..41bbbff 100644
--- a/horizons/component/coloroverlaycomponent.py
+++ b/horizons/component/coloroverlaycomponent.py
@@ -166,7 +166,7 @@ def add_overlay(self, overlay_name, z_order):
except TypeError:
# not using atlases
frame_length = frame_data
- pic = horizons.globals.fife.imagemanager.load(frame_img)
+ pic = horizons.globals.fife.animationloader.load_image(frame_img, self.action_set, overlay_name, rotation)
frame_milliseconds = int(frame_length * 1000)
ov_anim.addFrame(pic, frame_milliseconds)
overlay = fife.OverlayColors(ov_anim)

View file

@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=unknown-horizons
VERSION=${VERSION:-2013.3}
VERSION=${VERSION:-2014.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -69,13 +69,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch -p1 < $CWD/coloroverlaycomponent.patch
python setup.py install --root=$PKG
mkdir -p $PKG/usr/share/applications
install -D -m644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
mkdir -p $PKG/usr/share/pixmaps/
install -D -m644 content/$PRGNAM.xpm $PKG/usr/share/pixmaps/$PRGNAM.svg
install -D -m644 content/gfx/uh.png $PKG/usr/share/pixmaps/$PRGNAM.png
mkdir -p $PKG/usr/man
mv $PKG/usr/share/man/man6 $PKG/usr/man

View file

@ -1,8 +1,8 @@
PRGNAM="unknown-horizons"
VERSION="2013.3"
VERSION="2014.1"
HOMEPAGE="http://www.unknown-horizons.org"
DOWNLOAD="https://github.com/unknown-horizons/unknown-horizons/archive/2013.3.tar.gz"
MD5SUM="ccacd4b6de509baccd045e88324c7d2e"
DOWNLOAD="https://github.com/unknown-horizons/unknown-horizons/archive/2014.1.tar.gz"
MD5SUM="e308539649c7c42da34a463af7f6c946"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="fifengine PyYAML"