audio/moc: Moved from multimedia

This commit is contained in:
Heinz Wiesinger 2010-05-11 20:30:49 +02:00
parent 999c1ed65a
commit 96d9d5a9a4
6 changed files with 49 additions and 10 deletions

View file

@ -0,0 +1,10 @@
--- configure.in~ 2008-06-25 18:41:07.000000000 +0200
+++ configure.in 2008-06-25 18:41:15.000000000 +0200
@@ -383,6 +383,7 @@
DECODER_PLUGINS="$DECODER_PLUGINS ffmpeg"],
[true])
fi
+ AC_CHECK_HEADERS(ffmpeg/avformat.h libavformat/avformat.h)
fi
dnl speex

14
audio/moc/ffmpeg.c.diff Normal file
View file

@ -0,0 +1,14 @@
--- decoder_plugins/ffmpeg/ffmpeg.c~ 2008-06-25 18:43:02.000000000 +0200
+++ decoder_plugins/ffmpeg/ffmpeg.c 2008-06-25 18:43:15.000000000 +0200
@@ -22,7 +22,11 @@
#ifdef HAVE_INTTYPES_H
# include <inttypes.h>
#endif
+#if HAVE_LIBAVFORMAT_AVFORMAT_H
+#include <libavformat/avformat.h>
+#else
#include <ffmpeg/avformat.h>
+#endif
/* FFmpeg also likes common names, without that, our common.h and log.h would
* not be included. */

View file

@ -25,8 +25,9 @@
PRGNAM=moc
VERSION=2.4.3
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
@ -39,27 +40,41 @@ if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP || exit 1
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2 || exit 1
cd $PRGNAM-$VERSION || exit 1
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Patch configure.in and ffmpeg.c for use with newer
# ffmpeg versions
patch -p0 < $CWD/configure.in.diff
patch -p0 < $CWD/ffmpeg.c.diff
aclocal -I m4 && automake && autoconf
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--mandir=/usr/man \
--disable-debug \
|| exit 1
--disable-debug
make || exit 1
make install-strip DESTDIR=$PKG || exit 1
make
make install-strip DESTDIR=$PKG
gzip -9 $PKG/usr/man/man1/*.?

View file

@ -5,4 +5,4 @@ DOWNLOAD="ftp://ftp.daper.net/pub/soft/moc/stable/moc-2.4.3.tar.bz2"
MD5SUM="8808082848e90eeec5415baaec7e98ad"
MAINTAINER="Michael Wagner"
EMAIL="lapinours@web.de"
APPROVED="rworkman"
APPROVED="David Somero"