graphics/povray: Updated for version 3.8.0_beta.2.

Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com>

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
klaatu 2022-03-09 08:16:19 +13:00 committed by Willy Sudiarto Raharjo
parent 1ed44054b6
commit 9485e97be5
No known key found for this signature in database
GPG key ID: 3F617144D7238786
5 changed files with 38 additions and 60 deletions

View file

@ -1,5 +1,5 @@
POV-Ray: The Persistence of Vision Raytracer is a high-quality,
totally free tool for creating stunning three-dimensional graphics.
totally free tool for creating stunning 3D graphics.
The author of POV-Ray asks users who build their own binaries to
include their name and e-mail in the final result.
@ -7,7 +7,7 @@ include their name and e-mail in the final result.
The included SlackBuild offers this possibility by entering the
information on the command line like this:
# POVRAY_BUILDER="your name <email@address>" ./povray.SlackBuild
# POVRAY_BUILDER="your name <email@address>" ./povray.SlackBuild
If you leave this variable empty, it will be supplied by the
If you leave this variable empty, it's supplied by the
SlackBuild script as "`whoami` on `hostname`"

View file

@ -11,10 +11,10 @@ config() {
# Otherwise, we leave the .new copy for the admin to consider...
}
config etc/povray/@VERSION@/povray.conf.new
config etc/povray/@VERSION@/povray.ini.new
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
if [ -e /etc/povray/@VERSION@/povray.conf.new ]; then
config /etc/povray/@VERSION@/povray.conf.new
fi
if [ -e /etc/povray/@VERSION@/povray.ini.new ]; then
config /etc/povray/@VERSION@/povray.ini.new
fi

View file

@ -3,8 +3,8 @@
# Slackware build script for povray:
# the Persistence of Vision Raytracer
# Maintainer: Klaatu
# Thanks to: Franzen
# Maintainer: Klaatu <klaatu@member.fsf.org>
# Thanks to Franzen
# Copyright 2009,2011,2013 Niels Horn, Rio de Janeiro, RJ, Brazil
# All rights reserved.
@ -28,15 +28,17 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=povray
VERSION=${VERSION:-3.7.0.8}
SRCNAM=povunix
VERSION=${VERSION:-3.8.0_beta.2}
SRCVER=${SRCVER:-v3.8.0-beta.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
DOCDIR=${DOCDIR:-/usr/doc}
MANDIR=${MANDIR:-/usr/man}
# The "short" version number is needed later:
SHORT_VERSION=$( echo $VERSION | cut -f1-2 -d. )
# Short version number is generated during compilation
SHORTVER=$( echo $VERSION | cut -f1-2 -d. )
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@ -46,9 +48,7 @@ if [ -z "$ARCH" ]; then
esac
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
# If PRINT_PACKAGE_NAME is set, print the name of the package
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@ -80,7 +80,9 @@ set -e
rm -rf $TMP/$PRGNAM-$VERSION $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
mkdir $PRGNAM-$VERSION
tar xvf $CWD/$SRCNAM-$SRCVER-src.tar.?z* \
--strip-components=1 -C $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@ -89,19 +91,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# make sure no bundled static libs can be used
rm -r libraries
(
cd unix
sed 's/automake --w/automake --add-missing --w/g' -i prebuild.sh
# Prevent march=nativ for compatibility
sed "s/native/$ARCH/g" -i configure.ac
# By disabling march=nativ, compatibilitybreaking optimizations like sse4 may arize by prebuild.sh
# By disabling march=nativ, compatibility-breaking optimizations may arise
sed "s/ax_x86_cpuflags=.*/unset ax_x86_cpuflags/g" -i config/ax_x86_arch.m4
# prevent creating files in $HOME while building
patch prebuild.sh $CWD/prebuild.patch
sh ./prebuild.sh
)
CXXFLAGS="$SLKCFLAGS" \
@ -110,6 +105,7 @@ CXXFLAGS="$SLKCFLAGS" \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--docdir=$DOCDIR \
--mandir=$MANDIR \
--build=$ARCH-slackware-linux \
LIBS="-lboost_system -lboost_thread" \
@ -125,25 +121,30 @@ find $PKG/$MANDIR -type f -exec gzip -9 {} \;
for i in $( find $PKG/$MANDIR -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
# Rename configuration files to .new, will be checked by doinst.sh
mv $PKG/etc/$PRGNAM/$SHORT_VERSION/$PRGNAM.conf \
$PKG/etc/$PRGNAM/$SHORT_VERSION/$PRGNAM.conf.new
mv $PKG/etc/$PRGNAM/$SHORT_VERSION/$PRGNAM.ini \
$PKG/etc/$PRGNAM/$SHORT_VERSION/$PRGNAM.ini.new
mv $PKG/etc/$PRGNAM/$SHORTVER/$PRGNAM.conf \
$PKG/etc/$PRGNAM/$SHORTVER/$PRGNAM.conf.new
mv $PKG/etc/$PRGNAM/$SHORTVER/$PRGNAM.ini \
$PKG/etc/$PRGNAM/$SHORTVER/$PRGNAM.ini.new
# ./configure does not accept docdir; move docs manually as needed
# fix scripts
find $PKG/usr/share/$PRGNAM-$SHORTVER/scripts/ -type f \
-name "*.sh" | xargs sed -i "s/\r//"
# ./configure ignores DOCDIR; move docs manually
if [ "$DOCDIR" != "/usr/share/doc" ]; then
mkdir -p $PKG/$DOCDIR/$PRGNAM-$VERSION
mv $PKG/usr/share/doc/$PRGNAM-$SHORT_VERSION/* $PKG/$DOCDIR/$PRGNAM-$VERSION/
rm -r $PKG/usr/share/doc
mv $PKG/usr/share/doc/$PRGNAM-$SHORTVER $PKG/$DOCDIR/$PRGNAM-$VERSION
rmdir $PKG/usr/share/doc
fi
cp -a COPYING INSTALL $PKG/$DOCDIR/$PRGNAM-$VERSION
cp -a COPYING INSTALL AUTHORS changes.txt revision.txt \
README.md kde_install.sh $PKG/$DOCDIR/$PRGNAM-$VERSION
find $PKG/$DOCDIR/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
cat $CWD/$PRGNAM.SlackBuild > $PKG/$DOCDIR/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
sed "s,@VERSION@,$SHORT_VERSION,g" $CWD/doinst.sh > $PKG/install/doinst.sh
sed "s,@VERSION@,$VERSION,g" $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE

View file

@ -1,8 +1,8 @@
PRGNAM="povray"
VERSION="3.7.0.8"
VERSION="3.8.0_beta.2"
HOMEPAGE="http://www.povray.org/"
DOWNLOAD="https://github.com/POV-Ray/povray/archive/v3.7.0.8/povray-3.7.0.8.tar.gz"
MD5SUM="ec56b6a59e383e85369850841f910cff"
DOWNLOAD="https://github.com/POV-Ray/povray/releases/download/v3.8.0-beta.2/povunix-v3.8.0-beta.2-src.tar.gz"
MD5SUM="c4eb48935009b5b5387b4b676da38c9d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""

View file

@ -1,23 +0,0 @@
--- prebuild.sh.orig 2016-07-03 14:54:38.000000000 +0200
+++ prebuild.sh 2016-07-03 14:56:10.000000000 +0200
@@ -642,19 +642,6 @@
for f in \$\$filelist ; do \\
\$(INSTALL_DATA) \$(top_srcdir)/doc/\$\$f \$(DESTDIR)\$(povdocdir)/\$\$f && echo "\$(DESTDIR)\$(povdocdir)/\$\$f" >> \$(povinstall); \\
done
- @echo "Creating user directories..."; \\
- for p in \$(povuser) \$(povconfuser) ; do \\
- \$(mkdir_p) \$\$p && chown \$(povowner) \$\$p && chgrp \$(povgroup) \$\$p && printf "%s\\n" "\$\$p" "\`cat \$(povinstall)\`" > \$(povinstall); \\
- done
- @echo "Copying user configuration and INI files..."; \\
- for f in povray.conf povray.ini ; do \\
- if test -f \$(povconfuser)/\$\$f; then \\
- echo "Creating backup of \$(povconfuser)/\$\$f"; \\
- mv -f \$(povconfuser)/\$\$f \$(povconfuser)/\$\$f.bak; \\
- fi; \\
- done; \\
- \$(INSTALL_DATA) \$(top_srcdir)/povray.conf \$(povconfuser)/povray.conf && chown \$(povowner) \$(povconfuser)/povray.conf && chgrp \$(povgroup) \$(povconfuser)/povray.conf && echo "\$(povconfuser)/povray.conf" >> \$(povinstall); \\
- \$(INSTALL_DATA) \$(top_builddir)/povray.ini \$(povconfuser)/povray.ini && chown \$(povowner) \$(povconfuser)/povray.ini && chgrp \$(povgroup) \$(povconfuser)/povray.ini && echo "\$(povconfuser)/povray.ini" >> \$(povinstall)
# Remove data, config, and empty folders for 'make uninstall'.
# Use 'hook' instead of 'local' so as to properly remove *empty* folders (e.g. scripts).