mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
multimedia/miro: Updated for version 6.0.
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
This commit is contained in:
parent
111dda83f3
commit
8fb81a141d
3 changed files with 6 additions and 73 deletions
|
@ -1,63 +0,0 @@
|
|||
--- miro-5.0.1/linux/miro-segmenter.c~ 2012-07-06 14:33:24.618082171 +0000
|
||||
+++ miro-5.0.1/linux/miro-segmenter.c 2012-07-06 15:10:19.564146117 +0000
|
||||
@@ -156,7 +156,7 @@
|
||||
exit(1);
|
||||
}
|
||||
|
||||
- ret = av_open_input_file(&ic, input, ifmt, 0, NULL);
|
||||
+ ret = avformat_open_input(&ic, input, ifmt, 0);
|
||||
if (ret != 0) {
|
||||
fprintf(stderr, "Could not open input file, make sure it is an mpegts file: %d\n", ret);
|
||||
exit(1);
|
||||
@@ -215,12 +215,7 @@
|
||||
}
|
||||
}
|
||||
|
||||
- if (av_set_parameters(oc, NULL) < 0) {
|
||||
- fprintf(stderr, "Invalid output format parameters\n");
|
||||
- exit(1);
|
||||
- }
|
||||
-
|
||||
- dump_format(oc, 0, input, 1);
|
||||
+ av_dump_format(oc, 0, input, 1);
|
||||
|
||||
if (video_st) {
|
||||
codec = avcodec_find_decoder(video_st->codec->codec_id);
|
||||
@@ -233,12 +228,12 @@
|
||||
}
|
||||
}
|
||||
|
||||
- if (url_fopen(&oc->pb, output_filename, URL_WRONLY) < 0) {
|
||||
+ if (avio_open(&oc->pb, output_filename, AVIO_FLAG_WRITE) < 0) {
|
||||
fprintf(stderr, "Could not open '%s'\n", output_filename);
|
||||
exit(1);
|
||||
}
|
||||
|
||||
- if (av_write_header(oc)) {
|
||||
+ if (avformat_write_header(oc, NULL)) {
|
||||
fprintf(stderr, "Could not write mpegts header to first output file\n");
|
||||
|
||||
exit(1);
|
||||
@@ -274,10 +269,10 @@
|
||||
}
|
||||
|
||||
if (segment_time - prev_segment_time >= segment_duration) {
|
||||
- put_flush_packet(oc->pb);
|
||||
- url_fclose(oc->pb);
|
||||
+ avio_flush(oc->pb);
|
||||
+ avio_close(oc->pb);
|
||||
|
||||
- if (url_fopen(&oc->pb, output_filename, URL_WRONLY) < 0) {
|
||||
+ if (avio_open(&oc->pb, output_filename, AVIO_FLAG_WRITE) < 0) {
|
||||
fprintf(stderr, "Could not open '%s'\n", output_filename);
|
||||
break;
|
||||
}
|
||||
@@ -307,7 +302,7 @@
|
||||
av_freep(&oc->streams[i]);
|
||||
}
|
||||
|
||||
- url_fclose(oc->pb);
|
||||
+ avio_close(oc->pb);
|
||||
av_free(oc);
|
||||
|
||||
/* End-of-transcode marker. */
|
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for Miro
|
||||
|
||||
# Copyright 2009-2012 Larry Hajali <larryhaja[at]gmail[dot]com>
|
||||
# Copyright 2009-2013 Larry Hajali <larryhaja[at]gmail[dot]com>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -23,7 +23,7 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=miro
|
||||
VERSION=${VERSION:-5.0.4}
|
||||
VERSION=${VERSION:-6.0}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -71,8 +71,6 @@ find . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Patch to build against ffmpeg 0.11.x
|
||||
patch -p1 < $CWD/ffmpeg-0.11.patch
|
||||
# Patch to fix the gdb call from miro.
|
||||
patch -p1 < $CWD/miro-gdb-fix.patch
|
||||
# Fix .destkop item.
|
||||
|
@ -81,7 +79,7 @@ sed -i \
|
|||
-e 's|ogg$|ogg;|' linux/miro.desktop
|
||||
|
||||
cd linux
|
||||
sed -i 's|share/man|man|' setup.py
|
||||
sed -i -e 's|share/man|man|' -e '/miro.test/d' setup.py
|
||||
CFLAGS="$SLKCFLAGS" python setup.py install --root=$PKG
|
||||
cd -
|
||||
|
||||
|
@ -89,8 +87,6 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
|||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
# Remove unneeded files.
|
||||
PYVER=$(python -c 'import sys; print sys.version[:3]')
|
||||
rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/python${PYVER}/site-packages/miro/test
|
||||
rm -rf $PKG/usr/share/${PRGNAM}/resources/testdata
|
||||
if [ "$ARCH" == "x86_64" ]; then
|
||||
rm -f $PKG/usr/bin/codegen.Linux-i686
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="miro"
|
||||
VERSION="5.0.4"
|
||||
VERSION="6.0"
|
||||
HOMEPAGE="http://www.getmiro.com/"
|
||||
DOWNLOAD="http://ftp.osuosl.org/pub/pculture.org/miro/src/miro-5.0.4.tar.gz"
|
||||
MD5SUM="8a3de8356d2ba9d82f0a00f31ceb446e"
|
||||
DOWNLOAD="http://ftp.osuosl.org/pub/pculture.org/miro/src/miro-6.0.tar.gz"
|
||||
MD5SUM="058e89560bfbd0dc68e72119bc7e732f"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="ffmpeg gnome-python gst-python libtorrent-rasterbar mutagen pywebkitgtk"
|
||||
|
|
Loading…
Reference in a new issue