mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
network/pptpd: Added to 12.1 repository
This commit is contained in:
parent
1565510862
commit
8e5a0c1f0c
6 changed files with 179 additions and 0 deletions
3
network/pptpd/README
Normal file
3
network/pptpd/README
Normal file
|
@ -0,0 +1,3 @@
|
|||
pptpd (PoPToP) is a Point to Point Tunneling Server that
|
||||
provides a Virtual Private Networking (VPN) server which
|
||||
is compatible with Microsoft VPN clients.
|
19
network/pptpd/doinst.sh
Normal file
19
network/pptpd/doinst.sh
Normal file
|
@ -0,0 +1,19 @@
|
|||
#!/bin/sh
|
||||
|
||||
config() {
|
||||
NEW="$1"
|
||||
OLD="$(dirname $NEW)/$(basename $NEW .new)"
|
||||
# If there's no config file by that name, mv it over:
|
||||
if [ ! -r $OLD ]; then
|
||||
mv $NEW $OLD
|
||||
elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
|
||||
# toss the redundant copy
|
||||
rm $NEW
|
||||
fi
|
||||
# Otherwise, we leave the .new copy for the admin to consider...
|
||||
}
|
||||
|
||||
config etc/pptpd.conf.new
|
||||
config etc/ppp/options.pptpd.new
|
||||
config etc/ppp/chap-secrets.new
|
||||
|
30
network/pptpd/plugins_Makefile.diff
Normal file
30
network/pptpd/plugins_Makefile.diff
Normal file
|
@ -0,0 +1,30 @@
|
|||
--- pptpd-1.3.4/plugins/Makefile 2008-07-20 01:46:35.836374075 -0500
|
||||
+++ pptpd-1.3.4/plugins/Makefile 2008-07-20 01:48:48.729656656 -0500
|
||||
@@ -3,7 +3,7 @@
|
||||
CFLAGS = $(COPTS) -I.. -I../../include -fPIC
|
||||
LDFLAGS = -shared
|
||||
LDADD = -lutil
|
||||
-INSTALL = install -o root
|
||||
+INSTALL = install
|
||||
prefix = /usr/local
|
||||
|
||||
PLUGINS = pptpd-logwtmp.so
|
||||
@@ -18,14 +18,14 @@
|
||||
%.so: %.c
|
||||
$(CC) -o $@ $(LDFLAGS) $(CFLAGS) $^ $(LDADD)
|
||||
|
||||
-LIBDIR ?= $(DESTDIR)$(prefix)/lib/pptpd
|
||||
+LIBDIR ?= $(prefix)/lib/pptpd
|
||||
|
||||
install: $(PLUGINS)
|
||||
- $(INSTALL) -d $(LIBDIR)
|
||||
- $(INSTALL) $? $(LIBDIR)
|
||||
+ $(INSTALL) -d $(DESTDIR)/$(LIBDIR)
|
||||
+ $(INSTALL) $? $(DESTDIR)/$(LIBDIR)
|
||||
|
||||
uninstall:
|
||||
- rm -f $(LIBDIR)$(PLUGINS)
|
||||
+ rm -f $(DESTDIR)/$(LIBDIR)$(PLUGINS)
|
||||
|
||||
clean:
|
||||
rm -f *.o *.so *.a
|
100
network/pptpd/pptpd.SlackBuild
Normal file
100
network/pptpd/pptpd.SlackBuild
Normal file
|
@ -0,0 +1,100 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for pptpd
|
||||
|
||||
# Copyright 2007,2008 Robby Workman, Northport, Alabama, USA
|
||||
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=pptpd
|
||||
VERSION=1.3.4
|
||||
ARCH=${ARCH:-i486}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Fix the plugins Makefile
|
||||
patch -p1 < $CWD/plugins_Makefile.diff
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--sysconfdir=/etc \
|
||||
--mandir=/usr/man \
|
||||
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||
--with-libwrap \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
( cd $PKG/usr/man
|
||||
find . -type f -exec gzip -9 {} \;
|
||||
for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
|
||||
)
|
||||
|
||||
# Add some sample config files
|
||||
mkdir -p $PKG/etc/ppp
|
||||
cat samples/pptpd.conf > $PKG/etc/pptpd.conf.new
|
||||
cat samples/options.pptpd > $PKG/etc/ppp/options.pptpd.new
|
||||
cat samples/chap-secrets > $PKG/etc/ppp/chap-secrets.new
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a AUTHORS COPYING ChangeLog INSTALL NEWS README* TODO \
|
||||
html tools debian $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
find $PKG/usr/doc -type f -exec chmod 0644 {} \;
|
||||
find $PKG/usr/doc -type d -name 'CVS' | xargs rm -rf
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
|
8
network/pptpd/pptpd.info
Normal file
8
network/pptpd/pptpd.info
Normal file
|
@ -0,0 +1,8 @@
|
|||
PRGNAM="pptpd"
|
||||
VERSION="1.3.4"
|
||||
HOMEPAGE="http://www.poptop.org/"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/poptop/pptpd-1.3.4.tar.gz"
|
||||
MD5SUM="b38df9c431041922c997c1148bedf591"
|
||||
MAINTAINER="Robby Workman"
|
||||
EMAIL="rw@rlworkman.net"
|
||||
APPROVED="David Somero"
|
19
network/pptpd/slack-desc
Normal file
19
network/pptpd/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|'
|
||||
# on the right side marks the last column you can put a character in. You must
|
||||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
pptpd: pptpd (PoPToP Point to Point Tunneling Server)
|
||||
pptpd:
|
||||
pptpd: This implements a Virtual Private Networking Server (VPN) that is
|
||||
pptpd: compatible with Microsoft VPN clients. It allows windows users to
|
||||
pptpd: connect to an internal firewalled network using their dialup.
|
||||
pptpd:
|
||||
pptpd: Homepage: http://www.poptop.org/
|
||||
pptpd:
|
||||
pptpd:
|
||||
pptpd:
|
||||
pptpd:
|
Loading…
Reference in a new issue