development/hhvm: Updated for version 4.168.2

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Eugen Wissner 2023-06-15 21:37:36 +02:00 committed by Willy Sudiarto Raharjo
parent 8214ea785f
commit 8e309c703a
No known key found for this signature in database
GPG key ID: 3F617144D7238786
5 changed files with 276 additions and 257 deletions

View file

@ -2,7 +2,7 @@
# Slackware build script for HHVM
# Copyright 2015-2022 Eugene Wissner, Dachau, Germany
# Copyright 2015-2023 Eugene Wissner, Dachau, Germany
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@ -25,13 +25,14 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=hhvm
VERSION=${VERSION:-4.153.4}
VERSION=${VERSION:-4.168.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
OPAM_STAMP="12fbd9f"
CARGO_BUILD="2"
OPAM_STAMP="1d2e919"
CARGO_BUILD="3"
FB_VERSION="2022.07.04.00"
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@ -77,9 +78,9 @@ tar Jxvf $CWD/cargo-home-$CARGO_BUILD.tar.xz -C hphp/hack/_build
install -m 0755 -D $CWD/opam-2.1.0-x86_64-linux \
third-party/opam/opamDownload-prefix/src/opam-2.1.0-x86_64-linux
install -m 0644 -D $CWD/fmt-6.1.2.zip third-party/fmt/bundled_fmt-prefix/src/fmt-6.1.2.zip
unzip $CWD/fmt-6.1.2.zip -d third-party/fmt/bundled_fmt-prefix/src
mv third-party/fmt/bundled_fmt-prefix/src/fmt-6.1.2 third-party/fmt/bundled_fmt-prefix/src/bundled_fmt
install -m 0644 -D $CWD/fmt-8.0.0.zip third-party/fmt/bundled_fmt-prefix/src/fmt-8.0.0.zip
unzip $CWD/fmt-8.0.0.zip -d third-party/fmt/bundled_fmt-prefix/src
mv third-party/fmt/bundled_fmt-prefix/src/fmt-8.0.0 third-party/fmt/bundled_fmt-prefix/src/bundled_fmt
mkdir -p third-party/re2/bundled_re2-prefix/src/bundled_re2
install -m 0644 -D $CWD/re2-2021-11-01.tar.gz third-party/re2/bundled_re2-prefix/src/re2-2021-11-01.tar.gz
@ -101,54 +102,34 @@ tar zxvf $CWD/rust-nightly-x86_64-unknown-linux-gnu.tar.gz \
--strip-components=1
mkdir -p third-party/proxygen/bundled_proxygen-prefix/src/bundled_proxygen
install -m 0644 -D $CWD/proxygen-v2022.01.31.00.tar.gz \
third-party/proxygen/bundled_proxygen-prefix/src/proxygen-v2022.01.31.00.tar.gz
tar zxvf $CWD/proxygen-v2022.01.31.00.tar.gz \
install -m 0644 -D $CWD/proxygen-v${FB_VERSION}.tar.gz \
third-party/proxygen/bundled_proxygen-prefix/src/proxygen-v${FB_VERSION}.tar.gz
tar zxvf $CWD/proxygen-v${FB_VERSION}.tar.gz \
-C third-party/proxygen/bundled_proxygen-prefix/src/bundled_proxygen
mkdir -p third-party/folly/bundled_folly-prefix/src/bundled_folly
install -m 0644 -D $CWD/folly-v2022.03.14.00.tar.gz \
third-party/folly/bundled_folly-prefix/src/folly-v2022.03.14.00.tar.gz
tar zxvf $CWD/folly-v2022.03.14.00.tar.gz \
install -m 0644 -D $CWD/folly-v${FB_VERSION}.tar.gz \
third-party/folly/bundled_folly-prefix/src/folly-v${FB_VERSION}.tar.gz
tar zxvf $CWD/folly-v${FB_VERSION}.tar.gz \
-C third-party/folly/bundled_folly-prefix/src/bundled_folly
mkdir -p third-party/fb-mysql/bundled_fbmysqlclient-prefix/src/bundled_fbmysqlclient
install -m 0644 -D $CWD/fb-prod8-202101.tar.gz \
third-party/fb-mysql/bundled_fbmysqlclient-prefix/src/fb-prod8-202101.tar.gz
tar -zxvf $CWD/fb-prod8-202101.tar.gz \
-C third-party/fb-mysql/bundled_fbmysqlclient-prefix/src/bundled_fbmysqlclient
mkdir -p third-party/wangle/bundled_wangle-prefix/src/bundled_wangle
install -m 0644 -D $CWD/wangle-v2022.01.31.00.tar.gz \
third-party/wangle/bundled_wangle-prefix/src/wangle-v2022.01.31.00.tar.gz
tar -zxvf $CWD/wangle-v2022.01.31.00.tar.gz \
install -m 0644 -D $CWD/wangle-v${FB_VERSION}.tar.gz \
third-party/wangle/bundled_wangle-prefix/src/wangle-v${FB_VERSION}.tar.gz
tar -zxvf $CWD/wangle-v${FB_VERSION}.tar.gz \
-C third-party/wangle/bundled_wangle-prefix/src/bundled_wangle
mkdir -p third-party/squangle/bundled_squangle-prefix/src/bundled_squangle
install -m 0644 -D $CWD/squangle-v2022.01.31.00.tar.gz \
third-party/squangle/bundled_squangle-prefix/src/squangle-2022.01.31.00.tar.gz
tar -zxvf $CWD/squangle-v2022.01.31.00.tar.gz \
-C third-party/squangle/bundled_squangle-prefix/src/bundled_squangle \
--strip-components=1
mkdir -p third-party/watchman/bundled_watchman-prefix/src/bundled_watchman
install -m 0644 -D $CWD/watchman-v2022.01.31.00.tar.gz \
third-party/watchman/bundled_watchman-prefix/src/watchman-v2022.01.31.00.tar.gz
tar -zxvf $CWD/watchman-v2022.01.31.00.tar.gz \
-C third-party/watchman/bundled_watchman-prefix/src/bundled_watchman \
--strip-components=1
mkdir -p third-party/thrift/bundled_thrift-prefix/src/bundled_thrift
install -m 0644 -D $CWD/fbthrift-v2022.01.31.00.tar.gz \
third-party/thrift/bundled_thrift-prefix/src/fbthrift-v2022.01.31.00.tar.gz
tar -zxvf $CWD/fbthrift-v2022.01.31.00.tar.gz \
install -m 0644 -D $CWD/fbthrift-v${FB_VERSION}.tar.gz \
third-party/thrift/bundled_thrift-prefix/src/fbthrift-v${FB_VERSION}.tar.gz
tar -zxvf $CWD/fbthrift-v${FB_VERSION}.tar.gz \
-C third-party/thrift/bundled_thrift-prefix/src/bundled_thrift \
--strip-components=1
mkdir -p third-party/mcrouter/bundled_mcrouter-prefix/src/bundled_mcrouter
install -m 0644 -D $CWD/mcrouter-v2022.01.31.00.tar.gz \
third-party/mcrouter/bundled_mcrouter-prefix/src/mcrouter-v2022.01.31.00.tar.gz
tar -zxvf $CWD/mcrouter-v2022.01.31.00.tar.gz \
install -m 0644 -D $CWD/mcrouter-v${FB_VERSION}.tar.gz \
third-party/mcrouter/bundled_mcrouter-prefix/src/mcrouter-v${FB_VERSION}.tar.gz
tar -zxvf $CWD/mcrouter-v${FB_VERSION}.tar.gz \
-C third-party/mcrouter/bundled_mcrouter-prefix/src/bundled_mcrouter \
--strip-components=1
@ -159,14 +140,14 @@ tar -zxvf $CWD/timelib-2021.07.tar.gz \
--strip-components=1
mkdir -p third-party/fizz/bundled_fizz-prefix/src/bundled_fizz
install -m 0644 -D $CWD/fizz-v2022.01.31.00.tar.gz \
third-party/fizz/bundled_fizz-prefix/src/fizz-v2022.01.31.00.tar.gz
tar -zxvf $CWD/fizz-v2022.01.31.00.tar.gz \
install -m 0644 -D $CWD/fizz-v${FB_VERSION}.tar.gz \
third-party/fizz/bundled_fizz-prefix/src/fizz-v${FB_VERSION}.tar.gz
tar -zxvf $CWD/fizz-v${FB_VERSION}.tar.gz \
-C third-party/fizz/bundled_fizz-prefix/src/bundled_fizz
# The working directory is hphp/hack.
cat << EOF > hphp/hack/facebook/fetch_opam2_repo_hack.sh
#!/bin/sh
!/bin/sh
cp $CWD/index-$OPAM_STAMP.tar.gz facebook/
echo facebook/index-$OPAM_STAMP
EOF
@ -174,6 +155,7 @@ chmod 0755 hphp/hack/facebook/fetch_opam2_repo_hack.sh
patch -p1 --verbose -i $CWD/patches/0001-liburing.patch
patch -p1 --verbose -i $CWD/patches/0002-download.patch
patch -p1 --verbose -i $CWD/patches/0003-iquote.patch
chown -R root:root .
find -L . \
@ -196,6 +178,7 @@ cmake \
-DUSE_JEMALLOC=true \
-DUSE_BUNDLED_TZDATA=OFF \
-DFORCE_BUNDLED_LZ4=OFF \
-DCAN_USE_SYSTEM_ZSTD=ON \
-DMYSQL_UNIX_SOCK_ADDR=/var/run/mysqld/mysqld.sock \
-DCMAKE_BUILD_TYPE=Release .
make || make -j1

View file

@ -1,46 +1,40 @@
PRGNAM="hhvm"
VERSION="4.153.4"
VERSION="4.168.2"
HOMEPAGE="https://hhvm.com/"
DOWNLOAD="UNSUPPORTED"
MD5SUM=""
DOWNLOAD_x86_64="https://download.dlackware.com/hosted-sources/hhvm/hhvm-4.153.4.tar.xz \
https://static.rust-lang.org/dist/2021-11-29/rust-nightly-x86_64-unknown-linux-gnu.tar.gz \
DOWNLOAD_x86_64="https://download.dlackware.com/hosted-sources/hhvm/hhvm-4.168.2.tar.xz \
https://static.rust-lang.org/dist/2022-08-01/rust-nightly-x86_64-unknown-linux-gnu.tar.gz \
https://download.dlackware.com/hosted-sources/hhvm/opam-2.1.0-x86_64-linux \
https://download.dlackware.com/hosted-sources/hhvm/brotli-v1.0.9.tar.gz \
https://download.dlackware.com/hosted-sources/hhvm/fmt-6.1.2.zip \
https://download.dlackware.com/hosted-sources/hhvm/cargo-home-2.tar.xz \
https://download.dlackware.com/hosted-sources/hhvm/index-12fbd9f.tar.gz \
https://download.dlackware.com/hosted-sources/hhvm/hack-switch-12fbd9f.tar.xz \
https://download.dlackware.com/hosted-sources/hhvm/fb-prod8-202101.tar.gz \
https://download.dlackware.com/hosted-sources/hhvm/fbthrift-v2022.01.31.00.tar.gz \
https://download.dlackware.com/hosted-sources/hhvm/fizz-v2022.01.31.00.tar.gz \
https://download.dlackware.com/hosted-sources/hhvm/folly-v2022.03.14.00.tar.gz \
https://download.dlackware.com/hosted-sources/hhvm/mcrouter-v2022.01.31.00.tar.gz \
https://download.dlackware.com/hosted-sources/hhvm/proxygen-v2022.01.31.00.tar.gz \
https://download.dlackware.com/hosted-sources/hhvm/fmt-8.0.0.zip \
https://download.dlackware.com/hosted-sources/hhvm/cargo-home-3.tar.xz \
https://download.dlackware.com/hosted-sources/hhvm/index-1d2e919.tar.gz \
https://download.dlackware.com/hosted-sources/hhvm/hack-switch-1d2e919.tar.xz \
https://download.dlackware.com/hosted-sources/hhvm/fbthrift-v2022.07.04.00.tar.gz \
https://download.dlackware.com/hosted-sources/hhvm/fizz-v2022.07.04.00.tar.gz \
https://download.dlackware.com/hosted-sources/hhvm/folly-v2022.07.04.00.tar.gz \
https://download.dlackware.com/hosted-sources/hhvm/mcrouter-v2022.07.04.00.tar.gz \
https://download.dlackware.com/hosted-sources/hhvm/proxygen-v2022.07.04.00.tar.gz \
https://download.dlackware.com/hosted-sources/hhvm/re2-2021-11-01.tar.gz \
https://download.dlackware.com/hosted-sources/hhvm/squangle-v2022.01.31.00.tar.gz \
https://download.dlackware.com/hosted-sources/hhvm/timelib-2021.07.tar.gz \
https://download.dlackware.com/hosted-sources/hhvm/wangle-v2022.01.31.00.tar.gz \
https://download.dlackware.com/hosted-sources/hhvm/watchman-v2022.01.31.00.tar.gz"
MD5SUM_x86_64="ddd7354654a7aaf9c33636a5244f7582 \
89838b0c4768d43f88da2b2f37e53ae5 \
https://download.dlackware.com/hosted-sources/hhvm/wangle-v2022.07.04.00.tar.gz"
MD5SUM_x86_64="e28368785c9d9a450e535dfab58edd25 \
6c9d12670d6ef18be6da3e92ebe692e9 \
87d949d8dd93061c5f727094da67f315 \
c2274f0c7af8470ad514637c35bcee7d \
5ec643b082a34254ad07136e7cbd4220 \
20cdff02f59435ad514a509859028095 \
684797a17c2a638f18d615f66ba329ed \
2e0b9b2605c28e40097a04d6d2935f0d \
b12a3ffd803fd7f60d679f3feb4d5354 \
5af19e555bbe4ba1cd203117f1d5fb79 \
3d652c69d93936beafdd08bb696d72bd \
18b79091ae379c7a919b97eaad310445 \
81d8ddf74d97b1d0671d449368f9e5c8 \
fe8684e89b65c8256ad1b2a0d1d2e620 \
f6eb7f98a6aa09aa0102c0c931feec55 \
e4fd7b7137880abf755c34d8bd53cb2c \
65d68e3ecb52e910245cb6d3a02d137f \
0eec01bc44b88f75ce6a0799b09b6e3b \
ba0283a7a932e329852b0634765ea6f1 \
34e50ea874ba018c567409a02919f613 \
0b6de34c0ca84a4f89d72a3380de9391 \
0084e476218aeb9a03fa1a0e5d797522 \
cc6c17ef5b582d8f602efce8a61a117e \
8db4cf198c296eb001b4bf7ac194e598 \
43e92f04885bac22f4d40be0b03ddbe0 \
7b869e86c44b5a3d9296149285c8bd69 \
5041b92a50ec110fdfde69a3ea2e4daf \
1f9ebaac101929b0bf319ebc18c8a10a"
544011faeb62a328f8b92044f9adcf11"
REQUIRES="tbb glog libdwarf libmemcached double-conversion gflags"
MAINTAINER="Eugene Wissner"
EMAIL="belka@caraus.de"

View file

@ -24,20 +24,6 @@
namespace folly {
--- a/third-party/folly/bundled_folly-prefix/src/bundled_folly/folly/lang/Badge.h 2022-06-16 13:38:45.611000000 +0200
+++ b/third-party/folly/bundled_folly-prefix/src/bundled_folly/folly/lang/Badge.h 2022-06-16 13:45:32.863000000 +0200
@@ -92,10 +92,7 @@
typename = std::enable_if_t<folly::IsOneOf<Holder, Holders...>::value>>
/* implicit */ constexpr any_badge(badge<Holder>) noexcept {}
- template <
- typename... OtherHolders,
- typename = std::enable_if_t<folly::StrictConjunction<
- folly::IsOneOf<OtherHolders, Holders...>...>::value>>
+ template <typename... OtherHolders>
/* implicit */ constexpr any_badge(any_badge<OtherHolders...>) noexcept {}
};
--- a/third-party/folly/bundled_folly-prefix/src/bundled_folly/folly/experimental/io/IoUringBackend.cpp 2022-06-16 14:12:06.191000000 +0200
+++ b/third-party/folly/bundled_folly-prefix/src/bundled_folly/folly/experimental/io/IoUringBackend.cpp 2022-06-16 14:09:28.887000000 +0200
@@ -31,7 +31,7 @@
@ -49,26 +35,3 @@
extern "C" FOLLY_ATTR_WEAK void eb_poll_loop_pre_hook(uint64_t* call_time);
extern "C" FOLLY_ATTR_WEAK void eb_poll_loop_post_hook(
--- a/third-party/proxygen/bundled_proxygen-prefix/src/bundled_proxygen/proxygen/lib/stats/PeriodicStats.h 2022-06-16 14:28:37.919000000 +0200
+++ b/third-party/proxygen/bundled_proxygen-prefix/src/bundled_proxygen/proxygen/lib/stats/PeriodicStats.h 2022-06-16 14:24:03.920000000 +0200
@@ -163,7 +163,7 @@
void modifyData(T* newData, bool sync = false) {
auto* oldData = data_.exchange(newData);
if (sync) {
- folly::synchronize_rcu();
+ folly::rcu_synchronize();
delete oldData;
} else {
folly::rcu_retire(oldData);
--- a/third-party/zstd/CMakeLists.txt 2022-06-18 17:24:56.022000000 +0200
+++ a/third-party/zstd/CMakeLists.txt 2022-06-18 17:26:10.462000000 +0200
@@ -2,8 +2,7 @@
option(FORCE_BUNDLED_ZSTD "Always build zstd, instead of using the system version" OFF)
if (NOT FORCE_BUNDLED_ZSTD)
- set(CAN_USE_SYSTEM_ZSTD OFF)
- find_library(ZSTD_LIB NAMES zstd)
+ find_library(ZSTD_LIB NAMES zstd libzstd)
find_path(ZSTD_INCLUDE_DIR NAMES zstd.h)
set(CMAKE_REQUIRED_INCLUDES "${ZSTD_INCLUDE_DIR}")
check_cxx_source_compiles("

View file

@ -1,139 +1,18 @@
#--- a/third-party/fb-mysql/CMakeLists.txt 2022-06-16 16:50:22.283000000 +0200
#+++ b/third-party/fb-mysql/CMakeLists.txt 2022-06-16 18:30:00.373739502 +0200
@@ -12,10 +12,6 @@
SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
FB_MYSQL_DOWNLOAD_ARGS
- SOURCE_URL
- "https://github.com/facebook/mysql-5.6/archive/refs/tags/fb-prod8-202101.tar.gz"
- SOURCE_HASH
- "SHA512=4e07ae4e6628792ec5d77af7e524bddc2e9ac361dff4b93060f9fb5804d72a7144824ac84138487a3b4dcac350453cd5f17afd9a951b9d8248c292bf378e1e78"
)
ExternalProject_Add(
bundled_fbmysqlclient
--- a/third-party/proxygen/CMakeLists.txt 2022-06-16 16:51:48.652000000 +0200
+++ b/third-party/proxygen/CMakeLists.txt 2022-06-16 18:30:00.391586726 +0200
@@ -18,10 +18,6 @@
--- hhvm-4.168.2/third-party/libzip/CMakeLists.txt 2023-05-28 20:16:44.000000000 +0200
+++ - 2023-06-01 19:10:40.449428587 +0200
@@ -23,10 +23,6 @@
SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
PROXYGEN_SOURCE_ARGS
LIBZIP_DOWNLOAD_ARGS
- SOURCE_URL
- "https://github.com/facebook/proxygen/releases/download/v2022.01.31.00/proxygen-v2022.01.31.00.tar.gz"
- "https://libzip.org/download/libzip-1.6.1.tar.gz"
- SOURCE_HASH
- "SHA256=5360a8ccdfb2f5a6c7b3eed331ec7ab0e2c792d579c6fff499c85c516c11fe14"
- "SHA256=06eb8e9141fd19e2788cabaea9c9c2fd4d488d9e1484eb474bbfcac78e7b1d88"
)
ExternalProject_Add(
--- a/third-party/wangle/CMakeLists.txt 2022-06-16 16:51:48.652000000 +0200
+++ b/third-party/wangle/CMakeLists.txt 2022-06-16 18:30:00.394195460 +0200
@@ -20,10 +20,6 @@
SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
WANGLE_SOURCE_ARGS
- SOURCE_URL
- "https://github.com/facebook/wangle/releases/download/v2022.01.31.00/wangle-v2022.01.31.00.tar.gz"
- SOURCE_HASH
- "SHA256=1002e9c32b6f4837f6a760016e3b3e22f3509880ef3eaad191c80dc92655f23f"
)
ExternalProject_Add(
--- a/third-party/squangle/CMakeLists.txt 2022-06-16 16:51:48.652000000 +0200
+++ b/third-party/squangle/CMakeLists.txt 2022-06-16 18:30:00.396715727 +0200
@@ -16,10 +16,6 @@
SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
SQUANGLE_SOURCE_ARGS
- SOURCE_URL
- "https://github.com/facebook/squangle/archive/refs/tags/v2022.01.31.00.tar.gz"
- SOURCE_HASH
- "SHA256=78988eacf99d380da4c660161bcb20305e4b54369e17b1bb866c5fb188acff76"
FILENAME_PREFIX
"squangle-"
)
--- a/third-party/watchman/CMakeLists.txt 2022-06-16 16:51:48.652000000 +0200
+++ b/third-party/watchman/CMakeLists.txt 2022-06-16 18:30:00.404187081 +0200
@@ -5,10 +5,6 @@
SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
WATCHMAN_DOWNLOAD_ARGS
- SOURCE_URL "https://github.com/facebook/watchman/archive/refs/tags/v2022.01.31.00.tar.gz"
- SOURCE_HASH "SHA256=5a253c289141d19b8c6fb05e4d12a75343c62d236f98dbbf6af4a50dc0550d90"
- # The tarball name is just the tag name, which can conflict in the cache
- FILENAME_PREFIX "watchman-"
)
get_target_property(BOOST_INCLUDE_DIR boost INTERFACE_INCLUDE_DIRECTORIES)
--- a/third-party/thrift/CMakeLists.txt 2022-06-16 16:51:48.652000000 +0200
+++ b/third-party/thrift/CMakeLists.txt 2022-06-16 18:30:00.406737187 +0200
@@ -20,10 +20,6 @@
SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
THRIFT_SOURCE_ARGS
- SOURCE_URL
- "https://github.com/facebook/fbthrift/archive/refs/tags/v2022.01.31.00.tar.gz"
- SOURCE_HASH
- "SHA256=6194127fd9e6771bd34f502a84b292278bf3a6ee7b87377afd1ae287a5572f48"
FILENAME_PREFIX
"fbthrift-"
)
--- a/third-party/mcrouter/CMakeLists.txt 2022-06-16 16:51:48.651000000 +0200
+++ b/third-party/mcrouter/CMakeLists.txt 2022-06-16 18:30:00.412827594 +0200
@@ -5,10 +5,6 @@
SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
MCROUTER_DOWNLOAD_ARGS
- SOURCE_URL "https://github.com/facebook/mcrouter/archive/refs/tags/v2022.01.31.00.tar.gz"
- SOURCE_HASH "SHA256=478b8d0b88bdca7c65863764b50dc46f92d849c39f8b34ecc657884106c9b4e6"
- # The tarball name is just the tag name, which can conflict in the cache
- FILENAME_PREFIX "mcrouter-"
)
set(
--- a/third-party/timelib/CMakeLists.txt 2022-06-16 16:51:48.652000000 +0200
+++ b/third-party/timelib/CMakeLists.txt 2022-06-16 18:30:00.417958866 +0200
@@ -6,10 +6,6 @@
SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
TIMELIB_DOWNLOAD_ARGS
- SOURCE_URL "https://github.com/derickr/timelib/archive/refs/tags/2021.07.tar.gz"
- SOURCE_HASH "SHA512=7bc56d20360937af10f63960e443cc8bd4d24c5369f697241e54da21465d4512bd16cfa6f0efcf2b847cc19781e1cecf93c9e19a1efa4f1a7012c9fa442eeabe"
- # Look for timelib-YYYY.MM.tar.gz in download cache, not just YYYY.MM.tar.gz
- FILENAME_PREFIX "timelib-"
)
if(USE_BUNDLED_TZDATA)
--- a/third-party/folly/CMakeLists.txt 2022-06-16 16:51:48.651000000 +0200
+++ b/third-party/folly/CMakeLists.txt 2022-06-16 18:30:00.433286243 +0200
@@ -3,10 +3,6 @@
SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
FOLLY_SOURCE_ARGS
- SOURCE_URL
- "https://github.com/facebook/folly/releases/download/v2022.01.31.00/folly-v2022.01.31.00.tar.gz"
- SOURCE_HASH
- "SHA256=7b8d5dd2eb51757858247af0ad27af2e3e93823f84033a628722b01e06cd68a9"
)
get_target_property(BOOST_INCLUDE_DIR boost INTERFACE_INCLUDE_DIRECTORIES)
--- a/third-party/rustc/CMakeLists.txt 2022-06-17 13:07:47.767000000 +0200
+++ b/third-party/rustc/CMakeLists.txt 2022-06-17 13:07:58.963000000 +0200
@@ -15,14 +15,6 @@
SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
RUST_DOWNLOAD_ARGS
- Linux_URL
- "https://static.rust-lang.org/dist/${RUST_NIGHTLY_VERSION}/rust-nightly-x86_64-unknown-linux-gnu.tar.gz"
- Darwin_URL
- "https://static.rust-lang.org/dist/${RUST_NIGHTLY_VERSION}/rust-nightly-x86_64-apple-darwin.tar.gz"
- Linux_HASH
- "SHA512=a7ec879851bd1bb8bf57b77860c4d99b0b76702182782520ab5f5053b6b113f3a0890c1e8210f8c010f43ea0804abdeeb90422534498e47178cad3643ddcca32"
- Darwin_HASH
- "SHA512=b5655f92605e9a69b3ce49e73b92a960c4bc9bcb34edcef0d6b4829cec7258b0d00f398f41b0ce1fc399fe3cc35c91ca347eb2e0fe6b853aa94167f6dcf58697"
# The original filename doesn't contain any version information, so add the version information as a prefix to avoid cache collisions when updating later
FILENAME_PREFIX "rustc-${RUST_NIGHTLY_VERSION}-"
)
--- a/third-party/re2/CMakeLists.txt 2022-06-17 15:01:26.146000000 +0200
+++ b/third-party/re2/CMakeLists.txt 2022-06-17 15:02:34.110000000 +0200
--- hhvm-4.168.2/third-party/re2/CMakeLists.txt 2023-05-28 20:16:44.000000000 +0200
+++ - 2023-06-01 19:10:40.453034229 +0200
@@ -12,10 +12,6 @@
SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
@ -144,9 +23,35 @@
- "SHA256=8c45f7fba029ab41f2a7e6545058d9eec94eef97ce70df58e92d85cfc08b4669"
FILENAME_PREFIX "re2-"
)
--- a/third-party/brotli/CMakeLists.txt 2022-06-17 14:02:02.526000000 +0200
+++ b/third-party/brotli/CMakeLists.txt 2022-06-17 14:02:09.824000000 +0200
--- hhvm-4.168.2/third-party/zstd/CMakeLists.txt 2023-05-28 20:16:44.000000000 +0200
+++ - 2023-06-01 19:10:40.454513420 +0200
@@ -36,10 +36,6 @@
SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
ZSTD_DOWNLOAD_ARGS
- SOURCE_URL
- "https://github.com/facebook/zstd/releases/download/v1.4.9/zstd-1.4.9.tar.gz"
- SOURCE_HASH
- "SHA512=10d325c844be43f801c798158c6f1d1ab57401abf1e783e04f6b9e4ac0ba53cf487204fa3244370b1ade239d5f3a784bf1829e206c4ba61fdd9c2f4e9502b238"
)
ExternalProject_Add(
bundled_zstd
--- hhvm-4.168.2/third-party/libsodium/CMakeLists.txt 2023-05-28 20:16:44.000000000 +0200
+++ - 2023-06-01 19:10:40.456241341 +0200
@@ -21,10 +21,6 @@
SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
LIBSODIUM_DOWNLOAD_ARGS
- SOURCE_URL
- "https://github.com/jedisct1/libsodium/releases/download/1.0.18-RELEASE/libsodium-1.0.18.tar.gz"
- SOURCE_HASH
- "SHA512=17e8638e46d8f6f7d024fe5559eccf2b8baf23e143fadd472a7d29d228b186d86686a5e6920385fe2020729119a5f12f989c3a782afbd05a8db4819bb18666ef"
)
if (CMAKE_OSX_SYSROOT)
--- hhvm-4.168.2/third-party/brotli/CMakeLists.txt 2023-05-28 20:16:43.000000000 +0200
+++ - 2023-06-01 19:10:40.458519062 +0200
@@ -4,10 +4,6 @@
include(HPHPFunctions)
SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
@ -158,29 +63,185 @@
FILENAME_PREFIX "brotli-"
)
--- a/third-party/fmt/CMakeLists.txt 2022-06-18 16:55:18.677000000 +0200
+++ b/third-party/fmt/CMakeLists.txt 2022-06-18 16:55:29.015000000 +0200
@@ -3,10 +3,6 @@
--- hhvm-4.168.2/third-party/proxygen/CMakeLists.txt 2023-05-28 20:24:27.000000000 +0200
+++ - 2023-06-01 19:10:40.460795033 +0200
@@ -18,10 +18,6 @@
SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
FMT_SOURCE_ARGS
PROXYGEN_SOURCE_ARGS
- SOURCE_URL
- "https://github.com/fmtlib/fmt/releases/download/6.1.2/fmt-6.1.2.zip"
- "https://github.com/facebook/proxygen/releases/download/v2022.07.04.00/proxygen-v2022.07.04.00.tar.gz"
- SOURCE_HASH
- "SHA512=d21085a2010786ff18c47acb033d9e4d51a3d58f9707cd9adf0f44642c1e4d80fd8cddafe58d95bb4f3e4a84ac5799caafead4a9feb12cc549b03d4d389fcc93"
- "SHA256=4de47545a5beb9f3ac2ccdd62ae9def112b3cc361bb71820b9306a04f4bb40e9"
)
set(INSTALL_DIR "${CMAKE_CURRENT_BINARY_DIR}/fmt-prefix")
--- a/third-party/fizz/CMakeLists.txt 2022-06-19 10:24:50.285000000 +0200
+++ b/third-party/fizz/CMakeLists.txt 2022-06-19 10:25:03.587000000 +0200
ExternalProject_Add(
--- hhvm-4.168.2/third-party/wangle/CMakeLists.txt 2023-05-28 20:24:27.000000000 +0200
+++ - 2023-06-01 19:10:40.463064724 +0200
@@ -20,10 +20,6 @@
SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
WANGLE_SOURCE_ARGS
- SOURCE_URL
- "https://github.com/facebook/wangle/releases/download/v2022.07.04.00/wangle-v2022.07.04.00.tar.gz"
- SOURCE_HASH
- "SHA256=8c7b538f9e9d84162056d6dc757bea1d0d4c0978889469f10e9d05b1dc4e5a83"
)
ExternalProject_Add(
--- hhvm-4.168.2/third-party/thrift/CMakeLists.txt 2023-05-28 20:24:27.000000000 +0200
+++ - 2023-06-01 19:10:40.465499515 +0200
@@ -20,10 +20,6 @@
SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
THRIFT_SOURCE_ARGS
- SOURCE_URL
- "https://github.com/facebook/fbthrift/archive/refs/tags/v2022.07.04.00.tar.gz"
- SOURCE_HASH
- "SHA256=45e7ffb38655d9b518d28066f4276000a298990c7c32b9460ddb7a37f2af78bd"
FILENAME_PREFIX
"fbthrift-"
)
--- hhvm-4.168.2/third-party/mcrouter/CMakeLists.txt 2023-05-28 20:24:27.000000000 +0200
+++ - 2023-06-01 19:10:40.467849786 +0200
@@ -5,9 +5,6 @@
SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
MCROUTER_DOWNLOAD_ARGS
- SOURCE_URL "https://github.com/facebook/mcrouter/archive/refs/tags/v2022.07.04.00.tar.gz"
- SOURCE_HASH "SHA256=7a2a0b44736e896c844c4f8c7697202cdebf7fa42dbb4b84931ee5036a46945c"
- # The tarball name is just the tag name, which can conflict in the cache
FILENAME_PREFIX "mcrouter-"
)
--- hhvm-4.168.2/third-party/double-conversion/CMakeLists.txt 2023-05-28 20:16:43.000000000 +0200
+++ - 2023-06-01 19:10:40.470198057 +0200
@@ -1,33 +1,7 @@
include(ExternalProject)
include(HPHPFunctions)
-SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
- DOUBLE_CONVERSION_DOWNLOAD_ARGS
- SOURCE_URL "https://github.com/google/double-conversion/archive/refs/tags/v3.0.1.tar.gz"
- SOURCE_HASH "SHA256=d400c86417df2980b60dc27ad68249dd124964738916d20cdc9c90b42de86490"
- # The tarball name is just the tag name, which can conflict in the cache
- FILENAME_PREFIX "double-conversion-"
-)
-
-ExternalProject_Add(
- bundled_double-conversion
- ${DOUBLE_CONVERSION_DOWNLOAD_ARGS}
- CMAKE_ARGS
- -DCMAKE_INSTALL_PREFIX=<INSTALL_DIR>
- -DCMAKE_INSTALL_LIBDIR=lib
- -DCMAKE_INSTALL_INCLUDEDIR=include
- -DCMAKE_C_COMPILER=${CMAKE_C_COMPILER}
- -DCMAKE_CXX_COMPILER=${CMAKE_CXX_COMPILER}
- -DCMAKE_OSX_SYSROOT=${CMAKE_OSX_SYSROOT}
- EXCLUDE_FROM_ALL
-)
-
-option(FORCE_BUNDLED_DOUBLE_CONVERSION "Always use bundled double-conversion" OFF)
-if(FORCE_BUNDLED_DOUBLE_CONVERSION)
- set(DOUBLE_CONVERSION_FOUND FALSE)
-else()
- find_package(DoubleConversion)
-endif()
+find_package(DoubleConversion)
add_library(double-conversion INTERFACE)
if(DOUBLE_CONVERSION_FOUND)
--- hhvm-4.168.2/third-party/timelib/CMakeLists.txt 2023-05-28 20:16:44.000000000 +0200
+++ - 2023-06-01 19:10:40.472727059 +0200
@@ -6,9 +6,6 @@
SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
TIMELIB_DOWNLOAD_ARGS
- SOURCE_URL "https://github.com/derickr/timelib/archive/refs/tags/2021.07.tar.gz"
- SOURCE_HASH "SHA512=7bc56d20360937af10f63960e443cc8bd4d24c5369f697241e54da21465d4512bd16cfa6f0efcf2b847cc19781e1cecf93c9e19a1efa4f1a7012c9fa442eeabe"
- # Look for timelib-YYYY.MM.tar.gz in download cache, not just YYYY.MM.tar.gz
FILENAME_PREFIX "timelib-"
)
--- hhvm-4.168.2/third-party/oniguruma/CMakeLists.txt 2023-05-28 20:16:44.000000000 +0200
+++ - 2023-06-01 19:10:40.474969410 +0200
@@ -28,10 +28,6 @@
SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
ONIG_SOURCE_ARGS
- SOURCE_URL
- "https://github.com/kkos/oniguruma/releases/download/v6.9.5/onig-6.9.5.tar.gz"
- SOURCE_HASH
- "SHA512=2bdb24914e7069c6df9ab8a3d0190ddb58440d94b13860cdc36d259062ae0bc2aa85d564a4209ec596fc7ee47b0823d1b817d4f7ffcc3ea60e9870da84491dc1"
)
ExternalProject_add(
--- hhvm-4.168.2/third-party/fizz/CMakeLists.txt 2023-05-28 20:24:27.000000000 +0200
+++ - 2023-06-01 19:10:40.477204211 +0200
@@ -22,10 +22,6 @@
SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
FIZZ_SOURCE_ARGS
- SOURCE_URL
- "https://github.com/facebookincubator/fizz/releases/download/v2022.01.31.00/fizz-v2022.01.31.00.tar.gz"
- "https://github.com/facebookincubator/fizz/releases/download/v2022.07.04.00/fizz-v2022.07.04.00.tar.gz"
- SOURCE_HASH
- "SHA256=32a60e78d41ea2682ce7e5d741b964f0ea83642656e42d4fea90c0936d6d0c7d"
- "SHA256=48941c3726b99aa9b22480ff92cbe3715154df0a4330ad42485b3d7649167b76"
)
set(
--- hhvm-4.168.2/third-party/fmt/CMakeLists.txt 2023-05-28 20:24:27.000000000 +0200
+++ - 2023-06-01 19:10:40.478716581 +0200
@@ -3,10 +3,6 @@
SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
FMT_SOURCE_ARGS
- SOURCE_URL
- "https://github.com/fmtlib/fmt/releases/download/8.0.0/fmt-8.0.0.zip"
- SOURCE_HASH
- "SHA512=70848739642bebf2820d661e7547208445329325a0d8b5919d85f375d683c0f9bef763bc7e9d7823def15100134fd9a126a9e418223b20bf8d567e5084334778"
)
set(INSTALL_DIR "${CMAKE_CURRENT_BINARY_DIR}/fmt-prefix")
--- hhvm-4.168.2/third-party/rustc/CMakeLists.txt 2023-05-28 20:16:44.000000000 +0200
+++ - 2023-06-01 19:10:40.480975123 +0200
@@ -32,14 +32,6 @@
SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
RUST_DOWNLOAD_ARGS
- Linux_URL
- "https://static.rust-lang.org/dist/${RUST_NIGHTLY_VERSION}/rust-nightly-x86_64-unknown-linux-gnu.tar.gz"
- Darwin_URL
- "https://static.rust-lang.org/dist/${RUST_NIGHTLY_VERSION}/rust-nightly-x86_64-apple-darwin.tar.gz"
- Linux_HASH
- "SHA512=de136959121b4117ab31a9ae4c4b3c593d4fcdf9724bd0f62e8a4ab41becccfa4b8e92ebe1460d9be508986888b95b38620bb68b58496db89706760074b9585d"
- Darwin_HASH
- "SHA512=77beb1d67233d3954c2709a47c2513762e91e506041bb5ad8d0aad90124cb5a229dfc87e1fb767826f27a31b52520f148c52c2f3a595dac6e09a676c6e660462"
# The original filename doesn't contain any version information, so add the version information as a prefix to avoid cache collisions when updating later
FILENAME_PREFIX "rustc-${RUST_NIGHTLY_VERSION}-"
)
--- hhvm-4.168.2/third-party/lz4/CMakeLists.txt 2023-05-28 20:16:44.000000000 +0200
+++ - 2023-06-01 19:10:40.483215304 +0200
@@ -21,10 +21,6 @@
SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
LZ4_DOWNLOAD_ARGS
- SOURCE_URL "https://github.com/lz4/lz4/archive/v1.9.2.tar.gz"
- SOURCE_HASH "SHA256=658ba6191fa44c92280d4aa2c271b0f4fbc0e34d249578dd05e50e76d0e5efcc"
- # By default, we'd look for v1.9.2.tar.gz in the cache - let's look for
- # lz4-v1.9.2 instead
FILENAME_PREFIX "lz4-"
)
set(MAKE_ARGS CC=${CMAKE_C_COMPILER} CXX=${CMAKE_CXX_COMPILER} "MOREFLAGS=-fPIC ${ISYSROOT_FLAG}")
--- hhvm-4.168.2/third-party/folly/CMakeLists.txt 2023-05-28 20:24:27.000000000 +0200
+++ - 2023-06-01 19:10:40.485574035 +0200
@@ -3,10 +3,6 @@
SET_HHVM_THIRD_PARTY_SOURCE_ARGS(
FOLLY_SOURCE_ARGS
- SOURCE_URL
- "https://github.com/facebook/folly/releases/download/v2022.07.04.00/folly-v2022.07.04.00.tar.gz"
- SOURCE_HASH
- "SHA256=fff7caa4a230ac0b3ee88e383fa9ea1ee2b2f3f7611ae5b18c73a71a40ec0d43"
)
get_target_property(BOOST_INCLUDE_DIR boost INTERFACE_INCLUDE_DIRECTORIES)

View file

@ -0,0 +1,18 @@
diff --git a/hphp/hack/CMakeLists.txt b/hphp/hack/CMakeLists.txt
index b1aec712dbb..831c46db9e4 100644
--- a/hphp/hack/CMakeLists.txt
+++ b/hphp/hack/CMakeLists.txt
@@ -293,11 +293,8 @@ function(build_cxx_bridge NAME)
"${NAME}_rust_part"
${CXX_BRIDGE_LINK_LIBS}
)
- # `-iquote` is like `-I` (or target_include_directories()`), except:
- # - it takes precedence over `-I`
- # - it only applies to `#include "foo"`, not `#include <foo>`
- target_compile_options("${NAME}" INTERFACE "-iquote" "${RUST_FFI_BUILD_ROOT}")
- target_compile_options("${NAME}" PRIVATE "-iquote" "${GENERATED_CXXBRIDGE}")
+ target_include_directories("${NAME}" INTERFACE "${RUST_FFI_BUILD_ROOT}")
+ target_include_directories("${NAME}" PRIVATE "${GENERATED_CXXBRIDGE}")
endfunction()
build_cxx_bridge(