mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-12 09:58:54 +01:00
python/sippy: Removed (Upstream is gone).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
29eedf307b
commit
8d3fb80051
5 changed files with 0 additions and 124 deletions
|
@ -1,14 +0,0 @@
|
|||
Sippy B2BUA is a RFC3261-compliant Session Initiation Protocol (SIP)
|
||||
Back-to-back user agent (B2BUA) server software.
|
||||
|
||||
The B2BUA is a SIP call controlling component. Unlike a SIP proxy server,
|
||||
which only maintains transaction state, the B2BUA maintains complete call
|
||||
state and participates in all call requests. For this reason it can perform
|
||||
number of functions that are not possible to implement using SIP proxy, such
|
||||
as for example accurate call accounting, pre-paid rating and billing, fail
|
||||
over call routing etc. Unlike PBX-type solutions such as Asterisk for example,
|
||||
the B2BUA doesn't perform any media relaying or processing, therefore it
|
||||
doesn't introduce any additional packet loss, delay or jitter into the
|
||||
media path.
|
||||
|
||||
The Sippy B2BUA is distributed under version 2 of GNU Public License (GPL).
|
|
@ -1,9 +0,0 @@
|
|||
--- setup.py 2009-12-01 07:58:44.000000000 +0300
|
||||
+++ setup.py.new 2013-01-16 17:55:50.000000000 +0400
|
||||
@@ -36,5 +36,4 @@
|
||||
url = 'http://www.b2bua.org/',
|
||||
packages = ['sippy'],
|
||||
scripts = ['sippy/b2bua_radius.py', 'sippy/b2bua_simple.py'],
|
||||
- data_files = [('etc/sippy', ['sippy/dictionary']),
|
||||
- ('share/doc/sippy', ['COPYING'])])
|
||||
+ data_files = [('etc/sippy', ['sippy/dictionary']),])
|
|
@ -1,72 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for sippy
|
||||
|
||||
# Copyright 2013, Nikolay Korotkiy <sikmir@gmail.com>
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=sippy
|
||||
VERSION=${VERSION:-1.0.3}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
set -eu
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
patch -p0 < $CWD/setup.patch
|
||||
|
||||
python setup.py install --root=$PKG
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a COPYING README $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
|
@ -1,10 +0,0 @@
|
|||
PRGNAM="sippy"
|
||||
VERSION="1.0.3"
|
||||
HOMEPAGE="http://www.sippysoft.com/"
|
||||
DOWNLOAD="http://pkgs.fedoraproject.org/repo/pkgs/python-sippy/sippy-1.0.3.tar.gz/588a418e6a15c25eebd06bfb8fed81de/sippy-1.0.3.tar.gz"
|
||||
MD5SUM="588a418e6a15c25eebd06bfb8fed81de"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
MAINTAINER="Nikolay Korotkiy"
|
||||
EMAIL="sikmir@gmail.com"
|
|
@ -1,19 +0,0 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description.
|
||||
# Line up the first '|' above the ':' following the base package name, and
|
||||
# the '|' on the right side marks the last column you can put a character in.
|
||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
sippy: sippy (Sippy B2BUA)
|
||||
sippy:
|
||||
sippy: Sippy B2BUA is a RFC3261-compliant Session Initiation Protocol (SIP)
|
||||
sippy: Back-to-back user agent (B2BUA) server software.
|
||||
sippy:
|
||||
sippy:
|
||||
sippy:
|
||||
sippy:
|
||||
sippy: Homepage: http://www.sippysoft.com/
|
||||
sippy:
|
||||
sippy:
|
Loading…
Reference in a new issue