mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-04 20:29:09 +01:00
audio/vamp-plugin-sdk: Updated for version 2.5 + new maintainer.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
c8995cae00
commit
8b6271e87a
3 changed files with 24 additions and 34 deletions
|
@ -1,22 +0,0 @@
|
|||
--- vamp-plugin-sdk-v2.2.1/Makefile.in.orig 2011-05-13 02:19:01.394170602 -0300
|
||||
+++ vamp-plugin-sdk-v2.2.1/Makefile.in 2011-05-13 02:21:24.384083316 -0300
|
||||
@@ -71,8 +71,8 @@
|
||||
INSTALL_API_HEADERS = $(INSTALL_PREFIX)/include/vamp
|
||||
INSTALL_SDK_HEADERS = $(INSTALL_PREFIX)/include/vamp-sdk
|
||||
INSTALL_HOSTSDK_HEADERS = $(INSTALL_PREFIX)/include/vamp-hostsdk
|
||||
-INSTALL_SDK_LIBS = $(INSTALL_PREFIX)/lib
|
||||
-INSTALL_PLUGINS = $(INSTALL_PREFIX)/lib/vamp
|
||||
+INSTALL_SDK_LIBS = $(INSTALL_PREFIX)/lib64
|
||||
+INSTALL_PLUGINS = $(INSTALL_PREFIX)/lib64/vamp
|
||||
INSTALL_BINARIES = $(INSTALL_PREFIX)/bin
|
||||
|
||||
INSTALL_SDK_LIBNAME = libvamp-sdk.so.2.2.0
|
||||
@@ -87,7 +87,7 @@
|
||||
INSTALL_HOSTSDK_STATIC = libvamp-hostsdk.a
|
||||
INSTALL_HOSTSDK_LA = libvamp-hostsdk.la
|
||||
|
||||
-INSTALL_PKGCONFIG = $(INSTALL_PREFIX)/lib/pkgconfig
|
||||
+INSTALL_PKGCONFIG = $(INSTALL_PREFIX)/lib64/pkgconfig
|
||||
|
||||
# Flags required to tell the compiler to create a dynamically loadable object
|
||||
#
|
|
@ -1,12 +1,23 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for vamp
|
||||
# Slackware build script for vamp-plugin-sdk
|
||||
|
||||
# Written by Luis Henrique <lmello.009@gmail.com>
|
||||
|
||||
# Now maintained by B. Watson <yalhcru@gmail.com>, please don't bother
|
||||
# Luis with questions as he no longer uses Slackware.
|
||||
|
||||
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
|
||||
|
||||
# 20140915 bkw:
|
||||
# - Update for v2.5
|
||||
# - Get rid of static libs
|
||||
# - Use sed instead of a diff for lib64 on x86_64
|
||||
# - Fix the x86_64 lib path in the .pc files, too
|
||||
|
||||
PRGNAM=vamp-plugin-sdk
|
||||
VERSION=${VERSION:-2.4}
|
||||
BUILD=${BUILD:-2}
|
||||
VERSION=${VERSION:-2.5}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -52,7 +63,7 @@ find -L . \
|
|||
-exec chmod 644 {} \;
|
||||
|
||||
# Fix libdir on x86_64
|
||||
[ "$ARCH" = "x86_64" ] && patch -p1 < $CWD/libdir_x86_64.diff
|
||||
sed -i "s,\<lib\>,&$LIBDIRSUFFIX,g" Makefile.in pkgconfig/*.pc.in
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
|
@ -65,6 +76,9 @@ CXXFLAGS="$SLKCFLAGS" \
|
|||
make
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
# we don't want the static libs
|
||||
rm -f $PKG/usr/lib$LIBDIRSUFFIX/*.a
|
||||
|
||||
mkdir -p $PKG/etc/profile.d/
|
||||
cat << EOF > $PKG/etc/profile.d/vamp.csh
|
||||
#!/bin/csh
|
||||
|
@ -80,9 +94,7 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
|||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a \
|
||||
CHANGELOG COPYING INSTALL README README.compat \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a CHANGELOG COPYING INSTALL README* $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="vamp-plugin-sdk"
|
||||
VERSION="2.4"
|
||||
VERSION="2.5"
|
||||
HOMEPAGE="http://www.vamp-plugins.org"
|
||||
DOWNLOAD="http://code.soundsoftware.ac.uk/attachments/download/517/vamp-plugin-sdk-2.4.tar.gz"
|
||||
MD5SUM="4bd75ca4515c141cd8776bdb59066261"
|
||||
DOWNLOAD="https://code.soundsoftware.ac.uk/attachments/download/690/vamp-plugin-sdk-2.5.tar.gz"
|
||||
MD5SUM="199872997f74951f6769b982bf0d0646"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
MAINTAINER="Luis Henrique"
|
||||
EMAIL="lmello.009@gmail.com"
|
||||
MAINTAINER="B. Watson"
|
||||
EMAIL="yalhcru@gmail.com"
|
||||
|
|
Loading…
Reference in a new issue