academic/cblas: Updated for version 3.11.0

Signed-off-by: Kyle Guinn <elyk03@gmail.com>

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Kyle Guinn 2022-11-20 14:13:55 -06:00 committed by Willy Sudiarto Raharjo
parent 8b488fbd31
commit 8aaada867a
No known key found for this signature in database
GPG key ID: 3F617144D7238786
3 changed files with 22 additions and 13 deletions

View file

@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=cblas PRGNAM=cblas
SRCNAM=lapack SRCNAM=lapack
VERSION=${VERSION:-3.10.1} VERSION=${VERSION:-3.11.0}
BUILD=${BUILD:-1} BUILD=${BUILD:-1}
TAG=${TAG:-_SBo} TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz} PKGTYPE=${PKGTYPE:-tgz}

View file

@ -1,8 +1,8 @@
PRGNAM="cblas" PRGNAM="cblas"
VERSION="3.10.1" VERSION="3.11.0"
HOMEPAGE="https://www.netlib.org/blas/" HOMEPAGE="https://www.netlib.org/blas/"
DOWNLOAD="https://github.com/Reference-LAPACK/lapack/archive/v3.10.1/lapack-3.10.1.tar.gz" DOWNLOAD="https://github.com/Reference-LAPACK/lapack/archive/v3.11.0/lapack-3.11.0.tar.gz"
MD5SUM="722407217a080a0012ae3d6913fb8008" MD5SUM="595b064fd448b161cd711fe346f498a7"
DOWNLOAD_x86_64="" DOWNLOAD_x86_64=""
MD5SUM_x86_64="" MD5SUM_x86_64=""
REQUIRES="blas" REQUIRES="blas"

View file

@ -96,12 +96,12 @@ deleted file mode 100644
diff --git a/CBLAS/src/CMakeLists.txt b/CBLAS/src/CMakeLists.txt diff --git a/CBLAS/src/CMakeLists.txt b/CBLAS/src/CMakeLists.txt
--- a/CBLAS/src/CMakeLists.txt --- a/CBLAS/src/CMakeLists.txt
+++ b/CBLAS/src/CMakeLists.txt +++ b/CBLAS/src/CMakeLists.txt
@@ -123,9 +123,5 @@ @@ -127,9 +127,5 @@
if(HAS_ATTRIBUTE_WEAK_SUPPORT) if(HAS_ATTRIBUTE_WEAK_SUPPORT)
target_compile_definitions(${CBLASLIB} PRIVATE HAS_ATTRIBUTE_WEAK_SUPPORT) target_compile_definitions(${CBLASLIB} PRIVATE HAS_ATTRIBUTE_WEAK_SUPPORT)
endif() endif()
-target_include_directories(${CBLASLIB} PUBLIC -target_include_directories(${CBLASLIB} PUBLIC
- $<BUILD_INTERFACE:${LAPACK_BINARY_DIR}/../include> - $<BUILD_INTERFACE:${LAPACK_BINARY_DIR}/include>
- $<INSTALL_INTERFACE:include> - $<INSTALL_INTERFACE:include>
-) -)
target_link_libraries(${CBLASLIB} PRIVATE ${BLAS_LIBRARIES}) target_link_libraries(${CBLASLIB} PRIVATE ${BLAS_LIBRARIES})
@ -152,7 +152,16 @@ deleted file mode 100644
diff --git a/CMakeLists.txt b/CMakeLists.txt diff --git a/CMakeLists.txt b/CMakeLists.txt
--- a/CMakeLists.txt --- a/CMakeLists.txt
+++ b/CMakeLists.txt +++ b/CMakeLists.txt
@@ -173,11 +173,8 @@ @@ -42,7 +42,7 @@
endif()
# By default test Fortran compiler complex abs and complex division
-option(TEST_FORTRAN_COMPILER "Test Fortran compiler complex abs and complex division" ON)
+option(TEST_FORTRAN_COMPILER "Test Fortran compiler complex abs and complex division" OFF)
if( TEST_FORTRAN_COMPILER )
add_executable( test_zcomplexabs ${LAPACK_SOURCE_DIR}/INSTALL/test_zcomplexabs.f )
@@ -209,11 +209,8 @@
# -------------------------------------------------- # --------------------------------------------------
@ -164,7 +173,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR} COMPONENT Development ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR} COMPONENT Development
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} COMPONENT RuntimeLibraries LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} COMPONENT RuntimeLibraries
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR} COMPONENT RuntimeLibraries RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR} COMPONENT RuntimeLibraries
@@ -217,21 +214,6 @@ @@ -253,21 +250,6 @@
include(CheckLAPACKCompilerFlags) include(CheckLAPACKCompilerFlags)
CheckLAPACKCompilerFlags() CheckLAPACKCompilerFlags()
@ -172,7 +181,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
-# Check second function -# Check second function
- -
-include(CheckTimeFunction) -include(CheckTimeFunction)
-set(NONE ${TIME_FUNC}) -set(TIME_FUNC NONE)
-CHECK_TIME_FUNCTION(NONE TIME_FUNC) -CHECK_TIME_FUNCTION(NONE TIME_FUNC)
-CHECK_TIME_FUNCTION(INT_CPU_TIME TIME_FUNC) -CHECK_TIME_FUNCTION(INT_CPU_TIME TIME_FUNC)
-CHECK_TIME_FUNCTION(EXT_ETIME TIME_FUNC) -CHECK_TIME_FUNCTION(EXT_ETIME TIME_FUNC)
@ -186,7 +195,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
# deprecated LAPACK and LAPACKE routines # deprecated LAPACK and LAPACKE routines
option(BUILD_DEPRECATED "Build deprecated routines" OFF) option(BUILD_DEPRECATED "Build deprecated routines" OFF)
message(STATUS "Build deprecated routines: ${BUILD_DEPRECATED}") message(STATUS "Build deprecated routines: ${BUILD_DEPRECATED}")
@@ -256,8 +238,9 @@ @@ -292,8 +274,9 @@
# -------------------------------------------------- # --------------------------------------------------
@ -197,7 +206,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
# Check the usage of the user provided BLAS libraries # Check the usage of the user provided BLAS libraries
if(BLAS_LIBRARIES) if(BLAS_LIBRARIES)
@@ -268,133 +251,109 @@ @@ -304,133 +287,109 @@
if(BLAS_FOUND) if(BLAS_FOUND)
message(STATUS "--> BLAS supplied by user is WORKING, will use ${BLAS_LIBRARIES}.") message(STATUS "--> BLAS supplied by user is WORKING, will use ${BLAS_LIBRARIES}.")
else() else()
@ -301,7 +310,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
+ +
+ # Check second function + # Check second function
+ include(CheckTimeFunction) + include(CheckTimeFunction)
+ set(NONE ${TIME_FUNC}) + set(TIME_FUNC NONE)
+ CHECK_TIME_FUNCTION(NONE TIME_FUNC) + CHECK_TIME_FUNCTION(NONE TIME_FUNC)
+ CHECK_TIME_FUNCTION(INT_CPU_TIME TIME_FUNC) + CHECK_TIME_FUNCTION(INT_CPU_TIME TIME_FUNC)
+ CHECK_TIME_FUNCTION(EXT_ETIME TIME_FUNC) + CHECK_TIME_FUNCTION(EXT_ETIME TIME_FUNC)
@ -381,7 +390,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
#------------------------------------- #-------------------------------------
# BLAS++ / LAPACK++ # BLAS++ / LAPACK++
option(BLAS++ "Build BLAS++" OFF) option(BLAS++ "Build BLAS++" OFF)
@@ -444,111 +403,16 @@ @@ -480,111 +439,16 @@
ExternalProject_Add_StepDependencies(lapackpp build blaspp ${BLAS_LIBRARIES} ${LAPACK_LIBRARIES}) ExternalProject_Add_StepDependencies(lapackpp build blaspp ${BLAS_LIBRARIES} ${LAPACK_LIBRARIES})
endif() endif()