development/meld3: Added patch to work with UTF-8.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Willy Sudiarto Raharjo 2014-12-23 07:50:11 +07:00
parent be2d8d211f
commit 8a91a15d8d
2 changed files with 12 additions and 1 deletions

View file

@ -25,7 +25,7 @@
PRGNAM=meld3
SRCNAM=meld
VERSION=${VERSION:-3.12.2}
BUILD=${BUILD:-1}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -68,6 +68,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch -p1 < $CWD/utf8.patch
python setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION

View file

@ -0,0 +1,10 @@
--- a/meld/patchdialog.py
+++ b/meld/patchdialog.py
@@ -118,6 +118,7 @@
filename = self.filediff._get_filename_for_saving(
_("Save Patch"))
if filename:
+ txt = txt.encode('utf-8')
self.filediff._save_text_to_filename(filename, txt)
break