mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
development/gazpacho: Removed (nonfunctional)
gazpacho builds (well, it's python), but doesn't work. There has not been an update in years, so I guess this is end-of-life for this SlackBuild. Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
e5843ee724
commit
8a0b0dca4f
6 changed files with 0 additions and 153 deletions
|
@ -1,7 +0,0 @@
|
|||
gazpacho (Next Generation GUI Design)
|
||||
|
||||
This program allows you to create the Graphical User Interface (GUI)
|
||||
of your GTK+ program in a visual way. It started as a Glade-3 clone
|
||||
but now it is more complete and featured than its ancestor. It tries
|
||||
to be compatible with libglade but it can handle some widgets that
|
||||
still lack support in libglade.
|
|
@ -1,33 +0,0 @@
|
|||
--- bin/gazpacho.orig 2009-08-17 00:15:26.000000000 +0300
|
||||
+++ bin/gazpacho 2009-08-17 00:15:44.000000000 +0300
|
||||
@@ -40,30 +40,6 @@
|
||||
appname,
|
||||
string.split(sys.version)[0]))
|
||||
|
||||
-# Figure out the directy which is the prefix
|
||||
-# path-of-current-file/..
|
||||
-currentdir = os.path.dirname(os.path.abspath(sys.argv[0]))
|
||||
-basedir = os.path.abspath(os.path.join(currentdir, '..'))
|
||||
-
|
||||
-# Add the base directory where the application is installed in to sys.path
|
||||
-if os.path.exists(os.path.join(basedir, 'lib')):
|
||||
- if sys.platform == 'win32':
|
||||
- pythondir = os.path.join(basedir, 'Lib', 'site-packages')
|
||||
- else:
|
||||
- pythondir = os.path.join(basedir, 'lib',
|
||||
- 'python%d.%d' % sys.version_info[:2],
|
||||
- 'site-packages')
|
||||
- if not os.path.exists(pythondir):
|
||||
- raise SystemExit("ERROR: Could not find required directory: %s" %
|
||||
- pythondir)
|
||||
-elif not os.path.exists(os.path.join(basedir, dirname)):
|
||||
- raise SystemExit("ERROR: Could not find required directory: %s" %
|
||||
- os.path.join(basedir, dirname))
|
||||
-else:
|
||||
- pythondir = basedir
|
||||
-
|
||||
-sys.path.insert(0, pythondir)
|
||||
-
|
||||
from gazpacho import main
|
||||
|
||||
try:
|
|
@ -1,4 +0,0 @@
|
|||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
|
@ -1,80 +0,0 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for gazpacho
|
||||
|
||||
# Copyright 2011 Mikko Värri, Finland
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=gazpacho
|
||||
VERSION=${VERSION:-0.7.2}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
# Automatically determine the architecture we're building on:
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
# Unless $ARCH is already set, use uname -m for all other archs:
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||
-exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Remove sys.path manipulation which is only needed for the developers who
|
||||
# don't want to install the development version (and the manipulation assumes
|
||||
# %prefix%/lib/ as the python path).
|
||||
patch -p0 < $CWD/bin_gazpacho.patch
|
||||
|
||||
python setup.py install --root=$PKG
|
||||
|
||||
mkdir -p $PKG/usr/doc
|
||||
mv $PKG/usr/share/doc/$PRGNAM $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
rmdir $PKG/usr/share/doc
|
||||
|
||||
# Gazpacho refuses to start unless /usr/share/doc/gazpacho exists
|
||||
( cd $PKG/usr/doc; ln -s $PRGNAM-$VERSION $PRGNAM )
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
|
@ -1,10 +0,0 @@
|
|||
PRGNAM="gazpacho"
|
||||
VERSION="0.7.2"
|
||||
HOMEPAGE="http://gazpacho.sicem.biz/"
|
||||
DOWNLOAD="http://ftp.gnome.org/pub/GNOME/sources/gazpacho/0.7/gazpacho-0.7.2.tar.gz"
|
||||
MD5SUM="42d180f2570f2f5d6c0fa69ed9897d9b"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="kiwi"
|
||||
MAINTAINER="Mikko Varri"
|
||||
EMAIL="vmj@linuxbox.fi"
|
|
@ -1,19 +0,0 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|'
|
||||
# on the right side marks the last column you can put a character in. You must
|
||||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
gazpacho: gazpacho (Next Generation GUI Design)
|
||||
gazpacho:
|
||||
gazpacho: This program allows you to create the Graphical User Interface (GUI)
|
||||
gazpacho: of your GTK+ program in a visual way. It started as a Glade-3 clone
|
||||
gazpacho: but now it is more complete and featured than its ancestor. It tries
|
||||
gazpacho: to be compatible with libglade but it can handle some widgets that
|
||||
gazpacho: still lack support in libglade.
|
||||
gazpacho:
|
||||
gazpacho: Homepage: http://gazpacho.sicem.biz
|
||||
gazpacho:
|
||||
gazpacho:
|
Loading…
Reference in a new issue