mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-22 19:44:21 +01:00
audio/muse: Updated for version 3.1.1.
Fixes building against qt5 Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
b4fd4e1b92
commit
87cb8b45c3
3 changed files with 7 additions and 28 deletions
|
@ -10,7 +10,7 @@
|
||||||
# - add realtime capability support
|
# - add realtime capability support
|
||||||
|
|
||||||
PRGNAM=muse
|
PRGNAM=muse
|
||||||
VERSION=${VERSION:-3.1}
|
VERSION=${VERSION:-3.1.1}
|
||||||
BUILD=${BUILD:-1}
|
BUILD=${BUILD:-1}
|
||||||
TAG=${TAG:-_SBo}
|
TAG=${TAG:-_SBo}
|
||||||
|
|
||||||
|
@ -56,7 +56,8 @@ find -L . \
|
||||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||||
-exec chmod 644 {} \;
|
-exec chmod 644 {} \;
|
||||||
|
|
||||||
patch -p1 < $CWD/qt512.patch
|
# Change the INSTALL_NAME or every path in the package is versioned
|
||||||
|
sed -e "s/muse-3.1/muse/" -i CMakeLists.txt
|
||||||
|
|
||||||
mkdir -p build
|
mkdir -p build
|
||||||
cd build
|
cd build
|
||||||
|
@ -79,7 +80,7 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||||
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||||
|
|
||||||
mkdir -p $PKG/usr/doc
|
mkdir -p $PKG/usr/doc
|
||||||
mv $PKG/usr/share/doc/$PRGNAM-$VERSION $PKG/usr/doc/$PRGNAM-$VERSION
|
mv $PKG/usr/share/doc/$PRGNAM $PKG/usr/doc/$PRGNAM-$VERSION
|
||||||
rmdir $PKG/usr/share/doc
|
rmdir $PKG/usr/share/doc
|
||||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||||
|
|
||||||
|
|
|
@ -1,8 +1,8 @@
|
||||||
PRGNAM="muse"
|
PRGNAM="muse"
|
||||||
VERSION="3.1"
|
VERSION="3.1.1"
|
||||||
HOMEPAGE="http://muse-sequencer.org/"
|
HOMEPAGE="http://muse-sequencer.org/"
|
||||||
DOWNLOAD="https://sourceforge.net/projects/lmuse/files/muse-3.1/muse-3.1.tar.gz"
|
DOWNLOAD="https://downloads.sourceforge.net/lmuse/muse-3.1.1.tar.gz"
|
||||||
MD5SUM="45557bf2f0932daedd057678b3faf913"
|
MD5SUM="ac9da5c16b670fd6a3139e86845a3d4d"
|
||||||
DOWNLOAD_x86_64=""
|
DOWNLOAD_x86_64=""
|
||||||
MD5SUM_x86_64=""
|
MD5SUM_x86_64=""
|
||||||
REQUIRES="jack ladspa_sdk liblo qt5"
|
REQUIRES="jack ladspa_sdk liblo qt5"
|
||||||
|
|
|
@ -1,22 +0,0 @@
|
||||||
diff -Naur muse-3.0.2/muse/mplugins/mitplugin.cpp muse-3.0.2.patched/muse/mplugins/mitplugin.cpp
|
|
||||||
--- muse-3.0.2/muse/mplugins/mitplugin.cpp 2017-12-04 22:01:18.000000000 +0100
|
|
||||||
+++ muse-3.0.2.patched/muse/mplugins/mitplugin.cpp 2020-02-26 23:27:20.013277911 +0100
|
|
||||||
@@ -21,6 +21,7 @@
|
|
||||||
//
|
|
||||||
//=========================================================
|
|
||||||
|
|
||||||
+#include <QtWidgets>
|
|
||||||
#include "mitplugin.h"
|
|
||||||
#include "app.h"
|
|
||||||
#include "event.h"
|
|
||||||
diff -Naur muse-3.0.2/muse/widgets/genset.cpp muse-3.0.2.patched/muse/widgets/genset.cpp
|
|
||||||
--- muse-3.0.2/muse/widgets/genset.cpp 2018-01-22 17:43:28.000000000 +0100
|
|
||||||
+++ muse-3.0.2.patched/muse/widgets/genset.cpp 2020-02-26 21:47:19.446707723 +0100
|
|
||||||
@@ -24,6 +24,7 @@
|
|
||||||
|
|
||||||
#include <stdio.h>
|
|
||||||
|
|
||||||
+#include <QButtonGroup>
|
|
||||||
#include <QFileDialog>
|
|
||||||
#include <QFileInfo>
|
|
||||||
#include <QRect>
|
|
Loading…
Reference in a new issue