academic/ITK: Support for Slackware current.

This commit is contained in:
Benjamin Trigona-Harany 2018-08-20 13:15:59 -07:00 committed by Willy Sudiarto Raharjo
parent b94cf5628d
commit 869278e195
No known key found for this signature in database
GPG key ID: 887B8374D7333381
2 changed files with 37 additions and 0 deletions

View file

@ -76,6 +76,9 @@ sed -i "s/lib\b/lib${LIBDIRSUFFIX}/" CMakeLists.txt
sed -i "s|/opj_config.h|& \$\{CMAKE_CURRENT_BINARY_DIR\}/openjpeg_mangle.h|" \ sed -i "s|/opj_config.h|& \$\{CMAKE_CURRENT_BINARY_DIR\}/openjpeg_mangle.h|" \
Modules/ThirdParty/GDCM/src/gdcm/Utilities/gdcmopenjpeg/src/lib/openjp2/CMakeLists.txt Modules/ThirdParty/GDCM/src/gdcm/Utilities/gdcmopenjpeg/src/lib/openjp2/CMakeLists.txt
# allow compilation under GCC 8
patch -p1 Modules/ThirdParty/VNL/src/vxl/vcl/vcl_compiler.h < $CWD/gcc8.patch
mkdir -p build mkdir -p build
cd build cd build
cmake \ cmake \

34
academic/ITK/gcc8.patch Normal file
View file

@ -0,0 +1,34 @@
From 2662860491ff44a16e01581a6b3727d53997fee8 Mon Sep 17 00:00:00 2001
From: Pablo Hernandez-Cerdan <pablo.hernandez.cerdan@outlook.com>
Date: Tue, 15 May 2018 16:17:01 -0400
Subject: [PATCH] COMP: Add gcc8 support to vcl_compiler.
It just adds a if/else branch to the existing logic.
Triggered here: https://discourse.itk.org/t/building-and-compiling-with-gcc-8-1/934/4
---
vcl/vcl_compiler.h | 11 +++++++++++
1 file changed, 11 insertions(+)
diff --git a/vcl/vcl_compiler.h b/vcl/vcl_compiler.h
index 6a3f2e2152..5ca624603d 100644
--- a/vcl/vcl_compiler.h
+++ b/vcl/vcl_compiler.h
@@ -86,6 +86,17 @@
# else
# define VCL_GCC_70
# endif
+# elif (__GNUC__==8)
+# define VCL_GCC_8
+# if (__GNUC_MINOR__ > 2 )
+# define VCL_GCC_83
+# elif (__GNUC_MINOR__ > 1 )
+# define VCL_GCC_82
+# elif (__GNUC_MINOR__ > 0 )
+# define VCL_GCC_81
+# else
+# define VCL_GCC_80
+# endif
# else
# error "Dunno about this gcc"
# endif