office/go_openoffice: Removed (build failure)

David is going to fix this up and resubmit it soonish. :-)
This commit is contained in:
Robby Workman 2010-05-24 16:54:45 -05:00
parent c4eaa5ab40
commit 859bb8b2d4
9 changed files with 0 additions and 3958 deletions

View file

@ -1,28 +0,0 @@
Go-oo is a fork of the OpenOffice.org Office Suite.
Go-oo has built in OpenXML import filters and it will import your Microsoft
Works files. Compared with up-stream OO.o, it has better Microsoft binary
file support (with eg. fields support), and it will import WordPerfect
graphics beautifully. If you are reliant on Excel VBA macros - then Go-oo
offers the best macro fidelity too. If you expect your spreadsheets to
calculate compatibly, or you get embedded Visio diagrams in your documents,
you'll want Go-oo.
NOTE: This build needs a few gig in $TMP and the source is about 400 meg
to download. It also takes hours to compile. This build is still a WIP
due to the long build time it is very hard to QA test.
This requires xulrunner, Archive-Zip, icu4c, apache-ant, jdk from /extra,
and seamonkey2 from /patches in Slackware.
Optional requirements are avahi, openclipart, ORBit2, GConf, and gnome-vfs.
Variables that can be passed to the SlackBuild script:
ARTPATH Path to openclipart, leave unset to disable.
NVIDIA=no Turns off an nvidia build work around.
LINGUAS_OOO Sets the languages to add.
PLUGIN=no Disable openoffice's mozilla plugin.
KDE=no Disable KDE4 UI.
GTK=no Disable GTK UI.
GNOME=yes Enables optioal gnome bits.
MYCONF Used to pass extra configure options.

View file

@ -1,29 +0,0 @@
config() {
NEW="$1"
OLD="$(dirname $NEW)/$(basename $NEW .new)"
# If there's no config file by that name, mv it over:
if [ ! -r $OLD ]; then
mv $NEW $OLD
elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
# toss the redundant copy
rm $NEW
fi
# Otherwise, we leave the .new copy for the admin to consider...
}
config etc/bash_completion.d/go_ooffice.sh.new
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
if [ -x /usr/bin/update-mime-database ]; then
/usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
fi
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
if [ -x /usr/bin/gtk-update-icon-cache ]; then
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
fi
fi

View file

@ -1,218 +0,0 @@
#!/bin/sh
# Slackware build script for go_openoffice
# Written by David Somero <dsomero@hotmail.com>
# Derived from Slackware's Slackbuilds.
#
# Copyright 2008, 2009 Patrick J. Volkerding, Sebeka, Minnesota, USA
# Copyright 2010 David Somero (dsomero@hotmail.com) Athens, TN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=go_openoffice
VERSION=3.1.1.5
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
fi
if [ ${NVIDIA:-yes} = "yes" ]; then
SLKCFLAGS="$SLKCFLAGS -DGL_GLEXT_PROTOTYPES"
fi
if [[ -z "${LINGUAS_OOO}" ]]; then
export LINGUAS_OOO="en-US"
else
export LINGUAS_OOO=$(echo ${LINGUAS_OOO} | sed -e 's/\ben\b/en_US/g;s/_/-/g')
fi
if [[ -z "${ARTPATH}" ]]; then
MYCONF="$MYCONF --without-openclipart"
else
MYCONF="$MYCONF --with-openclipart=${ARTPATH:-/usr/share/openclipart}"
fi
if [ ${GTK:-yes} = "yes" ]; then
MYCONF="$MYCONF --enable-gtk --enable-cairo --with-system-cairo"
else
MYCONF="$MYCONF --disable-gtk --disable-cairo --without-system-cairo"
fi
if [ ${GNOME:-no} = "no" ]; then
MYCONF="$MYCONF --disable-gnome --disable-gconf --disable-gnome-vfs"
fi
if [ ${KDE:-yes} = "yes" ]; then
MYCONF="$MYCONF --enable-kde4"
export QTDIR="${QT4DIR}"
export QTINC="$QTDIR/include"
export QTLIB="$QTDIR/lib$LIBDIRSUFFIX"
else
MYCONF="$MYCONF --disable-kde4"
fi
export CFLAGS="$SLKCFLAGS"
export CXXFLAGS="$SLKCFLAGS"
export OODESTDIR="$PKG"
export ARCH_FLAGS="$SLKCFLAGS"
# May need this on a multilib system.
#export LINKFLAGSOPTIMIZE="${LDFLAGS}"
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf ooo-build-$VERSION
tar xvf $CWD/ooo-build-$VERSION.tar.gz
cd ooo-build-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Upstream patches.
cp -f $CWD/patches/base64.diff patches/hotfixes
cp -f $CWD/patches/boost-undefined-references.diff patches/hotfixes
# Our patches to fix building on Slackware.
cp -f $CWD/patches/apply patches/dev300
cp -f $CWD/patches/Slackware.conf.in distro-configs
./configure \
$MYCONF \
--prefix=/usr \
--mandir=/usr/man \
--sysconfdir=/etc \
--without-binsuffix \
--localstatedir=/var/lib \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--with-installed-ooo-dirname=$PRGNAM \
--with-docdir=/usr/share/doc/$PRGNAM \
--with-ant-home=/usr/share/apache-ant \
--with-intro-bitmaps=$TMP/ooo-build-$VERSION/src/openintro_go-oo.bmp \
--with-about-bitmaps=$TMP/ooo-build-$VERSION/src/openabout_go-oo.bmp \
--with-lang=${LINGUAS_OOO} \
--with-num-cpus=${CPUS:-1} \
--with-max-jobs=${CPUS:-1} \
--with-extension-integration \
--with-java \
--disable-odk \
--disable-pam \
--disable-pam-link \
--disable-mono \
--disable-kde \
--disable-post-install-scripts \
--disable-rpath \
--enable-opengl \
--enable-openldap \
--enable-openxml \
--enable-cups \
--enable-fontconfig \
--enable-dbus \
--enable-access \
--enable-vba \
--enable-systray \
--enable-presenter-console \
--enable-pdfimport \
--enable-minimizer \
--enable-split-app-modules \
--enable-split-opt-features \
--with-system-python \
--with-system-expat \
--with-system-freetype \
--with-system-jpeg \
--with-system-curl \
--with-system-redland \
--with-system-poppler \
--with-system-libwpd \
--with-system-neon \
--with-system-icu \
--with-system-boost \
--with-system-mozilla=mozilla \
--with-gcc-speedup=ccache \
--with-system-db \
--with-mdbtools \
--with-drink=ale \
--with-distro=Slackware \
--with-lightproof \
--with-numbertext \
--with-arch=x86 \
--build=$ARCH-slackware-linux || exit 1
# Move local copies of the source packages.
cp -a $CWD/* ./src/
# Works around a make jobs bug
make -j1 patch.apply && make
cd bin
OODESTDIR=$PKG ./package-ooo || exit 1
cd -
# Preserve any existing config files
mv $PKG/etc/bash_completion.d/ooffice.sh \
$PKG/etc/bash_completion.d/go_ooffice.sh.new
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
( cd $PKG/usr/man
find . -type f -exec gzip -9 {} \;
for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
)
# If the user wants the plugin installed, then we'll do that too.
if [ ${PLUGIN:-yes} = "yes" ]; then
mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/mozilla/plugins
cd $PKG/usr/lib${LIBDIRSUFFIX}/mozilla/plugins
ln -s /usr/lib${LIBDIRSUFFIX}/go_openoffice/program/libnpsoplugin.so libnpsoplugin.so
cd -
fi
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
AUTHORS COPYING ChangeLog INSTALL NEWS README \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View file

@ -1,64 +0,0 @@
PRGNAM="go_openoffice"
VERSION="3.1.1.5"
HOMEPAGE="http://go-oo.org/"
DOWNLOAD="http://download.go-oo.org/OOO310/ooo-build-3.1.1.5.tar.gz
http://download.go-oo.org/OOO310/ooo310-m19-artwork.tar.bz2
http://download.go-oo.org/OOO310/ooo310-m19-base.tar.bz2
http://download.go-oo.org/OOO310/ooo310-m19-bootstrap.tar.bz2
http://download.go-oo.org/OOO310/ooo310-m19-calc.tar.bz2
http://download.go-oo.org/OOO310/ooo310-m19-components.tar.bz2
http://download.go-oo.org/OOO310/ooo310-m19-extensions.tar.bz2
http://download.go-oo.org/OOO310/ooo310-m19-extras.tar.bz2
http://download.go-oo.org/OOO310/ooo310-m19-filters.tar.bz2
http://download.go-oo.org/OOO310/ooo310-m19-help.tar.bz2
http://download.go-oo.org/OOO310/ooo310-m19-impress.tar.bz2
http://download.go-oo.org/OOO310/ooo310-m19-libs-core.tar.bz2
http://download.go-oo.org/OOO310/ooo310-m19-libs-extern.tar.bz2
http://download.go-oo.org/OOO310/ooo310-m19-libs-extern-sys.tar.bz2
http://download.go-oo.org/OOO310/ooo310-m19-libs-gui.tar.bz2
http://download.go-oo.org/OOO310/ooo310-m19-postprocess.tar.bz2
http://download.go-oo.org/OOO310/ooo310-m19-sdk.tar.bz2
http://download.go-oo.org/OOO310/ooo310-m19-testing.tar.bz2
http://download.go-oo.org/OOO310/ooo310-m19-ure.tar.bz2
http://download.go-oo.org/OOO310/ooo310-m19-writer.tar.bz2
http://download.go-oo.org/SRC680/extras-3.tar.bz2
http://download.go-oo.org/SRC680/biblio.tar.bz2
http://download.go-oo.org/DEV300/ooo_oxygen_images-2009-06-17.tar.gz
http://download.go-oo.org/SRC680/libwps-0.1.2.tar.gz
http://download.go-oo.org/SRC680/libwpg-0.1.3.tar.gz
http://download.go-oo.org//SRC680/mdbtools-0.6pre1.tar.gz
ftp://ftp.devall.hu/kami/go-oo//numbertext-0.6.1.oxt
ftp://ftp.devall.hu/kami/go-oo//lightproof-1.1.oxt"
MD5SUM="c1303e19302c087ce6dab43be42695df
092ce8212b591f8090a408631f0f3b5d
1cc6e2e31fbcc9b2e936e700235f5b1c
c2552c5b91054317806502fa5bd28087
da748a39c9d83a09badd8bd9604d4489
e5e3825fac16609c810fab3fbe2eb9d5
c0d5a2510c0a177d922f2027fbe983a2
257ac5758245c2ee1590273489b19048
5b78c271a6f8a8b95c15fb4689646e5b
2e0c32bbd34959999cf8aaa6b628cf44
8695921e8d5153de7bb2002caea9e0a4
a346c28a07c633cdb5e23fc38ba994c1
ef63e0ad73e1819e65ccfdb242408cde
df12331498c6ee810e8f768670bdf2a7
99fa052555499b06c78d9dd95cd84ce2
83ac184404a5e940f11b15e191f0414a
e4cd8de5ac4eed15792b9e4f45c4a789
dbb7b4c748664cc1c369f2c88b4072c9
f01114677484b4e008a4c0dde44282ab
5aa48153b1de6988bc5ca21f5800e8c4
36f323a55ee83e9dc968e1b92569b62a
1948e39a68f12bfa0b7eb309c14d940c
0b3ffc43231c525db1798495a6676902
799fc3b835a79adce8c88a3fee0150c1
db556b750bf3eac8481a4cc5e29e5af1
246e8f38b2a1af1bcff60ee0da59300b
e751a9c4da57b35d9113b75708d9d671
6b06f806c73e722c2fc980ac827204ec"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="David Somero"
EMAIL="dsomero@hotmail.com"
APPROVED="rworkman"

View file

@ -1,56 +0,0 @@
--with-vendor=\"Slackware\"
--prefix=/usr
--mandir=/usr/man
--sysconfdir=/etc
--without-binsuffix
--localstatedir=/var/lib
--with-ant-home=/usr/share/apache-ant
--with-extension-integration
--with-java
--with-x
--disable-odk
--disable-pam
--disable-pam-link
--disable-mono
--disable-kde
--disable-post-install-scripts
--disable-rpath
--enable-bonobo
--enable-libart
--enable-libsn
--enable-opengl
--enable-openldap
--enable-openxml
--enable-cups
--enable-fontconfig
--enable-dbus
--enable-access
--enable-cairo
--enable-kde4
--enable-gtk
--enable-systray
--enable-presenter-console
--enable-pdfimport
--enable-minimizer
--enable-split-app-modules
--enable-split-opt-features
--with-system-sane-header
--with-system-libpwd
--with-system-python
--with-system-expat
--with-system-freetype
--with-system-jpeg
--with-system-curl
--with-system-redland
--with-system-poppler
--with-system-libwpd
--with-system-cairo
--with-system-neon
--with-system-icu
--with-system-boost
--with-system-mozilla=mozilla
--with-system-libsvg
--with-system-sndfile
--with-gcc-speedup=ccache
--with-system-db
--with-drink=ale

File diff suppressed because it is too large Load diff

View file

@ -1,16 +0,0 @@
--- filter/source/xsltfilter/makefile.mk 2009-03-27 10:14:39.000000000 +0300
+++ filter/source/xsltfilter/makefile.mk 2009-03-27 18:14:56.000000000 +0300
@@ -72,11 +72,11 @@
CUSTOMMANIFESTFILE = Manifest
JARCOMPRESS = TRUE
-JARCLASSDIRS = XSLTransformer*.class XSLTFilterOLEExtracter*.class
+JARCLASSDIRS = XSLTransformer*.class XSLTFilterOLEExtracter*.class Base64*.class
JARTARGET = $(TARGET).jar
# --- Files --------------------------------------------------------
-JAVACLASSFILES=$(CLASSDIR)$/XSLTransformer.class $(CLASSDIR)$/XSLTFilterOLEExtracter.class
+JAVACLASSFILES=$(CLASSDIR)$/XSLTransformer.class $(CLASSDIR)$/XSLTFilterOLEExtracter.class $(CLASSDIR)$/Base64.class
.ENDIF
# --- Targets ------------------------------------------------------

View file

@ -1,12 +0,0 @@
--- sc/source/core/tool/makefile.mk-orig 2009-09-07 20:15:14.880679704 -0500
+++ sc/source/core/tool/makefile.mk 2009-09-07 20:14:38.941679215 -0500
@@ -132,7 +132,8 @@
$(SLO)$/prnsave.obj \
$(SLO)$/reftokenhelper.obj \
$(SLO)$/stringutil.obj \
- $(SLO)$/token.obj
+ $(SLO)$/token.obj \
+ $(SLO)$/detfunc.obj
# [kh] POWERPC compiler problem
.IF "$(OS)$(COM)$(CPUNAME)"=="LINUXGCCPOWERPC"

View file

@ -1,19 +0,0 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
go_openoffice: go_openoffice (a fork of the OpenOffice.org Office Suite)
go_openoffice:
go_openoffice: Go-oo has built in OpenXML import filters and it will import your
go_openoffice: Microsoft Works files. Compared with up-stream OO.o, it has better
go_openoffice: Microsoft binary file support (with eg. fields support), and it will
go_openoffice: import WordPerfect graphics beautifully. If you are reliant on Excel
go_openoffice: VBA macros - then Go-oo offers the best macro fidelity too. If you
go_openoffice: expect your spreadsheets to calculate compatibly, or you get embedded
go_openoffice: Visio diagrams in your documents, you'll want Go-oo.
go_openoffice:
go_openoffice: Homepage: http://go-oo.org