office/pcal: Added (generate monthly format calendars)

Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
This commit is contained in:
Tracy Williams 2011-01-02 12:21:03 -02:00 committed by Robby Workman
parent a74123b39b
commit 83ab8be7f6
5 changed files with 125 additions and 0 deletions

10
office/pcal/README Normal file
View file

@ -0,0 +1,10 @@
PCAL is a multi-platform (Unix/Linux, DOS, DOS+DJGPP, Windows+Cygwin,
Amiga) program which generates annotated PostScript or HTML calendars
in a monthly or yearly format.
It is usually run from the command line but there is an HTML/CGI
capability as well, to generate calendars (in either PostScript or HTML
format) from a web-browser interface.
Configuration file examples are available in the
/usr/doc/pcal-4.11.0/examples/ directory.

12
office/pcal/bindir.diff Normal file
View file

@ -0,0 +1,12 @@
diff -Naur pcal-4.11.0_orig/Makefile pcal-4.11.0/Makefile
--- pcal-4.11.0_orig/Makefile 2007-12-18 11:30:00.000000000 -0800
+++ pcal-4.11.0/Makefile 2011-01-01 22:18:02.000000000 -0800
@@ -147,7 +147,7 @@
MANDIR = $(DJDIR)/man/man1
CATDIR = $(DJDIR)/man/cat1
else # Unix
- BINDIR = /usr/local/bin
+ BINDIR = /usr/bin
MANDIR = /usr/man/man1
CATDIR = /usr/man/cat1
endif

View file

@ -0,0 +1,74 @@
#!/bin/sh
# Slackware build script for pcal
# Written by Tracy Williams
# contact: t_s_williams[at]yahoo[dot]com
PRGNAM=pcal
VERSION=4.11.0
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -eu
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tgz
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R a-s,u+w,go+r-w .
### There is no configure script for this application
### Makefile - Change BINDIR from /usr/local/bin to /usr/bin
patch -p1 < $CWD/bindir.diff
make CFLAGS="$SLKCFLAGS"
make install DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
### Man pages are compressed, should be gzipped
find $PKG/usr/man -type f -exec uncompress {} \;
find $PKG/usr/man -type f -exec gzip -9 {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a doc/ReadMe.txt doc/pcal-help.html doc/pcal-help.ps doc/pcal-help.txt \
doc/pcal.cat examples/ html/ scripts/ \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

10
office/pcal/pcal.info Normal file
View file

@ -0,0 +1,10 @@
PRGNAM="pcal"
VERSION="4.11.0"
HOMEPAGE="http://pcal.sourceforge.net"
DOWNLOAD="http://downloads.sourceforge.net/pcal/pcal-4.11.0.tgz"
MD5SUM="0ed7e9bec81fe3bdd62f8af283bef704"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Tracy Williams"
EMAIL="t_s_williams[at]yahoo[dot]com"
APPROVED="Niels Horn"

19
office/pcal/slack-desc Normal file
View file

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
pcal: pcal (generate monthly format calendars)
pcal:
pcal: PCAL is a multi-platform (Unix/Linux, DOS, DOS+DJGPP, Windows+Cygwin,
pcal: Amiga) program which generates annotated PostScript or HTML calendars
pcal: in a monthly or yearly format.
pcal:
pcal: It is usually run from the command line but there is an HTML/CGI
pcal: capability as well, to generate calendars (in either PostScript or
pcal: HTML format) from a web-browser interface.
pcal:
pcal: Homepage: http://pcal.sourceforge.net