games/fceux: Updated for version 2.1.4a.

Signed-off-by: Erik Hanson <erik@slackbuilds.org>
This commit is contained in:
M.Dinslage 2010-06-14 02:08:45 -05:00 committed by Erik Hanson
parent 7d19ca7995
commit 8386c63216
6 changed files with 48 additions and 30 deletions

BIN
games/fceux/Nintendo.png Normal file

Binary file not shown.

After

Width:  |  Height:  |  Size: 29 KiB

View file

@ -5,4 +5,4 @@ Famicom Disk System (FDS) emulator. It supports both PAL
(European) and NTSC (USA/JPN) modes. It supports both Windows (European) and NTSC (USA/JPN) modes. It supports both Windows
and SDL versions for cross compatibility. and SDL versions for cross compatibility.
This requires scons and zenity. This package requires scons (available at SBo)

View file

@ -0,0 +1,12 @@
diff -up fceu2.1.4a/SConstruct.00 fceu2.1.4a/SConstruct
--- fceu2.1.4a/SConstruct.00 2010-06-05 20:53:37.621706694 -0700
+++ fceu2.1.4a/SConstruct 2010-06-05 20:53:51.370717520 -0700
@@ -10,7 +10,7 @@ opts.AddVariables(
BoolVariable('DEBUG', 'Build with debugging symbols', 1),
BoolVariable('LUA', 'Enable Lua support', 1),
BoolVariable('NEWPPU', 'Enable new PPU core', 1),
- BoolVariable('CREATE_AVI', 'Enable avi creation support (SDL only)', 0),
+ BoolVariable('CREATE_AVI', 'Enable avi creation support (SDL only)', 1),
BoolVariable('LOGO', 'Enable a logoscreen when creating avis (SDL only)', '1'),
BoolVariable('GTK', 'Enable GTK2 GUI (SDL only)', 1),
BoolVariable('GTK_LITE', 'Enable GTK2 for dialogs only', 0)

View file

@ -5,16 +5,14 @@
# Written by M.Dinslage (daedra1980@gmail.com) # Written by M.Dinslage (daedra1980@gmail.com)
PRGNAM=fceux PRGNAM=fceux
VERSION=${VERSION:-2.1.3} VERSION=${VERSION:-2.1.4a}
BUILD=${BUILD:-4} BUILD=${BUILD:-1}
TAG=${TAG:-_SBo} TAG=${TAG:-_SBo}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then if [ -z "$ARCH" ]; then
case "$( uname -m )" in case "$( uname -m )" in
i?86) ARCH=i486 ;; i?86) ARCH=i486 ;;
arm*) ARCH=arm ;; arm*) ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;; *) ARCH=$( uname -m ) ;;
esac esac
fi fi
@ -38,14 +36,15 @@ else
LIBDIRSUFFIX="" LIBDIRSUFFIX=""
fi fi
set -e set -e # Exit on most errors
rm -rf $PKG rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT mkdir -p $TMP $PKG $OUTPUT
cd $TMP cd $TMP
rm -rf $PRGNAM-$VERSION rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.src.tar.bz2 tar xvf $CWD/$PRGNAM-$VERSION.src.tar.bz2
cd fceu cd fceu$VERSION
patch -p1 < $CWD/enable-recording.patch
chown -R root:root . chown -R root:root .
find . \ find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@ -54,34 +53,32 @@ find . \
-exec chmod 644 {} \; -exec chmod 644 {} \;
scons scons
#Dont use scons install, we'll take care of install ourselves
mkdir -p $PKG/usr/bin mkdir -p $PKG/usr/bin
install -m 0755 bin/fceux $PKG/usr/bin install -m 0755 bin/fceux $PKG/usr/bin
#install man pages
mkdir -p $PKG/usr/man/man6 mkdir -p $PKG/usr/man/man6
install -m 0644 documentation/fceux.6 $PKG/usr/man/man6 install -m 0644 documentation/fceux.6 $PKG/usr/man/man6
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/fceux
cp -a \
bin/fceux.chm COPYING INSTALL NEWS README-SDL TODO-PROJECT \
$PKG/usr/doc/$PRGNAM-$VERSION/fceux
# Build gfceux
cd $TMP/gfceux
python setup.py install --prefix=$PKG/usr
mkdir -p $PKG/usr/man/man1
mv $PKG/usr/share/man/man1/gfceux.1 $PKG/usr/man/man1
gzip -9 $PKG/usr/man/man?/*
rm -rf $PKG/usr/share/man
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/gfceux
cp ChangeLog COPYING INSTALL TODO \
$PKG/usr/doc/$PRGNAM-$VERSION/gfceux
# This is supposed to work with gtk+2-2.14.x as well...
sed -i "s%2.16%2.14%" $PKG/usr/share/gfceux/gfceux.glade
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
bin/fceux.chm COPYING INSTALL NEWS README-SDL TODO-PROJECT \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
#Add icon and application launcher
mkdir -p $PKG/usr/share/{applications,pixmaps}
cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
cat $CWD/Nintendo.png > $PKG/usr/share/pixmaps/Nintendo.png
mkdir -p $PKG/install mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh cat $CWD/doinst.sh > $PKG/install/doinst.sh

10
games/fceux/fceux.desktop Normal file
View file

@ -0,0 +1,10 @@
[Desktop Entry]
Encoding=UTF-8
Name=Fceux
GenericName=Nintendo/Famicon Emulator
Exec=fceux
Terminal=false
Type=Application
Categories=Application;Game;Emulator;
Icon=/usr/share/pixmaps/Nintendo.png
StartupNotify=false

View file

@ -1,11 +1,10 @@
PRGNAM="fceux" PRGNAM="fceux"
VERSION="2.1.3" VERSION="2.1.4a"
HOMEPAGE="http://fceux.com/web/home.html" HOMEPAGE="http://fceux.com/web/home.html"
DOWNLOAD="http://downloads.sourceforge.net/project/fceultra/Source%20Code/2.1.3%20src/fceux-2.1.3.src.tar.bz2" DOWNLOAD="http://downloads.sourceforge.net/fceultra/fceux-2.1.4a.src.tar.bz2"
MD5SUM="2943e3be634b4c1c1f5114e03c681af4" MD5SUM="a1252a888cdc8b2c42ae031211f2fad6"
DOWNLOAD_x86_64="" DOWNLOAD_x86_64=""
MD5SUM_x86_64="" MD5SUM_x86_64=""
MAINTAINER="M.Dinslage" MAINTAINER="M.Dinslage"
EMAIL="daedra1980@gmail.com" EMAIL="daedra1980@gmail.com"
APPROVED="dsomero" APPROVED="Erik Hanson"