system/virt-manager: Updated for version 3.2.0.

Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
This commit is contained in:
Robby Workman 2020-12-14 07:42:02 +01:00
parent f80a633fbf
commit 830a8dd0d9
3 changed files with 33 additions and 38 deletions

View file

@ -1,37 +1,21 @@
diff -Nur virt-manager-1.5.0.orig/virtinst/osdict.py virt-manager-1.5.0/virtinst/osdict.py
--- virt-manager-1.5.0.orig/virtinst/osdict.py 2018-01-27 14:57:20.000000000 -0600
+++ virt-manager-1.5.0/virtinst/osdict.py 2018-02-19 00:52:00.750416744 -0600
@@ -159,6 +159,7 @@
"rhel5": "rhel5.0",
"rhel6": "rhel6.0",
"rhel7": "rhel7.0",
+ "slackware": "slackware14.2",
"ubuntuhardy": "ubuntu8.04",
"ubuntuintrepid": "ubuntu8.10",
"ubuntujaunty": "ubuntu9.04",
@@ -373,7 +374,7 @@
# EOL date. So assume None == EOL, add some manual work arounds.
# We should fix this in a new libosinfo version, and then drop
# this hack
- if self._is_related_to(["fedora24", "rhel7.0", "debian6",
+ if self._is_related_to(["slackware14.2", "fedora24", "rhel7.0", "debian6",
"ubuntu13.04", "win8", "win2k12", "mageia5", "centos7.0"],
check_clones=False, check_derives=False):
return True
diff -Nur virt-manager-1.5.0.orig/virtinst/urlfetcher.py virt-manager-1.5.0/virtinst/urlfetcher.py
--- virt-manager-1.5.0.orig/virtinst/urlfetcher.py 2018-01-27 14:57:20.000000000 -0600
+++ virt-manager-1.5.0/virtinst/urlfetcher.py 2018-02-19 00:52:00.751416752 -0600
@@ -1379,6 +1379,43 @@
return False
diff -Nur virt-manager-2.2.0.orig/virtinst/install/urldetect.py virt-manager-2.2.0/virtinst/install/urldetect.py
--- virt-manager-2.2.0.orig/virtinst/install/urldetect.py 2019-06-17 00:20:11.000000000 -0500
+++ virt-manager-2.2.0/virtinst/install/urldetect.py 2019-07-03 02:14:35.978571412 -0500
@@ -466,6 +466,47 @@
return cache.treeinfo_family_regex(famregex)
+class SlackwareDistro(Distro):
+class SlackwareDistro(_DistroTree):
+ # slackware doesn't have installable URLs, so this is just for a
+ # mounted ISO
+ name = "Slackware"
+ urldistro = "slackware"
+ os_variant = "linux"
+
+ PRETTY_NAME = "Slackware"
+ matching_distros = ["slackware"]
+ _variant_prefix = "slackware"
+
+ _boot_iso_paths = []
+ _xen_kernel_paths = []
+
@ -62,6 +46,17 @@ diff -Nur virt-manager-1.5.0.orig/virtinst/urlfetcher.py virt-manager-1.5.0/virt
+ return False
+
+
# Build list of all *Distro classes
def _build_distro_list():
allstores = []
class _SuseDistro(_RHELDistro):
PRETTY_NAME = None
_suse_regex = []
diff -Nur virt-manager-2.2.0.orig/virtinst/osdict.py virt-manager-2.2.0/virtinst/osdict.py
--- virt-manager-2.2.0.orig/virtinst/osdict.py 2019-06-17 00:20:11.000000000 -0500
+++ virt-manager-2.2.0/virtinst/osdict.py 2019-07-03 02:11:59.208399622 -0500
@@ -146,6 +146,7 @@
"rhel5": "rhel5.0",
"rhel6": "rhel6.0",
"rhel7": "rhel7.0",
+ "slackware": "slackware14.2",
"ubuntuhardy": "ubuntu8.04",
"ubuntuintrepid": "ubuntu8.10",
"ubuntujaunty": "ubuntu9.04",

View file

@ -4,10 +4,10 @@
# Written by Ash Wiren ash@spooksoftware.com # Released to public domain.
# Modified by Zoran Stojakovic
# Lots of mods by rworkman for 1.x
# Lots of mods by rworkman for 1.x and (later) 2.x
PRGNAM=virt-manager
VERSION=${VERSION:-1.5.1}
VERSION=${VERSION:-3.2.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -56,8 +56,8 @@ find -L . \
# Add Slackware support
patch -p1 < $CWD/Add-Slackware-to-OS-choices.patch
python setup.py configure
python setup.py install --root=$PKG
python3 setup.py configure
python3 setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@ -68,7 +68,7 @@ for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; r
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
COPYING HACKING.md INSTALL.md NEWS.md README.md \
CONTRIBUTING.md COPYING INSTALL.md NEWS.md README.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

View file

@ -1,10 +1,10 @@
PRGNAM="virt-manager"
VERSION="1.5.1"
VERSION="3.2.0"
HOMEPAGE="http://virt-manager.org/"
DOWNLOAD="http://virt-manager.org/download/sources/virt-manager/virt-manager-1.5.1.tar.gz"
MD5SUM="32a929fd91fca9767730abaefb94661d"
DOWNLOAD="https://virt-manager.org/download/sources/virt-manager/virt-manager-3.2.0.tar.gz"
MD5SUM="a87507223c32d15eb12e1754404061dc"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libosinfo libvirt-glib libvirt-python gnome-python2-gconf tunctl ipaddr-py python-requests gtk-vnc spice-gtk vte3"
REQUIRES="gtksourceview3 libosinfo libvirt-glib libvirt-python gtk-vnc spice-gtk"
MAINTAINER="Robby Workman"
EMAIL="rworkman@slackbuilds.org"