mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
academic/Kst: patch to fix the path for H5Cpp.h file
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
bb97a3d11e
commit
8204b0bd3d
3 changed files with 37 additions and 4 deletions
|
@ -1,8 +1,27 @@
|
|||
#!/bin/bash
|
||||
|
||||
# Slackware build script for Kst
|
||||
# Based on Slackware 14.1 SlackBuild and AUR PKGBUILD for Kst
|
||||
# Written by Fellype do Nascimento <fellype(at)gmail.com>
|
||||
# last modification of this build script: 2014/12/10
|
||||
# Copyright 2014-2022 Fellype do Nascimento, Guaratingueta, Brazil
|
||||
# SBo team have contributed to the maintenance of this build script :)
|
||||
#
|
||||
# Based on Slackware 15.0 SlackBuild and AUR PKGBUILD for Kst
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
cd $(dirname $0) ; CWD=$(pwd)
|
||||
|
||||
|
@ -55,6 +74,9 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Fix the path for H5Cpp.h
|
||||
patch -p1 < $CWD/fix_hdf5_path.patch src/datasources/hdf5/hdf5.h
|
||||
|
||||
# Fix an issue with the newer cmake
|
||||
sed -i "s|else(GCC|elseif(GCC|" CMakeLists.txt || exit 1
|
||||
|
||||
|
|
|
@ -7,4 +7,4 @@ DOWNLOAD_x86_64=""
|
|||
MD5SUM_x86_64=""
|
||||
REQUIRES="scipy"
|
||||
MAINTAINER="Fellype do Nascimento"
|
||||
EMAIL="fellype(at)gmail.com"
|
||||
EMAIL="fellype (at) gmail (dot) com"
|
||||
|
|
11
academic/Kst/fix_hdf5_path.patch
Normal file
11
academic/Kst/fix_hdf5_path.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Kst-20220116_2b8e03e/src/datasources/hdf5/hdf5.h 2022-01-15 22:42:17.000000000 -0300
|
||||
+++ Kst-20220116_2b8e03e/src/datasources/hdf5/hdf5.h.new 2022-03-01 09:50:10.407808017 -0300
|
||||
@@ -18,7 +18,7 @@
|
||||
#include <dataplugin.h>
|
||||
|
||||
#include <QFileInfo>
|
||||
-#include <hdf5/serial/H5Cpp.h>
|
||||
+#include <H5Cpp.h>
|
||||
#include <exception>
|
||||
|
||||
#include "debug.h"
|
Loading…
Reference in a new issue