mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-07 20:27:02 +01:00
system/sandbox: Updated for version 2.14.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
3d6809694f
commit
81eb812b39
3 changed files with 8 additions and 25 deletions
|
@ -23,8 +23,8 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=sandbox
|
||||
VERSION=${VERSION:-2.13}
|
||||
BUILD=${BUILD:-2}
|
||||
VERSION=${VERSION:-2.14}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -69,11 +69,6 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Remove -nodefaultlibs to avoid compiler failures for 32-bit with slibtool.
|
||||
# GNU libtool swallows anything not on their list of "known" linker flags.
|
||||
# https://bugs.gentoo.org/657184
|
||||
patch -p1 < $CWD/slibtool.patch
|
||||
|
||||
autoreconf -fi
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
|
@ -90,12 +85,11 @@ make install DESTDIR=$PKG
|
|||
mv $PKG/etc/$PRGNAM.conf $PKG/etc/$PRGNAM.conf.new
|
||||
mv $PKG/etc/$PRGNAM.d/00default $PKG/etc/$PRGNAM.d/00default.new
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
|
||||
grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a AUTHORS COPYING ChangeLog.0 INSTALL NEWS README TODO \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a AUTHORS COPYING README $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="sandbox"
|
||||
VERSION="2.13"
|
||||
VERSION="2.14"
|
||||
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Sandbox"
|
||||
DOWNLOAD="https://gitweb.gentoo.org/proj/sandbox.git/snapshot/sandbox-2.13.tar.bz2"
|
||||
MD5SUM="827d62f76e531c77a6b90cf53be50f57"
|
||||
DOWNLOAD="https://gitweb.gentoo.org/proj/sandbox.git/snapshot/sandbox-2.14.tar.bz2"
|
||||
MD5SUM="a7a3f34ce12cd67e69326d13cc042362"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
diff -ur sandbox-2.13.orig/libsandbox/Makefile.am sandbox-2.13/libsandbox/Makefile.am
|
||||
--- sandbox-2.13.orig/libsandbox/Makefile.am 2018-02-19 05:50:18.000000000 -0000
|
||||
+++ sandbox-2.13/libsandbox/Makefile.am 2018-06-03 12:58:04.270611236 -0000
|
||||
@@ -20,7 +20,6 @@
|
||||
# and destructor will not be executed ...
|
||||
libsandbox_la_LDFLAGS = \
|
||||
-no-undefined \
|
||||
- -nodefaultlibs \
|
||||
-avoid-version \
|
||||
$(LDFLAG_VER),libsandbox.map
|
||||
libsandbox_la_SOURCES = \
|
Loading…
Reference in a new issue