mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
office/org-mode: Updated for version 7.01g.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
This commit is contained in:
parent
e748bd10dc
commit
81c3fb0b8f
5 changed files with 62 additions and 47 deletions
|
@ -1,25 +0,0 @@
|
|||
--- org-6.34c/Makefile 2010-01-18 02:10:45.000000000 +0300
|
||||
+++ org-6.34c/Makefile.2 2010-01-19 04:11:10.324503966 +0300
|
||||
@@ -14,13 +14,13 @@
|
||||
EMACS=emacs
|
||||
|
||||
# Where local software is found
|
||||
-prefix=/usr/local
|
||||
+prefix=/usr
|
||||
|
||||
# Where local lisp files go.
|
||||
lispdir = $(prefix)/share/emacs/site-lisp
|
||||
|
||||
# Where info files go.
|
||||
-infodir = $(prefix)/share/info
|
||||
+infodir = $(prefix)/info
|
||||
|
||||
##----------------------------------------------------------------------
|
||||
## YOU MAY NEED TO EDIT THESE
|
||||
@@ -381,4 +381,4 @@
|
||||
lisp/org-vm.elc: lisp/org.el
|
||||
lisp/org-w3m.elc: lisp/org.el
|
||||
lisp/org-wl.elc: lisp/org.el
|
||||
-lisp/org-xoxo.elc: lisp/org-exp.el
|
||||
\ No newline at end of file
|
||||
+lisp/org-xoxo.elc: lisp/org-exp.el
|
|
@ -1,11 +0,0 @@
|
|||
--- org-6.34c/Makefile 2010-01-19 04:12:47.314750357 +0300
|
||||
+++ org-6.34c/Makefile.2 2010-01-19 04:11:53.197796741 +0300
|
||||
@@ -14,7 +14,7 @@
|
||||
EMACS=emacs
|
||||
|
||||
# Where local software is found
|
||||
-prefix=/usr
|
||||
+prefix=$(PKG)/usr
|
||||
|
||||
# Where local lisp files go.
|
||||
lispdir = $(prefix)/share/emacs/site-lisp
|
51
office/org-mode/Makefile.patch
Normal file
51
office/org-mode/Makefile.patch
Normal file
|
@ -0,0 +1,51 @@
|
|||
--- org-7.01/Makefile 2010-07-19 10:27:15.000000000 +0400
|
||||
+++ Makefile.2 2010-07-20 01:11:21.449263023 +0400
|
||||
@@ -14,13 +14,14 @@
|
||||
EMACS=emacs
|
||||
|
||||
# Where local software is found
|
||||
-prefix=/usr/local
|
||||
+# prefix=/usr/local
|
||||
+prefix=$(DESTDIR)
|
||||
|
||||
# Where local lisp files go.
|
||||
lispdir = $(prefix)/share/emacs/site-lisp
|
||||
|
||||
# Where info files go.
|
||||
-infodir = $(prefix)/share/info
|
||||
+infodir = $(prefix)/info
|
||||
|
||||
##----------------------------------------------------------------------
|
||||
## YOU MAY NEED TO EDIT THESE
|
||||
@@ -183,6 +184,7 @@
|
||||
|
||||
install: install-lisp
|
||||
|
||||
+#doc: doc/org.html doc/org.pdf doc/orgcard.pdf doc/orgcard_letter.pdf doc/orgguide.pdf
|
||||
doc: doc/org.html doc/org.pdf doc/orgcard.pdf doc/orgcard_letter.pdf doc/orgguide.pdf
|
||||
|
||||
p:
|
||||
@@ -232,13 +234,13 @@
|
||||
|
||||
doc/org.html: doc/org.texi
|
||||
(cd doc; $(TEXI2HTML) --no-split -o org.html org.texi)
|
||||
- UTILITIES/manfull.pl doc/org.html
|
||||
+# UTILITIES/manfull.pl doc/org.html
|
||||
|
||||
doc/orgcard.pdf: doc/orgcard.tex
|
||||
(cd doc; pdftex orgcard.tex)
|
||||
|
||||
-doc/orgcard.txt: doc/orgcard.tex
|
||||
- (cd doc; perl ../UTILITIES/orgcard2txt.pl orgcard.tex > orgcard.txt)
|
||||
+#doc/orgcard.txt: doc/orgcard.tex
|
||||
+# (cd doc; perl ../UTILITIES/orgcard2txt.pl orgcard.tex > orgcard.txt)
|
||||
|
||||
doc/orgcard_letter.tex: doc/orgcard.tex
|
||||
perl -pe 's/\\pdflayout=\(0l\)/\\pdflayout=(1l)/' \
|
||||
@@ -430,4 +432,4 @@
|
||||
lisp/org-vm.elc: lisp/org.el
|
||||
lisp/org-w3m.elc: lisp/org.el
|
||||
lisp/org-wl.elc: lisp/org.el
|
||||
-lisp/org-xoxo.elc: lisp/org-exp.el
|
||||
\ В конце файла нет новой строки
|
||||
+lisp/org-xoxo.elc: lisp/org-exp.el
|
|
@ -5,7 +5,7 @@
|
|||
# Written by Valeriy Timchenko <ValTimchenko@gmail.com>
|
||||
|
||||
PRGNAM=org-mode
|
||||
VERSION=${VERSION:-6.36c}
|
||||
VERSION=${VERSION:-7.01g}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -53,11 +53,11 @@ find . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
patch Makefile $CWD/Makefile.1.patch
|
||||
make
|
||||
patch Makefile $CWD/Makefile.2.patch
|
||||
PKG=$PKG make install
|
||||
PKG=$PKG make install-info
|
||||
patch Makefile $CWD/Makefile.patch
|
||||
DESTDIR=/usr make
|
||||
DESTDIR=/usr make doc
|
||||
DESTDIR=$PKG/usr make install
|
||||
DESTDIR=$PKG/usr PKG=$PKG make install-info
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
@ -66,8 +66,8 @@ rm -f $PKG/usr/info/dir
|
|||
gzip -9 $PKG/usr/info/*
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a ChangeLog Changes.org README request-assign-future.txt \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a Changes.org README request-assign-future.txt \
|
||||
doc/*.pdf doc/*.html $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="org-mode"
|
||||
VERSION="6.36c"
|
||||
VERSION="7.01g"
|
||||
HOMEPAGE="http://orgmode.org"
|
||||
DOWNLOAD="http://orgmode.org/org-6.36c.tar.gz"
|
||||
MD5SUM="13d7850aab456406ed6781d4d98e5cad"
|
||||
DOWNLOAD="http://orgmode.org/org-7.01g.tar.gz"
|
||||
MD5SUM="a06a2377779252a87e1e9876db3a042f"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Valeriy Timchenko"
|
||||
|
|
Loading…
Reference in a new issue