mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
accessibility/flite: Updated for version 2.2.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
eac08384c2
commit
81b7beb0b4
7 changed files with 95 additions and 109 deletions
|
@ -11,10 +11,5 @@ http://festvox.org/flite/packed/flite-2.0/voices/ and place them
|
|||
in the same directory as the SlackBuild. They will be installed in
|
||||
/usr/share/flite/, and can be used with the flite's -voice option.
|
||||
|
||||
The flite API documentation is available as a GNU info document,
|
||||
via "info flite". The same docs are available as HTML in
|
||||
/usr/doc/flite-$VERSION/html if you have texi2html installed from SBo.
|
||||
|
||||
The API docs are only needed for developers who intend to write code that
|
||||
uses flite as a library. If you have build errors that mention texi2html,
|
||||
try 'export HTML=no' in the script's environment.
|
||||
The flite API documentation is available as a GNU info document, via
|
||||
"info flite", or as HTML in "/usr/doc/flite-$VERSION/html".
|
||||
|
|
|
@ -1,36 +0,0 @@
|
|||
diff -Naur flite-2.0.0-release/config/common_make_rules flite-2.0.0-release.new/config/common_make_rules
|
||||
--- flite-2.0.0-release/config/common_make_rules 2012-01-15 07:06:52.000000000 -0800
|
||||
+++ flite-2.0.0-release.new/config/common_make_rules 2017-06-14 00:41:06.080962503 -0700
|
||||
@@ -68,7 +68,7 @@
|
||||
|
||||
FLITELIBS = $(BUILDDIR)/lib/libflite.a
|
||||
FLITELIBFLAGS = -L$(BUILDDIR)/lib -lflite
|
||||
-LDFLAGS += -lm $(AUDIOLIBS) $(OTHERLIBS)
|
||||
+LDLIBS += -lm $(AUDIOLIBS) $(OTHERLIBS)
|
||||
|
||||
FULLOBJS = $(OBJS:%=$(OBJDIR)/%)
|
||||
ifdef SHFLAGS
|
||||
@@ -123,7 +123,7 @@
|
||||
@ rm -rf shared_os && mkdir shared_os
|
||||
@ rm -f $@ $@.${PROJECT_VERSION} $@.${PROJECT_SHLIB_VERSION}
|
||||
@ (cd shared_os && ar x ../$<)
|
||||
- @ (cd shared_os && $(CC) -shared -Wl,-soname,`basename $@`.${PROJECT_SHLIB_VERSION} -o ../$@.${PROJECT_VERSION} *.os)
|
||||
+ @ (cd shared_os && $(CC) ${LDFLAGS} -shared -Wl,-soname,`basename $@`.${PROJECT_SHLIB_VERSION} -o ../$@.${PROJECT_VERSION} *.os $(LDLIBS))
|
||||
@ (cd $(LIBDIR) && ln -s `basename $@.${PROJECT_VERSION}` `basename $@.${PROJECT_SHLIB_VERSION}` )
|
||||
@ (cd $(LIBDIR) && ln -s `basename $@.${PROJECT_SHLIB_VERSION}` `basename $@` )
|
||||
@ rm -rf shared_os
|
||||
diff -Naur flite-2.0.0-release/tools/Makefile flite-2.0.0-release.new/tools/Makefile
|
||||
--- flite-2.0.0-release/tools/Makefile 2014-08-22 06:06:18.000000000 -0700
|
||||
+++ flite-2.0.0-release.new/tools/Makefile 2017-06-14 00:23:10.081062041 -0700
|
||||
@@ -67,9 +67,9 @@
|
||||
LOCAL_CLEAN = $(BINDIR)/find_sts $(BINDIR)/flite_sort $(TOP)/bin
|
||||
|
||||
$(BINDIR)/find_sts: find_sts_main.o $(FLITELIBS)
|
||||
- $(CC) $(CFLAGS) -o $@ find_sts_main.o $(FLITELIBFLAGS) $(LDFLAGS)
|
||||
+ $(CC) $(CFLAGS) ${LDFLAGS} -o $@ find_sts_main.o $(FLITELIBFLAGS) $(LDLIBS)
|
||||
$(BINDIR)/flite_sort: flite_sort_main.o $(FLITELIBS)
|
||||
- $(CC) $(CFLAGS) -o $@ flite_sort_main.o $(FLITELIBFLAGS) $(LDFLAGS)
|
||||
+ $(CC) $(CFLAGS) ${LDFLAGS} -o $@ flite_sort_main.o $(FLITELIBFLAGS) $(LDLIBS)
|
||||
makescripts:
|
||||
@ cp -p $(SCRIPTS) $(TOP)/bin
|
||||
|
|
@ -5,6 +5,17 @@
|
|||
# Now maintained by B. Watson (yalhcru@gmail.com), original author is MIA.
|
||||
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
|
||||
|
||||
# 20210802 bkw: update for v2.2
|
||||
# - remove texi2html dep, as upstream now uses texi2any
|
||||
# - related to above, always build the HTML docs
|
||||
# - add flite_time and t2p to usr/bin. Also man pages for same,
|
||||
# from Debian.
|
||||
# - Note to self: the shared library versioning is weird looking. The
|
||||
# soname version is 1, same as FLITE_PROJECT_SHLIB_VERSION
|
||||
# in flite_version.h, and the files are installed as
|
||||
# libfliteblah.2.2. So we end up with symlinks libfliteblah.so.1 =>
|
||||
# libfliteblah.2.2, which is actually correct.
|
||||
|
||||
# 20181114 bkw:
|
||||
# - BUILD=2
|
||||
# - add WTFPL to script
|
||||
|
@ -45,8 +56,8 @@
|
|||
cd $(dirname $0) ; CWD=$(pwd)
|
||||
|
||||
PRGNAM=flite
|
||||
VERSION=${VERSION:-2.1}
|
||||
BUILD=${BUILD:-2}
|
||||
VERSION=${VERSION:-2.2}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
|
||||
|
@ -58,9 +69,6 @@ if [ -z "$ARCH" ]; then
|
|||
esac
|
||||
fi
|
||||
|
||||
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
||||
# the name of the created package would be, and then exit. This information
|
||||
# could be useful to other scripts.
|
||||
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
||||
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
|
||||
exit 0
|
||||
|
@ -89,18 +97,15 @@ set -e
|
|||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION-release
|
||||
tar xvf $CWD/$PRGNAM-$VERSION-release.tar.bz2
|
||||
cd $PRGNAM-$VERSION-release
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
|
||||
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
|
||||
|
||||
# fix LDLAGS to allow external programs to find libflite.so
|
||||
patch -p1 < $CWD/flite-ldflags-fix.patch
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
CFLAGS="$SLKCFLAGS -Wl,-s" \
|
||||
CXXFLAGS="$SLKCFLAGS -Wl,-s" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
|
@ -110,67 +115,50 @@ CXXFLAGS="$SLKCFLAGS" \
|
|||
--enable-shared \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
# Fix builds with SBo standalone texi2html. The -number option works
|
||||
# with Slackware's ancient texi2html (from t/tetex), but would have to
|
||||
# be --number-sections in the newer SBo texi2html. It turns out section
|
||||
# numbering is enabled by default in both versions, so get rid of it...
|
||||
sed -i '/texi2html/s,-number,,' doc/Makefile
|
||||
|
||||
make
|
||||
make install prefix=$PKG/usr INSTALLLIBDIR=$PKG/usr/lib${LIBDIRSUFFIX}
|
||||
strip $PKG/usr/lib$LIBDIRSUFFIX/*.so.*.*
|
||||
|
||||
# --disable-static is accepted by configure but totally ignored, so:
|
||||
rm -rf $PKG/usr/lib$LIBDIRSUFFIX/*.a
|
||||
|
||||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
# flite.1 written by SlackBuild author. The rest are from Debian.
|
||||
mkdir -p $PKG/usr/man/man1
|
||||
for i in $CWD/man/*.1; do
|
||||
gzip -9c < $i > $PKG/usr/man/man1/"$( basename "$i" )".gz
|
||||
done
|
||||
|
||||
# the Debian package includes these 2 binaries that don't get installed
|
||||
# by 'make install'. They look useful enough, so:
|
||||
install -s -m0755 bin/t2p bin/flite_time $PKG/usr/bin
|
||||
|
||||
# include any *.flitevox files the user downloaded.
|
||||
for file in $CWD/*.flitevox; do
|
||||
[ -e "$file" ] && \
|
||||
mkdir -p $PKG/usr/share/$PRGNAM && \
|
||||
cat $file > $PKG/usr/share/$PRGNAM/"$( basename "$file" )" &&
|
||||
cat $file > $PKG/usr/share/$PRGNAM/"$( basename "$file" )" && \
|
||||
EXTRA=yes
|
||||
done
|
||||
|
||||
# -current's tex is texlive, which lacks texi2html. Also lots of
|
||||
# users prefer to run texlive on 14.2, which has the same problem.
|
||||
# So only try to build the HTML docs if (a) the user forces with
|
||||
# HTML=yes, or (b) if HTML=auto (the default) and texi2html is
|
||||
# actually found on the $PATH.
|
||||
HTML="${HTML:-auto}"
|
||||
|
||||
if [ "$HTML" = "auto" ]; then
|
||||
if which texi2html 2>/dev/null; then
|
||||
HTML="yes"
|
||||
else
|
||||
HTML="no"
|
||||
fi
|
||||
fi
|
||||
|
||||
# build the docs. NB don't replace subshells with "cd dir" and
|
||||
# "cd -", as they don't nest.
|
||||
HTMLDOC=""
|
||||
if [ "$HTML" = "yes" ]; then
|
||||
HTMLDOC="doc/html"
|
||||
( cd doc
|
||||
# build the HTML docs.
|
||||
make $PRGNAM.html
|
||||
( cd html
|
||||
|
||||
# Upstream hardlinks index.html, use a symlink instead.
|
||||
rm -f index.html
|
||||
ln -s ${PRGNAM}_toc.html index.html
|
||||
|
||||
# Also, we don't ship the PDF doc, so link to upstream's.
|
||||
# Fix link to source package.
|
||||
sed -i \
|
||||
-e 's,HREF="flite.pdf",HREF="http://www.festvox.org/flite/doc/flite.pdf",' \
|
||||
-e 's,\.tar\.gz,.tar.bz2,g' \
|
||||
${PRGNAM}_toc.html
|
||||
)
|
||||
( cd doc
|
||||
# build the HTML docs.
|
||||
make $PRGNAM.html
|
||||
( cd html
|
||||
|
||||
# Upstream hardlinks index.html, use a symlink instead.
|
||||
rm -f index.html
|
||||
ln -s ${PRGNAM}_toc.html index.html
|
||||
|
||||
# Also, we don't ship the PDF doc, so link to upstream's.
|
||||
# Fix link to source package.
|
||||
sed -i \
|
||||
-e 's,HREF="flite.pdf",HREF="http://www.festvox.org/flite/doc/flite.pdf",' \
|
||||
-e 's,\.tar\.gz,.tar.bz2,g' \
|
||||
${PRGNAM}_toc.html
|
||||
)
|
||||
fi
|
||||
)
|
||||
|
||||
# 20181114 bkw: always build the GNU info docs.
|
||||
( cd doc
|
||||
|
@ -180,14 +168,10 @@ fi
|
|||
)
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a ACKNOWLEDGEMENTS COPYING README* $HTMLDOC doc/*.txt doc/alice \
|
||||
cp -a ACKNOWLEDGEMENTS COPYING README* doc/html doc/*.txt doc/alice \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
# man page written by SlackBuild author.
|
||||
mkdir -p $PKG/usr/man/man1
|
||||
gzip -9c < $CWD/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
|
||||
|
||||
mkdir -p $PKG/install
|
||||
|
||||
# slack-desc gets a note if extra voices are included.
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="flite"
|
||||
VERSION="2.1"
|
||||
VERSION="2.2"
|
||||
HOMEPAGE="http://festvox.org/"
|
||||
DOWNLOAD="http://festvox.org/flite/packed/flite-2.1/flite-2.1-release.tar.bz2"
|
||||
MD5SUM="915ac91068fc962f4a0e8aa26164cc8a"
|
||||
DOWNLOAD="https://github.com/festvox/flite/archive/v2.2/flite-2.2.tar.gz"
|
||||
MD5SUM="31f84ece0078906780f07942c0cd978c"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="texi2html"
|
||||
REQUIRES=""
|
||||
MAINTAINER="B. Watson"
|
||||
EMAIL="yalhcru@gmail.com"
|
||||
|
|
24
accessibility/flite/man/flite_time.1
Normal file
24
accessibility/flite/man/flite_time.1
Normal file
|
@ -0,0 +1,24 @@
|
|||
.TH FLITE_TIME 1 "February 25, 2003"
|
||||
.SH NAME
|
||||
flite_time \- A talking clock based on a limited-domain voice
|
||||
.SH SYNOPSIS
|
||||
.B flite_time
|
||||
.I HH:MM
|
||||
.SH DESCRIPTION
|
||||
.B flite_time
|
||||
is a example talking clock based on a limited domain
|
||||
voice from Festival Lite.
|
||||
|
||||
.SH OPTIONS
|
||||
Specify the time you want to have announced at the
|
||||
command-line using the format HH:MM.
|
||||
|
||||
.SH EXAMPLES
|
||||
.IP "flite_time `date +%H:%M`" 4
|
||||
Announce the current time.
|
||||
|
||||
.SH SEE ALSO
|
||||
.BR flite (1), " " festival (1)
|
||||
.SH AUTHOR
|
||||
This manual page was written by Mario Lang <mlang@debian.org>,
|
||||
for the Debian GNU/Linux system (but may be used by others).
|
19
accessibility/flite/man/t2p.1
Normal file
19
accessibility/flite/man/t2p.1
Normal file
|
@ -0,0 +1,19 @@
|
|||
.TH T2P 1 "February 25, 2003"
|
||||
.SH NAME
|
||||
t2p \- A text to phoneme converter
|
||||
.SH SYNOPSIS
|
||||
.B t2p
|
||||
"word word word"
|
||||
.SH DESCRIPTION
|
||||
.B t2p
|
||||
converts text specified on the command-line into US english phonemes.
|
||||
Output is given to STDOUT.
|
||||
|
||||
.SH OPTIONS
|
||||
No options.
|
||||
|
||||
.SH SEE ALSO
|
||||
.BR flite (1), " " flite_time (1), " " festival (1)
|
||||
.SH AUTHOR
|
||||
This manual page was written by Mario Lang <mlang@debian.org>,
|
||||
for the Debian GNU/Linux system (but may be used by others).
|
Loading…
Reference in a new issue