mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
gis/gpsbabel: Fix build against Qt5.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
8ac72611fd
commit
816be12bf3
2 changed files with 62 additions and 0 deletions
58
gis/gpsbabel/build-fix.patch
Normal file
58
gis/gpsbabel/build-fix.patch
Normal file
|
@ -0,0 +1,58 @@
|
|||
diff -wbBur gpsbabel-1.5.4/tef_xml.cc gpsbabel-1.5.4.my/tef_xml.cc
|
||||
--- gpsbabel-1.5.4/tef_xml.cc 2017-01-02 08:05:19.000000000 +0300
|
||||
+++ gpsbabel-1.5.4.my/tef_xml.cc 2017-02-16 16:20:22.788961096 +0300
|
||||
@@ -72,11 +72,11 @@
|
||||
bool valid = false;
|
||||
|
||||
foreach(QXmlStreamAttribute attr, *attrv) {
|
||||
- if (attr.name().compare("Comment", Qt::CaseInsensitive) == 0) {
|
||||
- if (attr.value().compare("TourExchangeFormat", Qt::CaseInsensitive) == 0) {
|
||||
+ if (attr.name().compare((QString&)"Comment", Qt::CaseInsensitive) == 0) {
|
||||
+ if (attr.value().compare((QString&)"TourExchangeFormat", Qt::CaseInsensitive) == 0) {
|
||||
valid = true;
|
||||
}
|
||||
- } else if (attr.name().compare("Version", Qt::CaseInsensitive) == 0) {
|
||||
+ } else if (attr.name().compare((QString&)"Version", Qt::CaseInsensitive) == 0) {
|
||||
version = attr.value().toString().toDouble();
|
||||
}
|
||||
}
|
||||
@@ -95,9 +95,9 @@
|
||||
{
|
||||
route = route_head_alloc();
|
||||
foreach(QXmlStreamAttribute attr, *attrv) {
|
||||
- if (attr.name().compare("Name", Qt::CaseInsensitive) == 0) {
|
||||
+ if (attr.name().compare((QString&)"Name", Qt::CaseInsensitive) == 0) {
|
||||
route->rte_name = attr.value().toString().trimmed();
|
||||
- } else if (attr.name().compare("Software", Qt::CaseInsensitive) == 0) {
|
||||
+ } else if (attr.name().compare((QString&)"Software", Qt::CaseInsensitive) == 0) {
|
||||
route->rte_desc = attr.value().toString().trimmed();
|
||||
}
|
||||
}
|
||||
@@ -248,20 +248,20 @@
|
||||
QString attrstr = attr.value().toString();
|
||||
QByteArray attrtext = attrstr.toUtf8();
|
||||
|
||||
- if (attr.name().compare("SegDescription", Qt::CaseInsensitive) == 0) {
|
||||
+ if (attr.name().compare((QString&)"SegDescription", Qt::CaseInsensitive) == 0) {
|
||||
wpt_tmp->shortname = attrstr.trimmed();
|
||||
- } else if (attr.name().compare("PointDescription", Qt::CaseInsensitive) == 0) {
|
||||
+ } else if (attr.name().compare((QString&)"PointDescription", Qt::CaseInsensitive) == 0) {
|
||||
wpt_tmp->description = attrstr.trimmed();
|
||||
- } else if (attr.name().compare("ViaStation", Qt::CaseInsensitive) == 0 &&
|
||||
- attr.value().compare("true", Qt::CaseInsensitive) == 0) {
|
||||
+ } else if (attr.name().compare((QString&)"ViaStation", Qt::CaseInsensitive) == 0 &&
|
||||
+ attr.value().compare((QString&)"true", Qt::CaseInsensitive) == 0) {
|
||||
wpt_tmp->wpt_flags.fmt_use = 1; /* only a flag */
|
||||
|
||||
/* new in TEF V2 */
|
||||
- } else if (attr.name().compare("Instruction", Qt::CaseInsensitive) == 0) {
|
||||
+ } else if (attr.name().compare((QString&)"Instruction", Qt::CaseInsensitive) == 0) {
|
||||
wpt_tmp->description = attrstr.trimmed();
|
||||
- } else if (attr.name().compare("Altitude", Qt::CaseInsensitive) == 0) {
|
||||
+ } else if (attr.name().compare((QString&)"Altitude", Qt::CaseInsensitive) == 0) {
|
||||
wpt_tmp->altitude = attrstr.toDouble();
|
||||
- } else if (attr.name().compare("TimeStamp", Qt::CaseInsensitive) == 0) {
|
||||
+ } else if (attr.name().compare((QString&)"TimeStamp", Qt::CaseInsensitive) == 0) {
|
||||
/* nothing for the moment */
|
||||
}
|
||||
}
|
|
@ -89,6 +89,10 @@ sed -i 's|QApplication::applicationDirPath()|"/usr/share/gpsbabel"|' gui/mainwin
|
|||
# Thanks to Gentoo.
|
||||
sed -i '/AC_CHECK_LIB(\[z\], \[gzopen\])/aAC_CHECK_LIB([minizip], [zipOpen64])' configure.in
|
||||
sed -i 's|"zlib/contrib/minizip/zip.h"|<minizip/zip.h>|' src/core/ziparchive.cc src/core/ziparchive.h
|
||||
|
||||
# Patched to build against Qt5
|
||||
patch -p1 < $CWD/build-fix.patch
|
||||
|
||||
autoreconf -vif
|
||||
|
||||
./configure \
|
||||
|
|
Loading…
Reference in a new issue