mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-20 19:41:34 +01:00
network/offlineimap: Updated for version 6.3.4.
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
This commit is contained in:
parent
d884f9fa57
commit
81198616f6
6 changed files with 67 additions and 16 deletions
|
@ -1,4 +1,8 @@
|
|||
OfflineIMAP is a tool to sync remote imap mailboxes and particularly
|
||||
useful in syncing mailboxes between two imap servers.
|
||||
OfflineIMAP is a tool to sync remote imap mailboxes
|
||||
and particularly useful in syncing mailboxes between
|
||||
two imap servers.
|
||||
|
||||
This requires docutils.
|
||||
Requires: docutils (available on SBo)
|
||||
|
||||
NOTE: docutils is a new dependency with version >= 6.3.2,
|
||||
needed for generating documentation and man page.
|
||||
|
|
|
@ -1,3 +1,4 @@
|
|||
#!/bin/sh
|
||||
config() {
|
||||
NEW="$1"
|
||||
OLD="$(dirname $NEW)/$(basename $NEW .new)"
|
||||
|
@ -10,4 +11,5 @@ config() {
|
|||
fi
|
||||
# Otherwise, we leave the .new copy for the admin to consider...
|
||||
}
|
||||
|
||||
config etc/offlineimap.conf.new
|
||||
|
|
|
@ -24,9 +24,9 @@
|
|||
# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
|
||||
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
SRCNAM="nicolas33-offlineimap-v6.3.3-0-g3b09695"
|
||||
SRCNAM="nicolas33-offlineimap-v6.3.4-0-g61e50b3"
|
||||
PRGNAM="offlineimap"
|
||||
VERSION=${VERSION:-6.3.3}
|
||||
VERSION=${VERSION:-6.3.4}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -49,7 +49,7 @@ rm -fr $TMP/$PRGNAM-$VERSION $PKG
|
|||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
tar xvf $CWD/$SRCNAM.tar.gz
|
||||
mv nicolas33-offlineimap-cf325d5 $PRGNAM-$VERSION
|
||||
mv nicolas33-offlineimap-94450e9 $PRGNAM-$VERSION
|
||||
cd $PRGNAM-$VERSION
|
||||
|
||||
chown -R root.root .
|
||||
|
@ -59,18 +59,33 @@ find . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
mkdir -p $PKG/usr/{man/man1,doc/$PRGNAM-$VERSION} $PKG/etc
|
||||
python setup.py install --root=$PKG
|
||||
make doc man
|
||||
### fix the manual file to build correctly
|
||||
patch -p0 < $CWD/patches/manual.rst.patch
|
||||
|
||||
### Patch makefile to disable building dev docs
|
||||
patch -p0 < $CWD/patches/doc_generation_fix.patch
|
||||
|
||||
### build and install
|
||||
python setup.py install --root=$PKG
|
||||
|
||||
### make and install docs
|
||||
make doc
|
||||
mkdir -p $PKG/usr/{man/man1,doc/$PRGNAM-$VERSION/html} $PKG/etc
|
||||
|
||||
### install config file
|
||||
install -m 0644 -D $PRGNAM.conf $PKG/etc/$PRGNAM.conf.new
|
||||
|
||||
install -m 0644 $PRGNAM.1 $PKG/usr/man/man1
|
||||
### make and install man page and html docs
|
||||
( cd docs; make man && make html )
|
||||
|
||||
install -m 0644 docs/$PRGNAM.1 $PKG/usr/man/man1
|
||||
gzip -9 $PKG/usr/man/man1/$PRGNAM.1
|
||||
|
||||
cp -a \
|
||||
COPYING COPYRIGHT readme.html $PRGNAM.conf* docs/*.html \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
COPYING COPYRIGHT $PRGNAM.conf* \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a readme.html docs/FAQ.html docs/INSTALL.html docs/MANUAL.html \
|
||||
docs/UPGRADE.html $PKG/usr/doc/$PRGNAM-$VERSION/html
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="offlineimap"
|
||||
VERSION="6.3.3"
|
||||
VERSION="6.3.4"
|
||||
HOMEPAGE="https://github.com/nicolas33/offlineimap"
|
||||
DOWNLOAD="https://github.com/nicolas33/offlineimap/tarball/v6.3.3"
|
||||
MD5SUM="cdccc3f22011e4fefd6e1ba36e0bae66"
|
||||
DOWNLOAD="https://github.com/nicolas33/offlineimap/tarball/v6.3.4"
|
||||
MD5SUM="84c42088ffcc7092473fef76e17c082b"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Nishant Limbachia"
|
||||
EMAIL="nishant@mnspace.net"
|
||||
APPROVED="rworkman"
|
||||
APPROVED="Erik Hanson"
|
||||
|
|
10
network/offlineimap/patches/doc_generation_fix.patch
Normal file
10
network/offlineimap/patches/doc_generation_fix.patch
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- Makefile.orig 2011-09-09 16:00:42.784605863 -0500
|
||||
+++ Makefile 2011-09-09 16:00:50.423804120 -0500
|
||||
@@ -44,7 +44,6 @@
|
||||
@$(MAKE) -C docs man
|
||||
|
||||
doc:
|
||||
- @$(MAKE) -C docs
|
||||
$(RST2HTML) README.rst readme.html
|
||||
$(RST2HTML) SubmittingPatches.rst SubmittingPatches.html
|
||||
$(RST2HTML) Changelog.rst Changelog.html
|
20
network/offlineimap/patches/manual.rst.patch
Normal file
20
network/offlineimap/patches/manual.rst.patch
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- docs/MANUAL.rst.orig 2011-08-10 14:44:58.000000000 -0500
|
||||
+++ docs/MANUAL.rst 2011-09-09 15:43:23.813649765 -0500
|
||||
@@ -380,7 +380,7 @@
|
||||
default.
|
||||
|
||||
Certificate checking
|
||||
-^^^^^^^^^^^^^^^^^^^^
|
||||
+====================
|
||||
|
||||
Unfortunately, by default we will not verify the certificate of an IMAP
|
||||
TLS/SSL server we connect to, so connecting by SSL is no guarantee
|
||||
@@ -397,7 +397,7 @@
|
||||
certificate and CA certificate.
|
||||
|
||||
StartTLS
|
||||
-^^^^^^^^
|
||||
+========
|
||||
|
||||
If you have not configured your account to connect via SSL anyway,
|
||||
OfflineImap will still attempt to set up an SSL connection via the
|
Loading…
Reference in a new issue