system/conky: Patch for gcc >= 7.x.

Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
This commit is contained in:
Matteo Bernardini 2017-05-05 23:18:40 +02:00 committed by Robby Workman
parent 4914880aef
commit 7f2c7f6eb8
2 changed files with 14 additions and 0 deletions

View file

@ -0,0 +1,11 @@
diff -Naur conky-1.10.6.orig/src/luamm.hh conky-1.10.6/src/luamm.hh
--- conky-1.10.6.orig/src/luamm.hh 2016-12-04 16:13:57.000000000 +0100
+++ conky-1.10.6/src/luamm.hh 2017-05-05 12:44:37.525676651 +0200
@@ -27,6 +27,7 @@
#include <mutex>
#include <exception>
#include <stdexcept>
+#include <functional>
#include <string>
#include <lua.hpp>

View file

@ -87,6 +87,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fix for the newer gcc
patch -p1 < $CWD/conky-1.10.6-gcc7.patch
# fix MANDIR
sed -i 's,share/man/man1,man/man1,g' CMakeLists.txt